Skip to content

Commit

Permalink
dev-lang/squirrel: bump up to 3.1
Browse files Browse the repository at this point in the history
While at it use long names for interpreter:
    /usr/bin/sq -> /usr/bin/squirrel3
    /usr/lib/libsquirrel.so -> /usr/lib/libsquirrel3.so

Package-Manager: portage-2.3.0
  • Loading branch information
Sergei Trofimovich committed Aug 10, 2016
1 parent 955bc8b commit 8041183
Show file tree
Hide file tree
Showing 3 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/squirrel/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST squirrel-3.1.tar.gz 175612 SHA256 51942b8638a97b673e34ecf3ca50304996fa99bbdbfa7fe93d9744e6769b2f95 SHA512 8aec059c801a8f6a1ddb9585cebd51457cfd43743cb0b03494e022fd47392e7b4b88e4703f184f4dcba2be8c0fb756e9b260e2f230e1bd92b37cdcb86d4f1141 WHIRLPOOL f1b7b1c96c0d0e8fd7f1c27f05684bacb803a33fd5dbe2bd767b955e2fd747c83a7ef666bc10f1b6ab7fa51fe6df46551dec947e77c862855fee3b7ad7289703
DIST squirrel_2.2.4_stable.tar.gz 419567 SHA256 936ca05469ab19f16a730685ef4ad1ca5a3838195765d47935a4ba9052d8b2d4 SHA512 91fe260b362d682eb5d21334c0ffa532120550c1c49a40412ac87118bee5f045e79c260f42247bd2c897d33b7a593dd2bc2e5c8e78e219553682f8b6cd79201d WHIRLPOOL 7cc953f1bbfc8e228be9310eff714b682f0e77b5e1ae9bf0a5bb0ec1c9f53b873c9199bb0679b7b13759bbe54e96de674a9b42b90db3ddd2a3caa36bc067ab50
1 change: 1 addition & 0 deletions dev-lang/squirrel/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="sourceforge">squirrel</remote-id>
<remote-id type="github">albertodemichelis/squirrel</remote-id>
</upstream>
</pkgmetadata>
43 changes: 43 additions & 0 deletions dev-lang/squirrel/squirrel-3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit cmake-utils

DESCRIPTION="A interpreted language mainly used for games"
HOMEPAGE="http://squirrel-lang.org/"
SRC_URI="https://github.com/albertodemichelis/squirrel/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples static-libs"

RDEPEND=""
DEPEND="${RDEPEND}"

src_configure() {
local mycmakeargs=(
-DINSTALL_LIB_DIR="$(get_libdir)" \
-DINSTALL_INC_DIR=include
$(usex static-libs '' -DDISABLE_STATIC=YES)
# /usr/bin/sq is used by app-text/ispell
# /usr/lib/libsquirrel.so is used by app-shells/squirrelsh
-DLONG_OUTPUT_NAMES=YES
)

cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install

dodoc HISTORY

if use examples; then
docompress -x /usr/share/doc/${PF}/samples
dodoc -r samples
fi
}

0 comments on commit 8041183

Please sign in to comment.