Skip to content

Commit

Permalink
sys-fs/multipath-tools: Bump to version 0.7.1
Browse files Browse the repository at this point in the history
This also fixes bug #624884

Package-Manager: Portage-2.3.6, Repoman-2.3.3
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 2, 2017
1 parent 12d2bbc commit 804a6c3
Show file tree
Hide file tree
Showing 2 changed files with 90 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/multipath-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST multipath-tools-0.5.0.tar.bz2 184024 SHA256 f13cf1eb84e94e83b2019e68f7965526903c13e94246db43965d181668a0a6f9 SHA512 dfad21c45d0f69e39041d30d203a582c8ee8329bf390c51cde10155b3de379e7ad8fead2ac4beb268a924fd7e7dc8e1cf538ea3c70d41479fd8786fa30ba22a9 WHIRLPOOL bc8a365d66d1c5f584de04304125949926d4a1576cba4a00acca0f1333eb13d83318da36d9d88c5dc92691a331d427ad6b99eb1f2983fbc387303dbfdbae11ff
DIST multipath-tools-0.6.2.tar.gz 242413 SHA256 f5cec5d92d56ec99220fccc1e70b9d10bc8ff5039c809ebcc201ce34d7ee3095 SHA512 8a04302002bf778299495e4be2d4302c19350d8ec218da23c5f781233efa6d0b39208a676b0d770771d7f09d62fa2b1ce32c03f60662691f74afb111e918b639 WHIRLPOOL f040273bd188c30f2f3b87e21a403b5f5d3ce2f0918382890cc0750b803bf05f70ed6bf46a83c5b68137835bc9bcf6cbca14f6462cfbef660667118b59eafc7d
DIST multipath-tools-0.6.4.tar.gz 285448 SHA256 1e2747883320f7db854201e5bfb97216e7518468f03503985382ce2c69e5558b SHA512 ec35c6c26c3b233ebece7136ea99dd4c0dff2927e7b543e7091219dc7065fe87e609a1eda9ab6d08399d44fe882d70c8dbe6be9ab175d154c5dd2d12ee1d86ea WHIRLPOOL 6138ba1cbb814bbf53e7a5113f50325d7a7d7088ff2b0f83f1e574f0644241e368cc6b5223eca039b414a0a459a52413d396ea214ff3eaa57f0681e8322b2d9d
DIST multipath-tools-0.7.1.tar.gz 329008 SHA256 d788aaf3ea862b44b5aa07eaa0e5696061f972a1a46d0f469c4a4f4c477c1970 SHA512 81ceb3887250a691b94cb49b7141ace4fc1f69d7f8381e517560dfc7c51ee4c5a1f4f4e40a0b368cf5f7381697fa746b856cbade8990c1608cbcd77248946a82 WHIRLPOOL 2bcc7cc2f425ca3f3f634807cafb7817b54b83d82987a09c9dd530dca1375175a7d52f1854bdd6d5f37c3b1fcf7bc34d67fc2dcae5809dfae968b313c8c86cba
89 changes: 89 additions & 0 deletions sys-fs/multipath-tools/multipath-tools-0.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit linux-info systemd toolchain-funcs udev vcs-snapshot toolchain-funcs

DESCRIPTION="Device mapper target autoconfig"
HOMEPAGE="http://christophe.varoqui.free.fr/"
SRC_URI="http://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=${PV};sf=tgz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="systemd rbd"

RDEPEND=">=sys-fs/lvm2-2.02.45
>=virtual/udev-171
dev-libs/libaio
dev-libs/userspace-rcu
sys-libs/readline:0=
rbd? ( sys-cluster/ceph )
systemd? ( sys-apps/systemd )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

CONFIG_CHECK="~DM_MULTIPATH"

get_systemd_pv() {
use systemd && \
$(tc-getPKG_CONFIG) --modversion systemd
}

pkg_pretend() {
linux-info_pkg_setup
}

pkg_setup() {
linux-info_pkg_setup
}

src_prepare() {
default

# Fix for bug #624884
if grep -qF DM_TABLE_STATE kpartx/kpartx.rules ; then
sed '/DM_TABLE_STATE/d' -i kpartx/kpartx.rules || die
else
elog "DM_TABLE_STATE sed hack is no longer necessary."
fi

# The upstream lacks any way to configure the build at present
# and ceph is a huge dependency, so we're using sed to make it
# optional until the upstream has a proer configure system
if ! use rbd ; then
sed -i -e "s/libcheckrbd.so/# libcheckrbd.so/" libmultipath/checkers/Makefile
sed -i -e "s/-lrados//" libmultipath/checkers/Makefile
fi
}

src_compile() {
# LIBDM_API_FLUSH involves grepping files in /usr/include,
# so force the test to go the way we want #411337.
emake \
CC="$(tc-getCC)" \
LIBDM_API_FLUSH=1 SYSTEMD="$(get_systemd_pv)"
}

src_install() {
dodir /sbin /usr/share/man/man{5,8}
emake \
DESTDIR="${D}" \
SYSTEMD=$(get_systemd_pv) \
unitdir="$(systemd_get_systemunitdir)" \
libudevdir='${prefix}'/"$(get_udevdir)" \
install

newinitd "${FILESDIR}"/rc-multipathd multipathd
newinitd "${FILESDIR}"/multipath.rc multipath

einstalldocs
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "If you need multipath on your system, you must"
elog "add 'multipath' into your boot runlevel!"
fi
}

0 comments on commit 804a6c3

Please sign in to comment.