Skip to content

Commit

Permalink
games-emulation/melonds-jg: New package, v0.9.5
Browse files Browse the repository at this point in the history
  • Loading branch information
orbea authored and thesamesam committed Jan 15, 2023
1 parent 481a8ac commit 80785a2
Show file tree
Hide file tree
Showing 5 changed files with 151 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/melonds-jg/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST melonds-0.9.5.tar.bz2 5396317 BLAKE2B 4f834c1037b0a1f2e6acdc52bc0b974107343485cdfeff35d16520afb46895abec3046fa9c91c53b6c02855b19af39a64bfc98722887e5090eb0b051ae0d106b SHA512 11a0a71b20e516f426f6fa6dbb46418c5afdd34997d2943a91149f527ca81c7c9a76db8460439e7593e245df92799a69a76dc426eea14a01383ce0a8c1a4b473
27 changes: 27 additions & 0 deletions games-emulation/melonds-jg/files/melonds-jg-0.9.5-format.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
Upstream-PR: https://github.com/melonDS-emu/melonDS/pull/1532
Upstream-Commit: https://github.com/melonDS-emu/melonDS/commit/bd9c614cebe47f809ae125a4bf59649191332a3a
melonds-jg-Commit: https://gitlab.com/jgemu/melonds/-/commit/bd9c614cebe47f809ae125a4bf59649191332a3a

From bd9c614cebe47f809ae125a4bf59649191332a3a Mon Sep 17 00:00:00 2001
From: Rupert Carmichael <[email protected]>
Date: Fri, 30 Dec 2022 15:13:39 -0500
Subject: [PATCH] Wifi: -Wformat warning caused by missing printf argument
(#1532)

---
src/Wifi.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/Wifi.cpp b/src/Wifi.cpp
index c2614e7..5373187 100644
--- a/src/Wifi.cpp
+++ b/src/Wifi.cpp
@@ -872,7 +872,7 @@ bool ProcessTX(TXSlot* slot, int num)
}

if ((num != 5) && (RAM[slot->Addr+4] > 0))
- printf("SLOT %d RETRY COUNTER %d\n", RAM[slot->Addr+4]);
+ printf("SLOT %d RETRY COUNTER %d\n", num, RAM[slot->Addr+4]);

// set TX addr
IOPORT(W_RXTXAddr) = slot->Addr >> 1;
53 changes: 53 additions & 0 deletions games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

MY_PN=${PN%-*}
MY_P=${MY_PN}-${PV}
DESCRIPTION="Jolly Good Port of melonDS"
HOMEPAGE="https://gitlab.com/jgemu/melonds"
if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
else
SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64"
fi

LICENSE="BSD-1 BSD-2 GPL-3+ MIT Unlicense public-domain"
SLOT="1"

DEPEND="
media-libs/jg:1=
media-libs/libsamplerate
"
RDEPEND="
${DEPEND}
games-emulation/jgrf
"
BDEPEND="
virtual/pkgconfig
"

PATCHES=(
"${FILESDIR}"/${P}-format.patch
)

src_compile() {
emake -C jollygood \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
PKG_CONFIG="$(tc-getPKG_CONFIG)"
}

src_install() {
emake -C jollygood install \
DESTDIR="${D}" \
PREFIX="${EPREFIX}"/usr \
DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
LIBDIR="${EPREFIX}/usr/$(get_libdir)"
}
49 changes: 49 additions & 0 deletions games-emulation/melonds-jg/melonds-jg-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

MY_PN=${PN%-*}
MY_P=${MY_PN}-${PV}
DESCRIPTION="Jolly Good Port of melonDS"
HOMEPAGE="https://gitlab.com/jgemu/melonds"
if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
else
SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64"
fi

LICENSE="BSD-1 BSD-2 GPL-3+ MIT Unlicense public-domain"
SLOT="1"

DEPEND="
media-libs/jg:1=
media-libs/libsamplerate
"
RDEPEND="
${DEPEND}
games-emulation/jgrf
"
BDEPEND="
virtual/pkgconfig
"

src_compile() {
emake -C jollygood \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
PKG_CONFIG="$(tc-getPKG_CONFIG)"
}

src_install() {
emake -C jollygood install \
DESTDIR="${D}" \
PREFIX="${EPREFIX}"/usr \
DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
LIBDIR="${EPREFIX}/usr/$(get_libdir)"
}
21 changes: 21 additions & 0 deletions games-emulation/melonds-jg/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
<pkgmetadata>
<maintainer type="person" proxied="yes">
<email>[email protected]</email>
<name>orbea</name>
</maintainer>
<maintainer type="project" proxied="proxy">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription>
melonDS is an emulator for the Nintendo DS and DSi. The
Jolly Good API port is designed for use with content for
the Nintendo DS.
</longdescription>
<upstream>
<bugs-to>https://gitlab.com/jgemu/melonds/-/issues</bugs-to>
<remote-id type="gitlab">jgemu/melonds</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 80785a2

Please sign in to comment.