Skip to content

Commit

Permalink
media-sound/audacity: Bump to version 2.2.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.4
  • Loading branch information
Lars Wendler committed Nov 6, 2017
1 parent 8d5cc68 commit 80fbe68
Show file tree
Hide file tree
Showing 2 changed files with 114 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/audacity/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST audacity-help-2.1.3.zip 20682229 SHA256 35a8f989ac8dfd24fa73716498feeffb82f838972280623309a557a3fa632a88 SHA512 4666d414628aaf611f98001350bdbcb761dac19ce4cc1e59d1a29e5d74056b9bfe4492a356bcd6c44aac9a3aaa24e30acd7bb9647ca10395fa8d5f0839f893ec WHIRLPOOL 413390d10f977da3ebd339ed7925a8e81efede5b322d0e5c96c21ab86f8dd3c800d9a5eaeb5a69a6655e7c76ba7010b0ccb4da14864d77891d3028da54d3de04
DIST audacity-minsrc-2.1.3.tar.xz 8073388 SHA256 c8fe1d52a58cef05390118a7f458f89252a3aa70155b78e8e25c92c4eeaabf31 SHA512 96e8bc49ef431b964d67857387cd9e5c1b398becfcaa452e26ef7617f267b7688617a5312d4a9873a24ee34986ea411148369e0ce138d86fea9b520e2c74a3ef WHIRLPOOL 730c962b6ff0861d9f96a58fb7d1c97af73cbf0072d3b8560c0250b4a37568741762d2891d8fb5097e6456a014e1ebe1dce4a41e039af5feb48d7bc454b67483
DIST audacity-minsrc-2.2.0.tar.xz 10191924 SHA256 87635ed19ebcc80d6e4bb88d578c67277c63a02bd22d09d5489080ad216f606b SHA512 2b0cfbedce279faff4d26b8a8fc68730596891394a6cc7d9bce9d48f2e180d6ecdebfb87cdd381f1f92111a9d143d2ebd3906517206d888a2d922dc176a0f7ec WHIRLPOOL b171864dc0419a17d08693d9c97086021283601dc48c2487fc0a89264dd2ee30bfbf22264052564ef82f063ce9f3ae42a9df94486ac3f8041d50b96537473f29
113 changes: 113 additions & 0 deletions media-sound/audacity/audacity-2.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,113 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit eutils wxwidgets xdg-utils

MY_P="${PN}-minsrc-${PV}"
DOC_PV="2.1.3"
DESCRIPTION="Free crossplatform audio editor"
HOMEPAGE="http://web.audacityteam.org/"
SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${MY_P}.tar.xz
doc? ( https://dev.gentoo.org/~polynomial-c/dist/${PN}-help-${DOC_PV}.zip )"
# wget doesn't seem to work on FossHub links, so we mirror

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
IUSE="alsa cpu_flags_x86_sse doc ffmpeg +flac id3tag jack +ladspa +lame libav
+lv2 mad +midi nls +portmixer sbsms +soundtouch twolame vamp +vorbis +vst"
RESTRICT="test"

RDEPEND=">=app-arch/zip-2.3
dev-libs/expat
>=media-libs/libsndfile-1.0.0
=media-libs/portaudio-19*
media-libs/soxr
x11-libs/wxGTK:3.0[X]
alsa? ( media-libs/alsa-lib )
ffmpeg? ( libav? ( media-video/libav:= )
!libav? ( >=media-video/ffmpeg-1.2:= ) )
flac? ( >=media-libs/flac-1.3.1[cxx] )
id3tag? ( media-libs/libid3tag )
jack? ( virtual/jack )
lame? ( >=media-sound/lame-3.70 )
lv2? ( media-libs/lv2 )
mad? ( >=media-libs/libmad-0.14.2b )
midi? ( media-libs/portmidi )
sbsms? ( media-libs/libsbsms )
soundtouch? ( >=media-libs/libsoundtouch-1.3.1 )
twolame? ( media-sound/twolame )
vamp? ( >=media-libs/vamp-plugin-sdk-2.0 )
vorbis? ( >=media-libs/libvorbis-1.0 )"
DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )"

REQUIRED_USE="soundtouch? ( midi )"

S="${WORKDIR}/${MY_P}"

src_configure() {
local WX_GTK_VER="3.0"
need-wxwidgets unicode

# * always use system libraries if possible
# * options listed in the order that configure --help lists them
local myeconfargs=(
--disable-dynamic-loading
--enable-nyquist
--enable-unicode
--with-expat=system
--with-libsndfile=system
--with-libsoxr=system
--with-portaudio
--with-widgetextra=local
--with-wx-version=${WX_GTK_VER}
$(use_enable cpu_flags_x86_sse sse)
$(use_enable ladspa)
$(use_enable nls)
$(use_enable vst)
#$(use_with alsa)
$(use_with ffmpeg)
$(use_with flac libflac)
$(use_with id3tag libid3tag)
#$(use_with jack)
$(use_with lame)
$(use_with lv2)
$(use_with mad libmad)
$(use_with midi)
$(use_with sbsms)
$(use_with soundtouch)
$(use_with twolame libtwolame)
$(use_with vamp libvamp)
$(use_with vorbis libvorbis)
$(use_with portmixer)
)
econf "${myeconfargs[@]}"
}

src_install() {
emake DESTDIR="${D}" install

# Remove bad doc install
rm -r "${D%/}"/usr/share/doc || die

# Install our docs
dodoc README.txt

if use doc ; then
docinto html
dodoc -r "${WORKDIR}"/{m,man,manual}
dodoc "${WORKDIR}"/{favicon.ico,index.html,quick_help.html}
fi
}

pkg_postinst() {
xdg_mimeinfo_database_update
}

pkg_postrm() {
xdg_mimeinfo_database_update
}

0 comments on commit 80fbe68

Please sign in to comment.