Skip to content

Commit

Permalink
sci-geosciences/opencpn: Add new version 4.8.8
Browse files Browse the repository at this point in the history
Fixes #654786

Signed-off-by: Marc Schiffbauer <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.10
  • Loading branch information
mschiff committed Dec 2, 2018
1 parent f41d89f commit 81325ca
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
2 changes: 2 additions & 0 deletions sci-geosciences/opencpn/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
DIST opencpn-4.8.0.tar.gz 53008393 BLAKE2B 79184b678db329e98c704f4f1a132e5d3af4a65b104c6eab1c37738cbbf98d88c21647ce654077a8f4b781221d7e3766c35d7450b81befdad7f269b636263c09 SHA512 1f1ea666566e98ee3af24423985119c1b14e184d4310dbc588b00065878b1dcb8fe73a7331e4ad3f75a905774fff187203fb31253faea7238f3d783a6729ad75
DIST opencpn-4.8.2.tar.gz 59164504 BLAKE2B fbfa86051845a922a7c642194cd0672fbccd6a75e3897e8b0b3f9b08c091d0933a146060f83265c9a85d0bacf18f57a0f9ba55aa4f26e035a77d39d73e5e5a7d SHA512 231f8ba29f8a0343cb3807e52e8535bdade221de65a169b57e94816b4b464407ba90b605dcec21a5c45c742de076b644f076fee88616ec2867a8ae182105102d
DIST opencpn-4.8.8.tar.gz 59140674 BLAKE2B a03fd28b26bee46d559d16bf061eac409ca9395fdf1595162a51fe4cdfb30c3151c23b30f3396b645c4b177b3fd3b0f2ea03a850d0ea3fe2258f1abc4956a3db SHA512 4fa94655d7b9d389f5f335c15898e7138c792c71b824720fedd762ccd71c01481e5a24598b85211dba0c7d89d0ad0b2ebc2afc38301235829d4aa6f499c6f9b2
DIST opencpn-doc_4.1.1329.1.orig.tar.xz 8739872 BLAKE2B 1d0b1538230488586318212d371669d0dfd6fefb45a49c1405c8749cfc2d5b1ced39c03ad7814954db42644ab5c21a37177e0f315b8d6d49c2200508f27a9899 SHA512 652a932edbf8a6f05fd3c64ddf566f817405cf44697035f58ddbf1a99bf92269b7fd9ee83b7ee065aa60db15b6030d8c5c9a4a4001049ed2def9962bc51746c2
DIST opencpn-doc_4.8.2.0.orig.tar.xz 22302480 BLAKE2B 2bcd2ac01340cde0d0be80537321c8c3e829a8e664944c34f3f3112f931c45746059b5c173402982601ccf88926241741c7fb44f251e9fe48b83aa5f3e8d7727 SHA512 678317c77feb3b0bf695e337e7e95083df1d488e0a5ad3bad41bad11dc87271d6fc0ac194a6b63b603d5c1f1184e6c9f91de895a7db01017ef2a7068a62404eb
63 changes: 63 additions & 0 deletions sci-geosciences/opencpn/opencpn-4.8.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

WX_GTK_VER="3.0"
inherit cmake-utils wxwidgets

DOC_VERSION="4.8.2.0"

DESCRIPTION="a free, open source software for marine navigation"
HOMEPAGE="https://opencpn.org/"
SRC_URI="https://github.com/OpenCPN/OpenCPN/archive/v${PV}.tar.gz -> ${P}.tar.gz
doc? ( https://launchpad.net/~opencpn/+archive/ubuntu/${PN}/+files/${PN}-doc_${DOC_VERSION}.orig.tar.xz )
"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc lzma opengl"

RDEPEND="
app-arch/bzip2
lzma? ( app-arch/xz-utils )
dev-libs/tinyxml
media-libs/freetype:2
media-libs/portaudio
net-misc/curl
sys-libs/zlib
opengl? ( virtual/opengl )
x11-libs/gtk+:2
x11-libs/wxGTK:${WX_GTK_VER}[X]
!sci-geosciences/opencpn-plugin-wmm
"
DEPEND="${RDEPEND}
sys-devel/gettext"

S="${WORKDIR}/OpenCPN-${PV}"

src_configure() {
setup-wxwidgets
local mycmakeargs=(
-DUSE_S57=ON
-DUSE_GARMINHOST=ON
-DBUNDLE_GSHHS=CRUDE
-DBUNDLE_TCDATA=ON
)

cmake-utils_src_configure
}

src_install() {
if use doc; then
dohtml -r "${S}"/../${PN}/doc/*
fi
cmake-utils_src_install
}

pkg_postinst() {
if use doc; then
einfo "Documentation is available at file:///usr/share/doc/${PF}/html/help_en_US.html"
fi
}

0 comments on commit 81325ca

Please sign in to comment.