Skip to content

Commit

Permalink
app-backup/backup-manager: version bump to 0.7.12, bug #597020
Browse files Browse the repository at this point in the history
Simplify ebuild (should also fix #336428 again)
Doc requires a debian tool to build, so we do not ship it

Package-Manager: portage-2.3.2
  • Loading branch information
voyageur committed Nov 7, 2016
1 parent e7a0556 commit 8135130
Show file tree
Hide file tree
Showing 3 changed files with 55 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-backup/backup-manager/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST Backup-Manager-0.7.10.1.tar.gz 150963 SHA256 16994520d3fded41e166d17c946405dd192acf960603044aa6c915465e78d41f SHA512 8c51e8150b0a67c416bcba6291b85f2bb2dfd79521f4e0f8a2de47c5903dafbebde4048224cbecf92fc09b3a6ac431fab51434ccced81cf2fbfdd24482432618 WHIRLPOOL e1fb4913038dd25fc39dd0663cb434b3cadcb855c704fa3825ec2484a965f5b6b6ad1cf4e20132fa487b84c082a5883641fa9ad7d2b01f44f58d2d13003bf5c6
DIST backup-manager-0.7.12.tar.gz 136204 SHA256 a218f0e87830060603273e27213c68555905193743ebd6f14755923756b859f3 SHA512 737651857c305e331faaf3ab040b7f926bc1195177715732356760a56eb7012fd837ed62f974ad50d29a7d1ecfd0f75833515cec755b24a46e13109831b6f770 WHIRLPOOL e49bdf91748936e183ad233381ce1160ba0e6d372814587fd906cef04b9e34cfc46a5e1456310a0a286d842dd962d23ff1dd240143bc3564d5f5a795f3123ea9
DIST backup-manager-0.7.5.tar.gz 159855 SHA256 a7aa04ebec5b8a80d5e75d48121092afb969e1efb252b1ffdbcd28b04225e55a SHA512 3101e695d79c429e5a415a174c12b6217495aaefc0b44ee870bb492eea75ce07dacb766a45c60268a0f7da798d51b46f6d91f33b9d545360f09b92b61329bcef WHIRLPOOL 366e205c15084231fad81af9cbcebca34e7d3637476ba7046dc840d3f54c110469588ddc939c112525bac8d4764a7be2097c1b218f59af752af453091ff8299f
52 changes: 52 additions & 0 deletions app-backup/backup-manager/backup-manager-0.7.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils

MY_P=Backup-Manager-${PV}
DESCRIPTION="Backup Manager is a command line backup tool for GNU/Linux"
HOMEPAGE="https://github.com/sukria/Backup-Manager"
SRC_URI="http://github.com/sukria/Backup-Manager/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="s3"

DEPEND="dev-lang/perl
sys-devel/gettext"

RDEPEND="${DEPEND}
s3? ( dev-perl/Net-Amazon-S3
dev-perl/File-Slurp )"

S=${WORKDIR}/${MY_P}

src_prepare() {
sed -i "/^PERL5DIR/s/sitelib/vendorlib/" Makefile \
|| die "Makefile sed failed"

default
}

src_compile() {
default
emake -C po
}

src_install() {
emake DESTDIR="${D}" PREFIX=/usr install
}

pkg_postinst() {
elog "After installing,"
elog "copy ${ROOT%/}/usr/share/backup-manager/backup-manager.conf.tpl to"
elog "/etc/backup-manager.conf and customize it for your environment."
elog "You could also set-up your cron for daily or weekly backup."

ewarn "New configuration keys may have been defined."
ewarn "Please check the docs for info"
}
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.orig 2010-09-14 17:24:31.267313414 +0200
+++ Makefile 2010-09-14 17:24:36.395250687 +0200
--- backup-manager-0.7.9/Makefile.orig 2010-09-14 17:24:31.267313414 +0200
+++ backup-manager-0.7.9/Makefile 2010-09-14 17:24:36.395250687 +0200
@@ -62,7 +62,7 @@

# Main build rule (we don't buid the docs as we don't know if debiandocs can be
Expand Down

0 comments on commit 8135130

Please sign in to comment.