Skip to content

Commit

Permalink
gui-apps/foot: bump to 1.12.1
Browse files Browse the repository at this point in the history
Closes: gentoo#25213
Signed-off-by: Arsen Arsenović <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
ArsenArsen authored and juippis committed Apr 28, 2022
1 parent cd7130c commit 81775fd
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-apps/foot/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST foot-1.11.0.tar.gz 468899 BLAKE2B f3e3909c670598dab151f8be4104921fddd6621e833a8fe43c68d06347e3e866101fe1563282622436638674b7f73770762d47a7b9fd61d42b00bc7634e2ea76 SHA512 edf8130dfb52e06b6d8638115eca19695b24536f3f6b284e0319876edb95c3c86800f9527cc9dae3f66d2d317d26add793634a19f302e52c9f0118b9b91fc9c2
DIST foot-1.12.1.tar.gz 484702 BLAKE2B 5f3ed5923dfe2e3d110da298d4abefb331c15bb0f3db3135a4e8d481b528b3f8287fc5d8516e9d3a34b8084f6364edae93dee496d9192fe610d2c17733277451 SHA512 553f404b074f4372fb8cfb050f0378d1cbe1620ea8afe2e279523df3006eefd0b0ed24addca33de10cfc8109e5aaec66beccbd5f30e032bb9f2bd9b81ac798cb
73 changes: 73 additions & 0 deletions gui-apps/foot/foot-1.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson xdg systemd

DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
HOMEPAGE="https://codeberg.org/dnkl/foot"
SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="+grapheme-clustering"

COMMON_DEPEND="
dev-libs/wayland
media-libs/fcft
media-libs/fontconfig
x11-libs/libxkbcommon
x11-libs/pixman
grapheme-clustering? (
dev-libs/libutf8proc:=
media-libs/fcft[harfbuzz]
)
"
DEPEND="
${COMMON_DEPEND}
dev-libs/tllist
dev-libs/wayland-protocols
"
RDEPEND="
${COMMON_DEPEND}
|| (
>=sys-libs/ncurses-6.3[-minimal]
~gui-apps/foot-terminfo-${PV}
)
"
BDEPEND="
app-text/scdoc
dev-util/wayland-scanner
"

src_prepare() {
default
# disable the systemd dep, we install the unit file manually
sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
}

src_configure() {
local emesonargs=(
$(meson_feature grapheme-clustering)
-Dthemes=true
-Dime=true
-Dterminfo=disabled
-Dwerror=false
)
meson_src_configure

sed 's|@bindir@|/usr/bin|g' "${S}/"/[email protected] > [email protected]
}

src_install() {
local DOCS=( CHANGELOG.md README.md LICENSE )
meson_src_install

# foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
# we handle this via DOCS and dodoc instead.
rm -r "${ED}/usr/share/doc/${PN}" || die
systemd_douserunit [email protected] "${S}"/[email protected]
}

0 comments on commit 81775fd

Please sign in to comment.