Skip to content

Commit

Permalink
games-arcade/mrrescue: Update love dependency
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
BetaRays authored and mgorny committed Jul 20, 2018
1 parent 73635f8 commit 817966c
Showing 1 changed file with 46 additions and 0 deletions.
46 changes: 46 additions & 0 deletions games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils gnome2-utils

DESCRIPTION="Arcade 2d action game based around evacuating civilians from burning buildings"
HOMEPAGE="http://tangramgames.dk/games/mrrescue/"
SRC_URI="https://github.com/SimonLarsen/mrrescue/releases/download/v${PV}/${P}-love.zip
https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"

LICENSE="CC-BY-SA-3.0 MIT ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

LVSLOT="0.8"
RDEPEND="games-engines/love:${LVSLOT}"
DEPEND="app-arch/unzip"

S="${WORKDIR}/${P}-love"

src_install() {
local dir=/usr/share/love/${PN}

exeinto "${dir}"
doexe ${PN}.love

einstalldocs

doicon -s 64 "${DISTDIR}"/${PN}.png
make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
make_desktop_entry ${PN}
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 817966c

Please sign in to comment.