Skip to content

Commit

Permalink
dev-libs/boost: Fix Boost.Bimap headers
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/703294
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Dec 21, 2019
1 parent 32c8d5f commit 81a235b
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-libs/boost/boost-1.72.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -54,6 +54,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.71.0-disable_icu_rpath.patch
"${FILESDIR}"/${PN}-1.71.0-context-x32.patch
"${FILESDIR}"/${PN}-1.71.0-build-auto_index-tool.patch
# Bug 703294, incomplete Boost.Serialization refactoring
"${FILESDIR}"/${PN}-1.72.0-missing-serialization-split_member-include.patch
)

python_bindings_needed() {
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
Missing #include, as the split_member.hpp include is not
part of the nvp.hpp interface, and hence cannot be relied
upon to be included transitively.

Confirmed on
https://github.com/boostorg/serialization/commit/c32a663c9963385430abc563f9c85f94d8da43a9#r36528430

Bug: https://bugs.gentoo.org/703294

--- a/boost/bimap/detail/map_view_iterator.hpp
+++ b/boost/bimap/detail/map_view_iterator.hpp
@@ -22,6 +22,7 @@

#ifndef BOOST_BIMAP_DISABLE_SERIALIZATION
#include <boost/serialization/nvp.hpp>
+ #include <boost/serialization/split_member.hpp>
#endif // BOOST_BIMAP_DISABLE_SERIALIZATION

#include <boost/iterator/detail/enable_if.hpp>
--- a/boost/bimap/detail/set_view_iterator.hpp
+++ b/boost/bimap/detail/set_view_iterator.hpp
@@ -22,6 +22,7 @@

#ifndef BOOST_BIMAP_DISABLE_SERIALIZATION
#include <boost/serialization/nvp.hpp>
+ #include <boost/serialization/split_member.hpp>
#endif // BOOST_BIMAP_DISABLE_SERIALIZATION

#include <boost/iterator/detail/enable_if.hpp>

0 comments on commit 81a235b

Please sign in to comment.