Skip to content

Commit

Permalink
app-admin/keepassxc: Bump to version 2.7.1
Browse files Browse the repository at this point in the history
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Apr 6, 2022
1 parent b934ab4 commit 81b4e87
Show file tree
Hide file tree
Showing 2 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/keepassxc/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST keepassxc-2.6.6-src.tar.xz 7640532 BLAKE2B ed55dfe992c02e78354d7aeb9f63853380dbcdec0e834232997cb6f5ecc303ff18ed50dcc48f54497031d6fc8b741c620202e78c3eacbe50d4dcfa7e4d59a92c SHA512 175702ef3ae5b048ba23a794ddf4e17d61f2640955de7ec21a3e49e4abe7cab8c93c9a2bc61c5c052c62382a69bd8dcb4a4f0cf6daa162f5e00cff3f7a1a713b
DIST keepassxc-2.7.0-src.tar.xz 8846780 BLAKE2B 74c4e9c6d06239950f1b8a64c5bce894799fdd73a562ee22d1189c60dedfff3555132c0619488e0682e94de8759e096627520b96d664f472645e4b6375d68ff9 SHA512 0fc436ae5fb8fb82765a0c2df20c9567b1baf6aceff1e08c843a151ddcc0920d4cb2d416aebd89bdd8f1b53efb0a4ad0f579955c6943ee66c20b0becbb978e12
DIST keepassxc-2.7.1.tar.gz 11168642 BLAKE2B 4708821c596e8fc736e086a700d5526be6d9c4cfcb270e3a0a8b73395e9ca3544cbb5973494b15d66e0b98264f4e79d9fa122961407211d346275a9aa1bd5cae SHA512 c2f780ba1f464b32f741d1c6e83734ff220de56dce382f3c38d940abf255d689559c13bff6ad565c38c18cfdb1d883aca52650dba0486e3e28bb4ef872253cc9
97 changes: 97 additions & 0 deletions app-admin/keepassxc/keepassxc-2.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake flag-o-matic xdg

DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"

if [[ "${PV}" != *9999 ]] ; then
if [[ "${PV}" == *_beta* ]] ; then
SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
else
SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
#SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
else
inherit git-r3
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
[[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
fi

LICENSE="LGPL-2.1 GPL-2 GPL-3"
SLOT="0"
IUSE="autotype browser ccache doc keeshare +network test yubikey"

RESTRICT="!test? ( test )"

RDEPEND="
app-crypt/argon2:=
dev-libs/botan:2
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
media-gfx/qrencode:=
sys-libs/readline:0=
sys-libs/zlib:=
autotype? (
x11-libs/libX11
x11-libs/libXtst
)
keeshare? ( sys-libs/zlib:=[minizip] )
yubikey? (
dev-libs/libusb:1
sys-apps/pcsc-lite
)
"

DEPEND="
${RDEPEND}
dev-qt/linguist-tools:5
dev-qt/qttest:5
"
BDEPEND="
ccache? ( dev-util/ccache )
doc? ( dev-ruby/asciidoctor )
"

src_prepare() {
if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
printf '%s' "${PV}" > .version || die
fi

cmake_src_prepare
}

src_configure() {
# https://github.com/keepassxreboot/keepassxc/issues/5801
filter-flags -flto*

local mycmakeargs=(
-DWITH_CCACHE="$(usex ccache)"
-DWITH_GUI_TESTS=OFF
-DWITH_TESTS="$(usex test)"
-DWITH_XC_AUTOTYPE="$(usex autotype)"
-DWITH_XC_DOCS="$(usex doc)"
-DWITH_XC_BROWSER="$(usex browser)"
-DWITH_XC_FDOSECRETS=ON
-DWITH_XC_KEESHARE="$(usex keeshare)"
-DWITH_XC_NETWORKING="$(usex network)"
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_UPDATECHECK=OFF
-DWITH_XC_YUBIKEY="$(usex yubikey)"
)
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
cmake_src_configure
}

0 comments on commit 81b4e87

Please sign in to comment.