Skip to content

Commit

Permalink
dev-util/pkgcheck: add 0.10.25
Browse files Browse the repository at this point in the history
Signed-off-by: Arthur Zamarin <[email protected]>
  • Loading branch information
arthurzam committed Jul 30, 2023
1 parent 9acfbfb commit 81df6c5
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/pkgcheck/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pkgcheck-0.10.23.tar.gz 568903 BLAKE2B 8b00dc93d0c3f597f7397d2e7b3686d11b12da715d6e8071f1b02a8085061cbb2d7cb24bde6a73ef6e5d1459637cb78e536ce80a162f188a42739a434c62c397 SHA512 3bcdb91bf73cde60fd9fc2f5e470c5ccdfd7b3564e83192201b0fa1dc38265e1e0c7f7052039accbb62c55d816a6e89317d7d388c0cc3da3b4836475cb82bd03
DIST pkgcheck-0.10.24.tar.gz 572336 BLAKE2B 851d6e8d8a5402c539cb690e6e915d3875658f0f4c9e60e8f506d6a663d0732993f2af7a46b3dcf7c2fba11a3d7b521753aa537a893796b8cda216c9e9d370af SHA512 bb0eb962d9d6cafc5b4ca1280307aae8e154d813151841373334971b7613099ebeeb2b9eb3ca9755da43d76a6448b6a8f6570201810b182cf868a172992b40a5
DIST pkgcheck-0.10.25.tar.gz 580383 BLAKE2B 2f32bf413dcb68a59b82ee04147b7844efd7b69d932b5d57182e1c91be12750fe14fdd42bf40c652c69e8ac009b2346cc644a9407cf11f03eea2e74f4ab8edc6 SHA512 8d90b5629236f468b5553ca288dbd4843d83b09adc9b9b20a6ad6228a8bff74bf1c1e473575f85d1fb00bdd416e07cc77ea098fd6a2b29edf39f51da364c4831
94 changes: 94 additions & 0 deletions dev-util/pkgcheck/pkgcheck-0.10.25.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit elisp-common distutils-r1 optfeature

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgcheck.git
https://github.com/pkgcore/pkgcheck.git"
inherit git-r3
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
inherit pypi
fi

DESCRIPTION="pkgcore-based QA utility for ebuild repos"
HOMEPAGE="https://github.com/pkgcore/pkgcheck"

LICENSE="BSD MIT"
SLOT="0"
IUSE="emacs"

if [[ ${PV} == *9999 ]]; then
RDEPEND="
~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
else
RDEPEND="
>=dev-python/snakeoil-0.10.4[${PYTHON_USEDEP}]
>=sys-apps/pkgcore-0.12.18[${PYTHON_USEDEP}]"
fi
RDEPEND+="
dev-libs/tree-sitter
dev-libs/tree-sitter-bash
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pathspec[${PYTHON_USEDEP}]
>=dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
emacs? (
>=app-editors/emacs-24.1:*
app-emacs/ebuild-mode
app-emacs/flycheck
)
"
BDEPEND="${RDEPEND}
dev-python/wheel
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-vcs/git
)
"

SITEFILE="50${PN}-gentoo.el"

distutils_enable_tests pytest

export USE_SYSTEM_TREE_SITTER_BASH=1

src_compile() {
distutils-r1_src_compile

if use emacs ; then
pushd "${S}"/contrib/emacs >/dev/null || die
elisp-compile *.el
popd >/dev/null || die
fi
}

python_install_all() {
local DOCS=( NEWS.rst )
[[ ${PV} == *9999 ]] || doman man/*
distutils-r1_python_install_all

if use emacs ; then
elisp-install ${PN} "${S}"/contrib/emacs/*.el{,c}
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
}

pkg_postinst() {
use emacs && elisp-site-regen

optfeature "Network check support" dev-python/requests
optfeature "Perl module version check support" dev-perl/Gentoo-PerlMod-Version
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 81df6c5

Please sign in to comment.