Skip to content

Commit

Permalink
app-backup/btrbk: 0.27.2 version bump, don't compress docs
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/667400
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Mar 26, 2019
1 parent 3c993f6 commit 8204317
Show file tree
Hide file tree
Showing 3 changed files with 86 additions and 3 deletions.
1 change: 1 addition & 0 deletions app-backup/btrbk/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST btrbk-0.26.0.tar.xz 82472 BLAKE2B 06effda16b2173e6d3dc3ea896ed9729d6f2840a2
DIST btrbk-0.26.1.tar.xz 83624 BLAKE2B a99c66dc16432edb1da38ac51e68ed939207ad8553108258346d4261c243a1a478a3e1dca1cf6d39d03e10a8a5c44e45a7784aec131246e060aded4fc24d708e SHA512 ee0043f468e11545ca28b5bd456aa9dab1b994ed6d8899ab0f53d455f78bb44f83bcf493e32fdecfec82b3029d5dabc2db72a2f32de80b709a12930df6d53b22
DIST btrbk-0.27.0.tar.xz 86648 BLAKE2B bebb1c56b5c08e588829697df1d00e89366582d7c501ffc7c72baf8136ec62ac1f9b7aea300f1ba20c6060646e80916a52e2b83a85b383cb04289867d82b2a53 SHA512 2d65d32cecdd8598d5028a78a449559563bf38a172849e0a13ccfa8129189a044cb2d007561b5c7e611c8bbbe069fd9c1177085dca519c88d40233fb0d49db36
DIST btrbk-0.27.1.tar.xz 86764 BLAKE2B a46514a94e6f49f83f92bba6f545738fe6a0b274a7eb39a132a41e1f89e0e6428ee8e29164ca2ba249bf98d2c7a5f682a81bb5c113a9cd5af12e4abf98669684 SHA512 b30be9fa2459d34d33ed0c2ef1b4f2e7010d1d7f9dc6e6e3236550307b7e2f2f517a61d21bcd2aca3ed0750ef64259bb51c32ff26abcc70008db92e1a66212bd
DIST btrbk-0.27.2.tar.xz 87012 BLAKE2B 7b25ce04e088b9c3df1f5d4f41ec3e6aef7e48bebb8fcd4c4a8365bb73d26dd09afdf1814985362b28958a93df2797dd62444475024f66bd027303955a160604 SHA512 497d1dd1d2de712d4de80d0bfcdf6995590fd5308b81d7198af7cebe81c45fd53c8940265c1451eb95339636cf0e4c2a9162befb7cdd48cc8d4142b4e9ca75f1
77 changes: 77 additions & 0 deletions app-backup/btrbk/btrbk-0.27.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/digint/btrbk.git"
inherit git-r3
SRC_URI=""
KEYWORDS=""
else
SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
HOMEPAGE="https://digint.ch/btrbk/"
LICENSE="GPL-3+"
SLOT="0"
IUSE="+pv +doc"

DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"

RDEPEND="dev-lang/perl
net-misc/openssh
pv? ( sys-apps/pv )
>=sys-fs/btrfs-progs-4.12"

src_compile() {
use doc && emake -C doc COMPRESS=no
}
src_install() {
local targets="install-bin install-etc install-share install-systemd"
use doc && targets="${targets} install-man install-doc"
emake \
COMPRESS=no \
DESTDIR="${D}" \
DOCDIR="/usr/share/doc/${PF}" \
SYSTEMDDIR="$(systemd_get_systemunitdir)" \
${targets}
}
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
upgrade_0_26_0_warning="1"
fi
if has_version "<${CATEGORY}/${PN}-0.27.0" ; then
upgrade_0_27_0_warning="1"
fi
}
pkg_postinst() {
if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
ewarn "If you are using raw targets, make sure to run the"
ewarn "\"raw_suffix2sidecar\" utility in each target directory."
fi
if [[ "${upgrade_0_27_0_warning}" == "1" ]]; then
ewarn 'Due to a bugfix in the scheduler [1] [2], previously preserved'
ewarn 'monthly/yearly backups could get deleted when upgrading to'
ewarn 'btrbk-0.27.0.'
ewarn ''
ewarn 'Before upgrading to btrbk-0.27.0, make sure to stop all cron jobs'
ewarn 'or systemd timers calling btrbk.'
ewarn ''
ewarn 'After upgrading, run "btrbk prune --dry-run --print-schedule" and'
ewarn 'check if any snapshots/backups would get deleted. If you want to'
ewarn 'forcibly preserve a snapshot/backup forever, rename it:'
ewarn ''
ewarn ' mv mysubvol.YYYYMMDD mysubvol.YYYYMMDD.keep_forever'
ewarn ''
ewarn 'Note that btrbk ignores subvolumes with unknown naming scheme, e.g.'
ewarn '(".keep_forever" suffix in the example above).'
ewarn ''
ewarn ' [1] https://github.com/digint/btrbk/issues/217'
ewarn ' [2] https://github.com/digint/btrbk/commit/719fb5f'
fi
}
11 changes: 8 additions & 3 deletions app-backup/btrbk/btrbk-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -26,15 +26,20 @@ DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"
RDEPEND="dev-lang/perl
net-misc/openssh
pv? ( sys-apps/pv )
>=sys-fs/btrfs-progs-3.18.2"
>=sys-fs/btrfs-progs-4.12"

src_compile() {
use doc && emake -C doc
use doc && emake -C doc COMPRESS=no
}
src_install() {
local targets="install-bin install-etc install-share install-systemd"
use doc && targets="${targets} install-man install-doc"
emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" ${targets}
emake \
COMPRESS=no \
DESTDIR="${D}" \
DOCDIR="/usr/share/doc/${PF}" \
SYSTEMDDIR="$(systemd_get_systemunitdir)" \
${targets}
}
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
Expand Down

0 comments on commit 8204317

Please sign in to comment.