Skip to content

Commit

Permalink
dev-util/drone-cli: Update snapshot
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
mrueg committed Jun 23, 2017
1 parent 0724ec6 commit 821fc79
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/drone-cli/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST drone-cli-0.7.0_p20170603.tar.gz 1148152 SHA256 0440900f410141d0bd8e8f682a6acd2b9fecedb6d7def413b6bcc1304b362765 SHA512 a019295e97cd5683f97fc75d586b68df35fdf0ac8914f77a0efd2b6ec4a9727be04071556e92207cbaa07e573046a54e5a97e9aaccea5f9c1ea75b2a28d5c1df WHIRLPOOL 4357675b2f6ebfc5fb6ced9f4c2d1aa64673c51a4d2de55c329f7b15f37bdfaaca9427873b5bfdbe48c64a1b2f4a5117306ea13167d3efb213d3b34a0d3dd026
DIST drone-cli-0.7.0_p20170620.tar.gz 1148198 SHA256 ada290d76615965f2417b70a8bd2fc43ddbbd8f8ecd0ee5d9947de48d377c80f SHA512 2c548a7f79e9de93700d29694403289bbbf9b994441903e8d107c4c23726cd155762f0beea9e0d9081568f55bafe3fdca2d943af20023c4a81ceba9b00e69335 WHIRLPOOL 5132b03ebb9ee69f78669aad0d2db28f2440922585552c30a788e2986264821d1aa5064f3de2d41b56e36ef51709284b6edd511d9fe538ebfc9387440060ed07
35 changes: 35 additions & 0 deletions dev-util/drone-cli/drone-cli-0.7.0_p20170620.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGO_PN="github.com/drone/drone-cli"
EGIT_COMMIT="9d8dd90e5ba860eecf39972f46c7d0219e575442"

inherit golang-build golang-vcs-snapshot

ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Command-line interface for Drone"
HOMEPAGE="https://github.com/drone/drone-cli"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

RESTRICT="test"

RDEPEND="!!<dev-util/drone-0.7"

src_compile() {
pushd src || die
GOPATH="${WORKDIR}/${P}"\
go install -ldflags "-X main.version=${PV}.${EGIT_COMMIT:0:7}" ${EGO_PN}/drone || die
popd || die
}

src_install() {
dobin bin/drone
dodoc src/${EGO_PN}/README.md
}

0 comments on commit 821fc79

Please sign in to comment.