Skip to content

Commit

Permalink
dev-ruby/dnsruby: add 1.60.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
graaff committed Apr 25, 2017
1 parent 1e8642f commit 82239ca
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/dnsruby/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dnsruby-1.59.3.gem 233984 SHA256 ec350a4d5c0994428098693ddda1c1d65e03547a90c28c022d93357887f6ae3a SHA512 7cfd8c15b7691b86473f46c6e28c751f87d63459104c2b550312a717c654c5013751851497e3ab0242202a813c2cbfa2d78cc414aa80641d47ca4b622e3eee09 WHIRLPOOL 35d4ce0549c0a6c12738141980058d4a9c7e602ff2d18240a6948375d453810c87347f48f5eed5c2d0b454200401eab6db3b5cde243a48cfb32e04638ddb4c2f
DIST dnsruby-1.60.0.gem 244736 SHA256 bf9bd6d5e3610e51ac83da8bbad3ee7180b62cfe2f7e3f8df2e7ba355b93a56d SHA512 696f2cd72c09bfe6b6eecb59979f872843e7ebea320130edb86eb662ad8b5ad657bea0709614093b5dcdf6c95ebfebdae500ae5622fe999a4cdc03e1ad4b5fc6 WHIRLPOOL 4a0278344bf9a8428c11699a8107181fac2720509df338834148d42c105e596895284a985f2b47b4055b34545f6050b1102598ddd8b87a5b9f8f57dd3276dde5
DIST dnsruby-1.60.1.gem 254464 SHA256 7cc4a46e980e183a436194dc7f3fc93711f7ffc597458abcb9462cbf35baed72 SHA512 fb84a76224350b01925e5a5e413ec08c31988d7cc5fc5e403aabb1aaeee227f926b267628e8438da2fef5d14facf6efe98bceb100d8169117119ef115b6d2031 WHIRLPOOL ce3a9aac75f596dede7e56fde69c32d6f1cd41fe56c896ad0711a83f99164145edd8f4654932e956a24c1624528d0925aea9179a0092d59bf90c651872b509d4
33 changes: 33 additions & 0 deletions dev-ruby/dnsruby/dnsruby-1.60.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby21 ruby22 ruby23 ruby24"

RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_DOCDIR="html"
RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README.md"
inherit ruby-fakegem

DESCRIPTION="A pure Ruby DNS client library"
HOMEPAGE="https://github.com/alexdalitz/dnsruby"

KEYWORDS="~amd64 ~x86"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4:5 )"

all_ruby_prepare() {
sed -i -e "/[Cc]overall/d" Rakefile || die
sed -i -e '/display/d' \
-e '/Display/,/^}/d' test/spec_helper.rb || die
}

each_ruby_test() {
# only run offline tests
#${RUBY} -I .:lib test/ts_dnsruby.rb || die "test failed"
${RUBY} -I .:lib test/ts_offline.rb || die "test failed"
}

0 comments on commit 82239ca

Please sign in to comment.