Skip to content

Commit

Permalink
dev-perl/gnome2-perl: Bump to version 1.46.0 re bug #616954
Browse files Browse the repository at this point in the history
- EAPI6
- Patch tests for '.' in @inc removal

Upstream:
- Don't include timestamps in generated documentation

Bug: https://bugs.gentoo.org/616954
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
kentfredric committed Oct 22, 2017
1 parent 5a25447 commit 825d645
Show file tree
Hide file tree
Showing 3 changed files with 386 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-perl/gnome2-perl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Gnome2-1.045.tar.gz 79262 SHA256 1426044de3ab4900e0a7cb0cc27aa2213c6ad29ed0676b018dce2eee832692f7 SHA512 fa4ac02dbc3d96e6790cff964968f86b9eaf5bb79bbdd2fb3e967e4e8f4bcad25bf1308d25b26ae0298303dfaab7aaa5b49028336d25648614208e622a848316 WHIRLPOOL 54d747c44d06fa7324f3234d9849e400dedd9a0dbfff35834ad754bc74638df83dafd3dca5dab6de13832c533fdd19186765e301d004a03951f4cfad8be2ba6d
DIST Gnome2-1.046.tar.gz 80275 SHA256 a6c787232ab7e82a423a9ff5a49cec6bf586c1bb3c04c2052a91cdda5b66ae40 SHA512 0e4ee564b4514e63c3b66ef72aad6780e79d0f8d0376d7cbb925c579773d96d5fdf0918c90c0e1cc0f4b0be2c2d0043a54ec700361109c6b4b576627ca1d9efd WHIRLPOOL 3c95937b2f8ecf4bd463490b11445ebbc7ffed6be2c1ddf090ad1dd2219d2d0c87feb3928eb20121e829bae17867ce90e2a12a5af254f934b0e5bbdee2194961
355 changes: 355 additions & 0 deletions dev-perl/gnome2-perl/files/Gnome2-1.046-no-dot-inc.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,355 @@
From 6d397faa7006e0f3a67595d317e10d3bb81d8792 Mon Sep 17 00:00:00 2001
From: Kent Fredric <[email protected]>
Date: Sun, 22 Oct 2017 18:50:01 +1300
Subject: Fix tests failing on Perl 5.26 without '.' in @INC

eg: With PERL_USE_UNSAFE_INC=0 in ENV

This patch additionally creates safeguards against tests being allowed
to continue if the "do" call fails for any reason, as do does not
auto-fatalize, only warns at best.

Bug: https://rt.cpan.org/Ticket/Display.html?id=121440
Bug: https://bugs.gentoo.org/616954
---
t/Gnome.t | 4 +++-
t/GnomeApp.t | 4 +++-
t/GnomeAppBar.t | 4 +++-
t/GnomeAppHelper.t | 4 +++-
t/GnomeColorPicker.t | 4 +++-
t/GnomeConfig.t | 4 +++-
t/GnomeDateEdit.t | 4 +++-
t/GnomeDruid.t | 4 +++-
t/GnomeEntry.t | 4 +++-
t/GnomeFileEntry.t | 4 +++-
t/GnomeFontPicker.t | 4 +++-
t/GnomeHRef.t | 4 +++-
t/GnomeIconEntry.t | 4 +++-
t/GnomeIconList.t | 4 +++-
t/GnomeIconSelection.t | 4 +++-
t/GnomeIconTheme.t | 4 +++-
t/GnomePasswordDialog.t | 4 +++-
t/GnomePixmapEntry.t | 4 +++-
t/GnomePopupMenu.t | 4 +++-
t/GnomeScores.t | 4 +++-
t/GnomeThumbnail.t | 4 +++-
21 files changed, 63 insertions(+), 21 deletions(-)

diff --git a/t/Gnome.t b/t/Gnome.t
index 8b6d0c5..e62b662 100644
--- a/t/Gnome.t
+++ b/t/Gnome.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeApp.t b/t/GnomeApp.t
index d7fc143..49420c3 100644
--- a/t/GnomeApp.t
+++ b/t/GnomeApp.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeAppBar.t b/t/GnomeAppBar.t
index 22ac53d..b127b2c 100644
--- a/t/GnomeAppBar.t
+++ b/t/GnomeAppBar.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeAppHelper.t b/t/GnomeAppHelper.t
index 849bfe7..5ed6350 100644
--- a/t/GnomeAppHelper.t
+++ b/t/GnomeAppHelper.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeColorPicker.t b/t/GnomeColorPicker.t
index 7f7fba9..8dcee3e 100644
--- a/t/GnomeColorPicker.t
+++ b/t/GnomeColorPicker.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeConfig.t b/t/GnomeConfig.t
index 2c42a14..24973be 100644
--- a/t/GnomeConfig.t
+++ b/t/GnomeConfig.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeDateEdit.t b/t/GnomeDateEdit.t
index a8f2e33..addd98d 100644
--- a/t/GnomeDateEdit.t
+++ b/t/GnomeDateEdit.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeDruid.t b/t/GnomeDruid.t
index c209004..21a9fdd 100644
--- a/t/GnomeDruid.t
+++ b/t/GnomeDruid.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeEntry.t b/t/GnomeEntry.t
index c2d2b68..a0aa95a 100644
--- a/t/GnomeEntry.t
+++ b/t/GnomeEntry.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeFileEntry.t b/t/GnomeFileEntry.t
index 91befa8..1d572a9 100644
--- a/t/GnomeFileEntry.t
+++ b/t/GnomeFileEntry.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeFontPicker.t b/t/GnomeFontPicker.t
index a2e8e68..98520db 100644
--- a/t/GnomeFontPicker.t
+++ b/t/GnomeFontPicker.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeHRef.t b/t/GnomeHRef.t
index 256347b..484fa61 100644
--- a/t/GnomeHRef.t
+++ b/t/GnomeHRef.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeIconEntry.t b/t/GnomeIconEntry.t
index 35ef1e6..957efc0 100644
--- a/t/GnomeIconEntry.t
+++ b/t/GnomeIconEntry.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeIconList.t b/t/GnomeIconList.t
index 2bf9eb1..8067a70 100644
--- a/t/GnomeIconList.t
+++ b/t/GnomeIconList.t
@@ -11,7 +11,9 @@ use Test::More skip_all => "Seems to be broken", tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeIconSelection.t b/t/GnomeIconSelection.t
index 35117c9..566ae85 100644
--- a/t/GnomeIconSelection.t
+++ b/t/GnomeIconSelection.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeIconTheme.t b/t/GnomeIconTheme.t
index 9baeb4c..dda3582 100644
--- a/t/GnomeIconTheme.t
+++ b/t/GnomeIconTheme.t
@@ -13,7 +13,9 @@ Gnome2::VFS -> init();

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

skip("GnomeIconTheme is new in 2.0.6", TESTS)
unless (Gnome2 -> CHECK_VERSION(2, 0, 6));
diff --git a/t/GnomePasswordDialog.t b/t/GnomePasswordDialog.t
index 51c548c..38b2dcb 100644
--- a/t/GnomePasswordDialog.t
+++ b/t/GnomePasswordDialog.t
@@ -10,7 +10,9 @@ use Test::More tests => TESTS;
###############################################################################

SKIP: {
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

skip("GnomePasswordDialog and GnomeAuthenticationManager didn't appear until 2.4.0", TESTS)
unless (Gnome2 -> CHECK_VERSION(2, 4, 0));
diff --git a/t/GnomePixmapEntry.t b/t/GnomePixmapEntry.t
index 17e4996..dbfe42c 100644
--- a/t/GnomePixmapEntry.t
+++ b/t/GnomePixmapEntry.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomePopupMenu.t b/t/GnomePopupMenu.t
index 20275c9..151f410 100644
--- a/t/GnomePopupMenu.t
+++ b/t/GnomePopupMenu.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeScores.t b/t/GnomeScores.t
index 1b21ab2..82aa3a3 100644
--- a/t/GnomeScores.t
+++ b/t/GnomeScores.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

#############################################################################

diff --git a/t/GnomeThumbnail.t b/t/GnomeThumbnail.t
index ec0095f..ba24928 100644
--- a/t/GnomeThumbnail.t
+++ b/t/GnomeThumbnail.t
@@ -11,7 +11,9 @@ use Test::More tests => TESTS;

SKIP: {
our $application;
- do "t/TestBoilerplate";
+ do "./t/TestBoilerplate";
+ die $@ if $@;
+ die $! if $!;

skip("GnomeThumbnail is new in 2.0.6", 4)
unless (Gnome2 -> CHECK_VERSION(2, 0, 6));
--
2.14.2

30 changes: 30 additions & 0 deletions dev-perl/gnome2-perl/gnome2-perl-1.46.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_NAME=Gnome2
DIST_AUTHOR=XAOC
DIST_VERSION=1.046
inherit perl-module

DESCRIPTION="Perl interface to the 2.x series of the Gnome libraries"
HOMEPAGE="http://gtk2-perl.sourceforge.net/ ${HOMEPAGE}"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="x11-libs/gtk+:2
dev-perl/Gtk2
gnome-base/libgnomeui
gnome-base/libbonoboui
dev-perl/gnome2-canvas
>=dev-perl/glib-perl-1.40.0
dev-perl/gnome2-vfs-perl"
DEPEND="${RDEPEND}
dev-perl/ExtUtils-Depends
dev-perl/ExtUtils-PkgConfig"

PATCHES=( "${FILESDIR}/${DIST_NAME}-${DIST_VERSION}-no-dot-inc.patch" )

0 comments on commit 825d645

Please sign in to comment.