forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-arcade/performous: version bump
Package-Manager: portage-2.2.26
- Loading branch information
Michael Sterrett
committed
Apr 17, 2016
1 parent
0e3b3dd
commit 827062b
Showing
4 changed files
with
143 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
diff -ru performous-1.0.orig/game/CMakeLists.txt performous-1.0/game/CMakeLists.txt | ||
--- performous-1.0.orig/game/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400 | ||
+++ performous-1.0/game/CMakeLists.txt 2015-03-31 03:01:30.806061643 -0400 | ||
@@ -141,7 +141,7 @@ | ||
set(BIN_INSTALL .) # Straight to Program Files/Performous with no bin subfolder. | ||
set(SUBSYSTEM_WIN32 WIN32) | ||
else() | ||
- set(BIN_INSTALL bin) | ||
+ set(BIN_INSTALL @GENTOO_BINDIR@) | ||
endif() | ||
|
||
# Build main executable |
18 changes: 18 additions & 0 deletions
18
games-arcade/performous/files/performous-1.1-linguas.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
diff -ru performous-1.0.orig/lang/CMakeLists.txt performous-1.0/lang/CMakeLists.txt | ||
--- performous-1.0.orig/lang/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400 | ||
+++ performous-1.0/lang/CMakeLists.txt 2015-02-22 04:25:40.502252942 -0500 | ||
@@ -9,5 +9,13 @@ | ||
file(MAKE_DIRECTORY "${mobuild}") | ||
add_custom_command(OUTPUT "${mofile}" COMMAND "${Msgfmt_BIN}" -v "${pofile}" -o "${mofile}" MAIN_DEPENDENCY "${pofile}" COMMENT "Building ${language} locale" VERBATIM) | ||
add_custom_target("locale_${language}" ALL DEPENDS "${mofile}") # Make sure the mofiles are always built | ||
- install(FILES "${mofile}" DESTINATION "${LOCALE_DIR}/${language}/LC_MESSAGES") | ||
endforeach(language) | ||
+foreach(language $ENV{LINGUAS}) | ||
+ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po) | ||
+ if (EXISTS ${pofile}) | ||
+ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo) | ||
+ install(FILES ${mofile} DESTINATION | ||
+{LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo) | ||
+ endif() | ||
+endforeach(language) | ||
+ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,112 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
CMAKE_REMOVE_MODULES="yes" | ||
CMAKE_REMOVE_MODULES_LIST="FindALSA FindBoost FindFreetype FindGettext FindJpeg FindPng FindTiff FindZ" | ||
inherit eutils cmake-utils gnome2-utils games | ||
|
||
MY_PN=Performous | ||
MY_P=${MY_PN}-${PV} | ||
SONGS_PN=ultrastar-songs | ||
|
||
DESCRIPTION="SingStar GPL clone" | ||
HOMEPAGE="https://performous.org/" | ||
SRC_URI="https://github.com/performous/performous/archive/${PV}.tar.gz -> ${P}.tar.gz | ||
songs? ( | ||
mirror://sourceforge/performous/${SONGS_PN}-restricted-3.zip | ||
mirror://sourceforge/performous/${SONGS_PN}-jc-1.zip | ||
mirror://sourceforge/performous/${SONGS_PN}-libre-3.zip | ||
mirror://sourceforge/performous/${SONGS_PN}-shearer-1.zip | ||
)" | ||
|
||
LICENSE="GPL-2 | ||
songs? ( | ||
CC-BY-NC-SA-2.5 | ||
CC-BY-NC-ND-2.5 | ||
)" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="midi songs tools webcam" | ||
|
||
RDEPEND="dev-cpp/glibmm | ||
dev-cpp/libxmlpp | ||
media-libs/portaudio | ||
dev-libs/boost[threads(+)] | ||
dev-libs/glib:2 | ||
dev-libs/libxml2 | ||
gnome-base/librsvg | ||
media-gfx/imagemagick | ||
virtual/jpeg:0 | ||
media-libs/libpng:0 | ||
media-libs/libsdl2[joystick,video] | ||
virtual/ffmpeg | ||
virtual/opengl | ||
virtual/glu | ||
sys-libs/zlib | ||
virtual/libintl | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf | ||
x11-libs/pango | ||
media-libs/libepoxy | ||
midi? ( media-libs/portmidi ) | ||
webcam? ( media-libs/opencv )" | ||
DEPEND="${RDEPEND} | ||
sys-apps/help2man | ||
sys-devel/gettext" | ||
|
||
src_prepare() { | ||
cmake-utils_src_prepare | ||
epatch \ | ||
"${FILESDIR}"/${P}-gentoo.patch \ | ||
"${FILESDIR}"/${P}-linguas.patch | ||
sed -i \ | ||
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \ | ||
-e '/ Z /s/ Z / ZLIB /' \ | ||
-e 's/Jpeg/JPEG/' \ | ||
-e 's/Png/PNG/' \ | ||
game/CMakeLists.txt || die | ||
|
||
strip-linguas -u lang | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_enable tools TOOLS) | ||
$(cmake-utils_use_enable webcam WEBCAM) | ||
$(cmake-utils_use_enable midi MIDI) | ||
-DCMAKE_VERBOSE_MAKEFILE=TRUE | ||
-DSHARE_INSTALL="${GAMES_DATADIR}"/${PN} | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_compile() { | ||
cmake-utils_src_compile | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
if use songs ; then | ||
insinto "${GAMES_DATADIR}"/${PN} | ||
doins -r "${WORKDIR}/songs" | ||
fi | ||
dodoc docs/{Authors,instruments}.txt | ||
newicon -s scalable data/themes/default/icon.svg ${PN}.svg | ||
prepgamesdirs | ||
} | ||
|
||
pkg_preinst() { | ||
games_pkg_preinst | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
games_pkg_postinst | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |