Skip to content

Commit

Permalink
games-arcade/performous: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Michael Sterrett committed Apr 17, 2016
1 parent 0e3b3dd commit 827062b
Show file tree
Hide file tree
Showing 4 changed files with 143 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-arcade/performous/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST performous-1.0.tar.gz 3950246 SHA256 da9f39d281dbfe0849897dc98dc72cfc5a54be53f67c29b6430e57aefcc86b50 SHA512 9cdc6ad71248fede7df6fdc8ea4aca70a9c79be40e1d8c07c425f4a0e0c6e352233aee2ddeb586dcc6a7ea567b3e399aad9c5840475d8ce91c3ec7d4ec1eb30b WHIRLPOOL 2b9dbf8cec9e09bbff6a9490cbeb3fc04e88776c57fe80b9da04b91cdc2ac8ed9e129746e2adb4866ee52edb819229c6f52c45d2e301718a7c4e106ba27f14f1
DIST performous-1.1.tar.gz 3965473 SHA256 17d47da4092ffa0dc2087f69b8b9d4f920aa7d16ee80020bb5445f95d22b6a71 SHA512 6659aa03960e68d7af65b072e179e42b122d2a39d25229c6daf765146379a115a52e51c1dc2bc69081ea17fe7a22f1d7007b7cf9e09bc32d134c3ad8e3444dd1 WHIRLPOOL 9f82629afbe1146aaa8aed635214266f28c76d9ba1d1a7ecf9be2d0ff8684a11630ff4a32bf5cf852c353e894cd0a738f8d19ffbcd2a176104ca7f911c18da55
DIST ultrastar-songs-jc-1.zip 242698201 SHA256 b3a6f980926c4f1ce40bc763a406040855600ad005f4daa54e0ac324ce99a9ba SHA512 2f1b8416990c39617269cd6bb7271abdd4ebae65a9bac3dbb3f37cca26876bb7c79460a37597943a10a2d8bfcb5d2d9e2bf24084fe517a418e69f5c6111f6aea WHIRLPOOL 13bd3761b80b2a9491c6dbe2e535dbdc1e0f53b51d5070a0caf776da94c45c62a5a6980b4d95f629e0cfe5d6ef985428e5dcf6d4ba2f0931e6ea1d39d7f6674c
DIST ultrastar-songs-libre-3.zip 5289866 SHA256 739d1c678bb7c786499f5216faee420b9b56633142928aff60a7282dae755489 SHA512 820e3637a7b778c92ed1a8b925802134fa2146879b3e03e88cd412de5414635c90fe256dfaf984cfa3e8b07b7da8531dc3061b7c4e1bb4422127b469b2345e66 WHIRLPOOL 48d48e82ec8bd02376b3def5a3f215331c49853cf00439686cd577ebd51321e4a4e8b213d40356a46e2a2bd2a1bf6c1cb07b09195209833f4eb004166937bfe5
DIST ultrastar-songs-restricted-3.zip 10242651 SHA256 e05d81333f85e2c6c271a67f90beac453d64eac78cd95eec7214721182257a82 SHA512 70b987fec3705d6610625c1f30a7ff683a51bb6b7ee3174609c80dc31c1bccdb23dcb2c6ae8154e1b1d9ef115b914e27e73925878a3c5460b997fdde813456b8 WHIRLPOOL cb83550395bbbadb45ad982fd4586a4dca49ae96bbe7adfab1b925301fa69eb5581c24f0c5c8d3593851a80b3e86137eea7658753f720ad76bae6e5809c2feba
Expand Down
12 changes: 12 additions & 0 deletions games-arcade/performous/files/performous-1.1-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -ru performous-1.0.orig/game/CMakeLists.txt performous-1.0/game/CMakeLists.txt
--- performous-1.0.orig/game/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
+++ performous-1.0/game/CMakeLists.txt 2015-03-31 03:01:30.806061643 -0400
@@ -141,7 +141,7 @@
set(BIN_INSTALL .) # Straight to Program Files/Performous with no bin subfolder.
set(SUBSYSTEM_WIN32 WIN32)
else()
- set(BIN_INSTALL bin)
+ set(BIN_INSTALL @GENTOO_BINDIR@)
endif()

# Build main executable
18 changes: 18 additions & 0 deletions games-arcade/performous/files/performous-1.1-linguas.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
diff -ru performous-1.0.orig/lang/CMakeLists.txt performous-1.0/lang/CMakeLists.txt
--- performous-1.0.orig/lang/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
+++ performous-1.0/lang/CMakeLists.txt 2015-02-22 04:25:40.502252942 -0500
@@ -9,5 +9,13 @@
file(MAKE_DIRECTORY "${mobuild}")
add_custom_command(OUTPUT "${mofile}" COMMAND "${Msgfmt_BIN}" -v "${pofile}" -o "${mofile}" MAIN_DEPENDENCY "${pofile}" COMMENT "Building ${language} locale" VERBATIM)
add_custom_target("locale_${language}" ALL DEPENDS "${mofile}") # Make sure the mofiles are always built
- install(FILES "${mofile}" DESTINATION "${LOCALE_DIR}/${language}/LC_MESSAGES")
endforeach(language)
+foreach(language $ENV{LINGUAS})
+ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
+ if (EXISTS ${pofile})
+ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
+ install(FILES ${mofile} DESTINATION
+{LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
+ endif()
+endforeach(language)
+
112 changes: 112 additions & 0 deletions games-arcade/performous/performous-1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,112 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
CMAKE_REMOVE_MODULES="yes"
CMAKE_REMOVE_MODULES_LIST="FindALSA FindBoost FindFreetype FindGettext FindJpeg FindPng FindTiff FindZ"
inherit eutils cmake-utils gnome2-utils games

MY_PN=Performous
MY_P=${MY_PN}-${PV}
SONGS_PN=ultrastar-songs

DESCRIPTION="SingStar GPL clone"
HOMEPAGE="https://performous.org/"
SRC_URI="https://github.com/performous/performous/archive/${PV}.tar.gz -> ${P}.tar.gz
songs? (
mirror://sourceforge/performous/${SONGS_PN}-restricted-3.zip
mirror://sourceforge/performous/${SONGS_PN}-jc-1.zip
mirror://sourceforge/performous/${SONGS_PN}-libre-3.zip
mirror://sourceforge/performous/${SONGS_PN}-shearer-1.zip
)"

LICENSE="GPL-2
songs? (
CC-BY-NC-SA-2.5
CC-BY-NC-ND-2.5
)"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="midi songs tools webcam"

RDEPEND="dev-cpp/glibmm
dev-cpp/libxmlpp
media-libs/portaudio
dev-libs/boost[threads(+)]
dev-libs/glib:2
dev-libs/libxml2
gnome-base/librsvg
media-gfx/imagemagick
virtual/jpeg:0
media-libs/libpng:0
media-libs/libsdl2[joystick,video]
virtual/ffmpeg
virtual/opengl
virtual/glu
sys-libs/zlib
virtual/libintl
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/pango
media-libs/libepoxy
midi? ( media-libs/portmidi )
webcam? ( media-libs/opencv )"
DEPEND="${RDEPEND}
sys-apps/help2man
sys-devel/gettext"

src_prepare() {
cmake-utils_src_prepare
epatch \
"${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-linguas.patch
sed -i \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
-e '/ Z /s/ Z / ZLIB /' \
-e 's/Jpeg/JPEG/' \
-e 's/Png/PNG/' \
game/CMakeLists.txt || die

strip-linguas -u lang
}

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_enable tools TOOLS)
$(cmake-utils_use_enable webcam WEBCAM)
$(cmake-utils_use_enable midi MIDI)
-DCMAKE_VERBOSE_MAKEFILE=TRUE
-DSHARE_INSTALL="${GAMES_DATADIR}"/${PN}
)
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
if use songs ; then
insinto "${GAMES_DATADIR}"/${PN}
doins -r "${WORKDIR}/songs"
fi
dodoc docs/{Authors,instruments}.txt
newicon -s scalable data/themes/default/icon.svg ${PN}.svg
prepgamesdirs
}

pkg_preinst() {
games_pkg_preinst
gnome2_icon_savelist
}

pkg_postinst() {
games_pkg_postinst
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 827062b

Please sign in to comment.