Skip to content

Commit

Permalink
mail-client/alot: add Python 3.9
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Feb 27, 2021
1 parent d4116cf commit 829785b
Show file tree
Hide file tree
Showing 2 changed files with 14 additions and 12 deletions.
11 changes: 6 additions & 5 deletions mail-client/alot/alot-0.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{7,8} )
PYTHON_COMPAT=( python3_{7,8,9} )

inherit distutils-r1

Expand All @@ -26,9 +26,12 @@ RDEPEND="
dev-python/twisted[${PYTHON_USEDEP}]
net-mail/mailbase
net-mail/notmuch[crypt,python,${PYTHON_USEDEP}]
"
"
BDEPEND="
dev-python/sphinx[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"

PATCHES=(
Expand All @@ -37,8 +40,6 @@ PATCHES=(

distutils_enable_tests unittest

BDEPEND+=" test? ( dev-python/mock[${PYTHON_USEDEP}] ) "

python_compile_all() {
emake -C docs man
use doc && emake -C docs html
Expand Down
15 changes: 8 additions & 7 deletions mail-client/alot/alot-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{7,8} )
PYTHON_COMPAT=( python3_{7,8,9} )

inherit distutils-r1

Expand Down Expand Up @@ -33,19 +33,20 @@ RDEPEND="
>=dev-python/twisted-18.4[${PYTHON_USEDEP}]
net-mail/mailbase
net-mail/notmuch[crypt,python]
"
"
DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
)
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
)
"
"

PATCHES=(
"${FILESDIR}/${PV}-0001-remove-non-working-test.patch"
"${FILESDIR}/${PV}-0002-update-reference-to-envelope-body.patch"
)
)

distutils_enable_tests setup.py

Expand Down

0 comments on commit 829785b

Please sign in to comment.