Skip to content

Commit

Permalink
net-im/libcommuni: bump to newest snapshot
Browse files Browse the repository at this point in the history
As bonus all tests can be now enabled.

Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Jul 11, 2020
1 parent 12c9e44 commit 82b84ec
Show file tree
Hide file tree
Showing 2 changed files with 80 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-im/libcommuni/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libcommuni-3.5.0_p20190110.tar.gz 471278 BLAKE2B 2836a5ae01b08aac624c899a40712a9c452fc5b8f242906063936e48bd59306758cc70ea07beaf8488d228d6029c8128e343bbd59b1bfeff9bb2dccda0153b59 SHA512 9da065ef6b0589f7406d8c66b46f9f8d3d16325b59b7281153233b1a8d2bf98cdd35ee4e416237ac760dfc07531578aa7432226932976b9bbf36209bed5db72c
DIST libcommuni-3.5.0_p20200711.tar.gz 471839 BLAKE2B 37a02c473496a0fe9394a8b019678afa96b07b9272556fd538d42d9ec296b34ad4c76b3110ff96732bccbed59f2faeedf80bd7782e7a6e395252c6430cb88fa7 SHA512 578e2f70bdfa0e62eb3acac4e8deb2f6f0c1cd5f0a5e559dae79d2a808b27d3cf63ede146a65026e156d988097a5b7903793acadcd7e9ac567f65c59e6738ed3
79 changes: 79 additions & 0 deletions net-im/libcommuni/libcommuni-3.5.0_p20200711.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

EGIT_COMMIT="85fc0d9d8659269b00499975d184d75e67f63a9f"

inherit qmake-utils

DESCRIPTION="A cross-platform IRC framework written with Qt"
HOMEPAGE="https://communi.github.io/"
SRC_URI="https://github.com/communi/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples qml test +uchardet"
RESTRICT="!test? ( test )"

RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
examples? ( || (
dev-qt/qtgui:5[X(-)]
dev-qt/qtgui:5[xcb(-)]
) )
uchardet? ( app-i18n/uchardet )
!uchardet? ( dev-libs/icu:= )
"

DEPEND="
${RDEPEND}
test? ( dev-qt/qttest:5 )
"

S="${WORKDIR}/${PN}-${EGIT_COMMIT}"

src_configure() {
local myqmakeargs=( libcommuni.pro
# Disables compile run-time benchmarks, as they don't make any sense
-config no_benchmarks
# Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
-config no_rpath
# Compile libcommuni always in Release mode, as Debug seems to do nothing
-config release
# Don't silence all compile messages
-config verbose
-config $(usex examples '' 'no_')examples
-config $(usex qml '' 'no_')qml
-config $(usex test '' 'no_')tests
-config $(usex uchardet 'no_' '')icu
-config $(usex uchardet '' 'no_')uchardet )

eqmake5 "${myqmakeargs[@]}"
}

src_test() {
# This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
# otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
# The test will fail, when libcommuni is emerged with USE="uchardet" and
# libcommuni is already installed with USE="-uchardat", or the other way around.
find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
local -x LD_LIBRARY_PATH="${S}/lib"

default
}

src_install() {
emake install INSTALL_ROOT="${D}"

if use examples; then
local examples=( "bot" "client" "minimal" "qmlbot" "quick" )
for example in ${examples[@]}; do
newbin examples/"${example}"/"${example}" libcommuni."${example}"
done
fi

einstalldocs
}

0 comments on commit 82b84ec

Please sign in to comment.