Skip to content

Commit

Permalink
dev-python/elasticsearch: add 8.13.0
Browse files Browse the repository at this point in the history
Signed-off-by: Alfred Wingate <[email protected]>
Closes: gentoo#35962
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
parona-source authored and mgorny committed Mar 29, 2024
1 parent 03f7274 commit 82e7620
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/elasticsearch/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST elasticsearch-py-8.12.1.gh.tar.gz 909340 BLAKE2B 3c5823ccdfa291406b53cbee9d85d65703eb4bc91cf1e244afd1da355c6ed034c8c5f1eca0fca2a3497f2b49c20545f2dfbea8fd4944fe0a8933a753edbd02a2 SHA512 51206fd4dace033a698dc7c40a568f81d622b6d54c7f930a3bbbd719347dea656f82f04ab517a688d5c0fe835d73d4a041ff1945a2fa530c71a7c7c9621c9b00
DIST elasticsearch-py-8.13.0.gh.tar.gz 1052777 BLAKE2B 90d6677fe40a635f33e37b4da90c0d8c6d3cde10a815932ee91b5e411162322edc22d13fe231b5d514f350a2b448ce1722e75426b5b5e08b711f3193d2963453 SHA512 fee1ba95d65be424f4ffeb65898bbafd5860358864d9706c82be663139e4543bce54c57bb21188c5ab6cdf5e15323cb1698bfb17715a7be38f844d3781840c97
75 changes: 75 additions & 0 deletions dev-python/elasticsearch/elasticsearch-8.13.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{11..12} )

inherit distutils-r1

MY_P="elasticsearch-py-${PV}"
DESCRIPTION="Official Elasticsearch client library for Python"
HOMEPAGE="
https://ela.st/es-python
https://github.com/elastic/elasticsearch-py/
https://pypi.org/project/elasticsearch/
"
SRC_URI="
https://github.com/elastic/elasticsearch-py/archive/v${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}

LICENSE="Apache-2.0"
SLOT="0/$(ver_cut 1)"
KEYWORDS="~amd64"

RDEPEND="
<dev-python/aiohttp-4[${PYTHON_USEDEP}]
>=dev-python/aiohttp-3[${PYTHON_USEDEP}]
<dev-python/elastic-transport-9[${PYTHON_USEDEP}]
>=dev-python/elastic-transport-8.13[${PYTHON_USEDEP}]
>=dev-python/orjson-3[${PYTHON_USEDEP}]
<dev-python/requests-3[${PYTHON_USEDEP}]
>=dev-python/requests-2.4[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
${RDEPEND}
dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/opentelemetry-api[${PYTHON_USEDEP}]
dev-python/opentelemetry-sdk[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
dev-python/unasync[${PYTHON_USEDEP}]
)
"

EPYTEST_IGNORE=(
# REST api tests are a black hole for effort. It downloads the tests
# so its an ever moving target. It also requires effort to blacklist
# tests for apis which are license restricted.
"test_elasticsearch/test_server/test_rest_api_spec.py"
# Counting deprecation warnings from python is bound to fail even
# if all are fixed in this package. Not worth it.
"test_elasticsearch/test_client/test_deprecated_options.py"
# Running daemon for tests is finicky and upstream CI fails at it
# as well.
"test_elasticsearch/test_server/"
"test_elasticsearch/test_async/test_server/"
)

distutils_enable_sphinx docs/sphinx \
dev-python/sphinx-autodoc-typehints \
dev-python/sphinx-rtd-theme
distutils_enable_tests pytest

python_test() {
local -x TEST_WITH_OTEL=1
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -o addopts= -p asyncio
}

0 comments on commit 82e7620

Please sign in to comment.