Skip to content

Commit

Permalink
dev-db/opendbx: Fix build failures and missing dependencies
Browse files Browse the repository at this point in the history
Non-maintainer commit

Closes: https://bugs.gentoo.org/548990
Closes: https://bugs.gentoo.org/549302
Closes: https://bugs.gentoo.org/665862
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Brian Evans <[email protected]>
  • Loading branch information
Brian Evans committed Feb 8, 2019
1 parent 8aa9910 commit 82e970b
Show file tree
Hide file tree
Showing 4 changed files with 90 additions and 51 deletions.
45 changes: 45 additions & 0 deletions dev-db/opendbx/files/opendbx-doxy.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
--- a/doc/Doxyfile.in 2009-07-13 16:30:48.000000000 -0400
+++ b/doc/Doxyfile.in 2019-02-08 13:22:51.088064431 -0500
@@ -46,6 +46,8 @@
DISTRIBUTE_GROUP_DOC = NO
SUBGROUPING = YES
TYPEDEF_HIDES_STRUCT = NO
+EXTENSION_MAPPING = no_extension=C++
+
#---------------------------------------------------------------------------
# Build related configuration options
#---------------------------------------------------------------------------
@@ -75,7 +77,6 @@
ENABLED_SECTIONS =
MAX_INITIALIZER_LINES = 30
SHOW_USED_FILES = YES
-SHOW_DIRECTORIES = NO
SHOW_FILES = YES
SHOW_NAMESPACES = YES
FILE_VERSION_FILTER =
@@ -182,7 +183,6 @@
HTML_HEADER =
HTML_FOOTER =
HTML_STYLESHEET =
-HTML_ALIGN_MEMBERS = YES
GENERATE_HTMLHELP = NO
GENERATE_DOCSET = NO
DOCSET_FEEDNAME = "Doxygen generated docs"
@@ -235,8 +235,6 @@
#---------------------------------------------------------------------------
GENERATE_XML = YES
XML_OUTPUT = xml
-XML_SCHEMA =
-XML_DTD =
XML_PROGRAMLISTING = YES
#---------------------------------------------------------------------------
# configuration options for the AutoGen Definitions output
@@ -276,7 +274,7 @@
MSCGEN_PATH =
HIDE_UNDOC_RELATIONS = YES
HAVE_DOT = NO
-DOT_FONTNAME = FreeSans
+DOT_FONTNAME = Helvetica
DOT_FONTPATH =
CLASS_GRAPH = YES
COLLABORATION_GRAPH = YES
28 changes: 13 additions & 15 deletions dev-db/opendbx/opendbx-1.4.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
EAPI="6"

inherit flag-o-matic multilib
inherit flag-o-matic

DESCRIPTION="OpenDBX - A database abstraction layer"
HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
Expand All @@ -15,28 +15,22 @@ KEYWORDS="amd64 x86"
IUSE="firebird +mysql oracle postgres sqlite"
RESTRICT="firebird? ( bindist )"

DEPEND="mysql? ( virtual/mysql )
RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
oracle? ( dev-db/oracle-instantclient-basic )
firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"

pkg_setup() {
if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
then
ewarn "You should enable at least one of the following USE flags:"
ewarn "firebird, mysql, oracle, postgres or sqlite"
fi
REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"

PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )

pkg_setup() {
if use oracle && [[ ! -d ${ORACLE_HOME} ]]
then
die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
fi

use mysql && append-cppflags -I/usr/include/mysql
use firebird && append-cppflags -I/opt/firebird/include
use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
}

src_configure() {
Expand All @@ -48,6 +42,10 @@ src_configure() {
use postgres && backends="${backends} pgsql"
use sqlite && backends="${backends} sqlite3"

use mysql && append-cppflags -I/usr/include/mysql
use firebird && append-cppflags -I/opt/firebird/include
use oracle && append-ldflags -L"${ORACLE_HOME}"/lib

econf --with-backends="${backends}"
}

Expand Down
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
EAPI="6"

inherit flag-o-matic multilib
inherit flag-o-matic

DESCRIPTION="OpenDBX - A database abstraction layer"
HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
Expand All @@ -15,28 +15,22 @@ KEYWORDS="~amd64 ~x86"
IUSE="firebird +mysql oracle postgres sqlite"
RESTRICT="firebird? ( bindist )"

DEPEND="mysql? ( virtual/mysql )
RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
oracle? ( dev-db/oracle-instantclient-basic )
firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"

pkg_setup() {
if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
then
ewarn "You should enable at least one of the following USE flags:"
ewarn "firebird, mysql, oracle, postgres or sqlite"
fi
REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"

PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )

pkg_setup() {
if use oracle && [[ ! -d ${ORACLE_HOME} ]]
then
die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
fi

use mysql && append-cppflags -I/usr/include/mysql
use firebird && append-cppflags -I/opt/firebird/include
use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
}

src_configure() {
Expand All @@ -48,16 +42,20 @@ src_configure() {
use postgres && backends="${backends} pgsql"
use sqlite && backends="${backends} sqlite3"

econf --with-backends="${backends}" || die "econf failed"
use mysql && append-cppflags -I/usr/include/mysql
use firebird && append-cppflags -I/opt/firebird/include
use oracle && append-ldflags -L"${ORACLE_HOME}"/lib

econf --with-backends="${backends}"
}

src_compile() {
# bug #322221
emake -j1 || die "emake failed"
emake -j1
}

src_install() {
emake -j1 install DESTDIR="${D}" || die "make install failed"
emake -j1 install DESTDIR="${D}"
dodoc AUTHORS ChangeLog README

rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
Expand Down
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
EAPI="6"

inherit flag-o-matic multilib
inherit flag-o-matic

MY_PN="lib${PN}"
MY_P="${MY_PN}-${PV}"
Expand All @@ -18,30 +18,24 @@ KEYWORDS="~x64-solaris"
IUSE="firebird +mysql oracle postgres sqlite"
RESTRICT="firebird? ( bindist )"

DEPEND="mysql? ( virtual/mysql )
RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
oracle? ( dev-db/oracle-instantclient-basic )
firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"

S="${WORKDIR}"/${MY_P}

pkg_setup() {
if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
then
ewarn "You should enable at least one of the following USE flags:"
ewarn "firebird, mysql, oracle, postgres or sqlite"
fi
REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"

PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )

pkg_setup() {
if use oracle && [[ ! -d ${ORACLE_HOME} ]]
then
die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
fi

use mysql && append-cppflags -I/usr/include/mysql
use firebird && append-cppflags -I/opt/firebird/include
use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
}

src_configure() {
Expand All @@ -53,16 +47,20 @@ src_configure() {
use postgres && backends="${backends} pgsql"
use sqlite && backends="${backends} sqlite3"

econf --with-backends="${backends}" || die "econf failed"
use mysql && append-cppflags -I/usr/include/mysql
use firebird && append-cppflags -I/opt/firebird/include
use oracle && append-ldflags -L"${ORACLE_HOME}"/lib

econf --with-backends="${backends}"
}

src_compile() {
# bug #322221
emake -j1 || die "emake failed"
emake -j1
}

src_install() {
emake -j1 install DESTDIR="${D}" || die "make install failed"
emake -j1 install DESTDIR="${D}"
dodoc AUTHORS ChangeLog README

rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
Expand Down

0 comments on commit 82e970b

Please sign in to comment.