Skip to content

Commit

Permalink
dev-cpp/gstreamermm: version bump 1.4.3 → 1.8.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
EvaSDK committed Aug 20, 2017
1 parent 6017030 commit 82fa509
Show file tree
Hide file tree
Showing 5 changed files with 180 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/gstreamermm/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gstreamermm-0.10.11.tar.xz 5840552 SHA256 12b5f377363594a69cb79f2f5cd0a8b1813ca6553680c3216e6354cfd682ebc6 SHA512 2ad370f6902dcb4663ea801bdbbf744a98de9e24fc04f27b5044a4a95337168e2bb195761a07ac9c1011f9ed4936287fcc5f4c2b984f0a362b429d05be7d3909 WHIRLPOOL d9be72d4691b9b0769b75819ca9403a2df7f1dbdad4974e4b26e4fd87d4b7ea0503fb2ba6a500a008ec9d1c29f6677e61649798801e6babf7e4d7b8562cc72f2
DIST gstreamermm-1.4.3.tar.xz 5886048 SHA256 f1c11ee1cf7537d77de7f8d486e09c5140cc4bb78882849718cd88959a55462e SHA512 ea4d281a4f3b79113fc3a0474e23d82442facac6eaf66215de412310b9c306aa5d586ee5570087d94d90acbfc09c5766edba1414b50f0fd9a3111cda610f5671 WHIRLPOOL b8bee1e9672c5ca527718e1826a4b486ea47fd772b079dddb532716c2082bb4cca55823a8b3dcd5eabe8819ee944b0cb68740c6b986ff329b71dad47240fe904
DIST gstreamermm-1.8.0.tar.xz 3848488 SHA256 3ee3c1457ea2c32c1e17b784faa828f414ba27a9731532bf26d137a2ad999a44 SHA512 4d458c8a2efde683dabd00308ddde6fbf732788fb9282cb2eeab9f3a01dc9b4a03bfbbe9991cd50ef3092cec861034b3a34a6c5e364582dbfc6b1a0d5bb935fe WHIRLPOOL 77b7bf6c3f6d96e26e41a80116b417e6012cacaaf884e7705218c694bc55aceeb7d065996ec02c2c3744975f146cced365974d853ef98195b069b9d6982b71ae
42 changes: 42 additions & 0 deletions dev-cpp/gstreamermm/files/1.8.0-add-missing-header.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
From 73b25333ca3778ccf4322f47abbcbc507c31890d Mon Sep 17 00:00:00 2001
From: Marcin Kolny <[email protected]>
Date: Wed, 12 Oct 2016 19:37:45 +0200
Subject: [PATCH] Gst::Caps: include missing header

---
gstreamer/src/caps.ccg | 1 -
gstreamer/src/caps.hg | 2 +-
2 files changed, 1 insertion(+), 2 deletions(-)

diff --git a/gstreamer/src/caps.ccg b/gstreamer/src/caps.ccg
index 93acf7e..782f8e2 100644
--- a/gstreamer/src/caps.ccg
+++ b/gstreamer/src/caps.ccg
@@ -17,7 +17,6 @@
* Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*/

-#include <gstreamermm/structure.h>
#include <gstreamermm/capsfeatures.h>

namespace Gst
diff --git a/gstreamer/src/caps.hg b/gstreamer/src/caps.hg
index 7969cdc..bf0b950 100644
--- a/gstreamer/src/caps.hg
+++ b/gstreamer/src/caps.hg
@@ -18,6 +18,7 @@
*/

#include <gstreamermm/miniobject.h>
+#include <gstreamermm/structure.h>

_DEFS(gstreamermm,gst)

@@ -28,7 +29,6 @@ _WRAP_ENUM(CapsIntersectMode, GstCapsIntersectMode, NO_GTYPE)

_WRAP_ENUM(CapsFlags, GstCapsFlags)

-class Structure;
class CapsFeatures;

/** Structure describing sets of media formats.
23 changes: 23 additions & 0 deletions dev-cpp/gstreamermm/files/1.8.0-fix-wrapping.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
From 3440f119a7d03d50688f303b3456695c4d8e5187 Mon Sep 17 00:00:00 2001
From: Marcin Kolny <[email protected]>
Date: Sun, 16 Oct 2016 22:20:42 +0200
Subject: [PATCH] Gst::Pad: fix method wrapper

* gstreamer/src/pad.hg: fix method proxy_query_accept_caps()
---
gstreamer/src/pad.hg | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gstreamer/src/pad.hg b/gstreamer/src/pad.hg
index cf0d78e..f2ff258 100644
--- a/gstreamer/src/pad.hg
+++ b/gstreamer/src/pad.hg
@@ -236,7 +236,7 @@ public:

_WRAP_METHOD(bool query_accept_caps(const Glib::RefPtr<const Gst::Caps>& caps) const, gst_pad_query_accept_caps)
_WRAP_METHOD(bool proxy_query_caps(const Glib::RefPtr<Gst::Query>& query) const, gst_pad_proxy_query_caps)
- _WRAP_METHOD(bool proxy_query_accept_caps(const Glib::RefPtr<Gst::Query>& query) const, gst_pad_proxy_accept_caps)
+ _WRAP_METHOD(bool proxy_query_accept_caps(const Glib::RefPtr<Gst::Query>& query) const, gst_pad_proxy_query_accept_caps)
_WRAP_METHOD(bool peer_query_accept_caps(const Glib::RefPtr<const Gst::Caps>& caps) const, gst_pad_peer_query_accept_caps)
_WRAP_METHOD(bool peer_query_position(Gst::Format format, gint64& cur) const, gst_pad_peer_query_position)
_WRAP_METHOD(bool peer_query_duration(Gst::Format format, gint64& duration) const, gst_pad_peer_query_duration)
42 changes: 42 additions & 0 deletions dev-cpp/gstreamermm/files/1.8.0-gst-bad-pkgconfig-cflags.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
From 3a4698e1c6e2b2c6c703f07687cc485ada734d60 Mon Sep 17 00:00:00 2001
From: Marcin Kolny <[email protected]>
Date: Tue, 15 Nov 2016 21:57:57 +0100
Subject: [PATCH] plugins-bad: use flags and libs from gstreamer-gl pkg config
file

---
examples/Makefile.am | 2 +-
gst-plugins-bad/gstreamermm-plugins-bad/Makefile.am | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/examples/Makefile.am b/examples/Makefile.am
index a08d446..200ab02 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -15,7 +15,7 @@

AUTOMAKE_OPTIONS = subdir-objects

-examples_cppflags = $(GSTREAMERMM_CFLAGS)
+examples_cppflags = $(GSTREAMERMM_CFLAGS) $(GSTREAMERMM_PLUGINS_BAD_CFLAGS) $(GSTREAMERMM_GL_CFLAGS)
gstreamermm_includes = -I$(top_builddir)/gstreamer $(if $(srcdir:.=),-I$(top_srcdir)/gstreamer)
local_libgstreamermm = $(top_builddir)/gstreamer/gstreamermm/libgstreamermm-$(GSTREAMERMM_API_VERSION).la

diff --git a/gst-plugins-bad/gstreamermm-plugins-bad/Makefile.am b/gst-plugins-bad/gstreamermm-plugins-bad/Makefile.am
index eb46188..859f0ba 100644
--- a/gst-plugins-bad/gstreamermm-plugins-bad/Makefile.am
+++ b/gst-plugins-bad/gstreamermm-plugins-bad/Makefile.am
@@ -23,11 +23,11 @@ include $(top_srcdir)/build/compile-binding.am
local_includes = -I$(top_builddir)/gstreamer $(if $(srcdir:.=),-I$(top_srcdir)/gstreamer)
local_cppflags = $(binding_includes) $(local_includes) $(binding_cppflags) -DGSTREAMERMM_PLUGINS_BAD_BUILD=1

-AM_CPPFLAGS = $(local_cppflags) $(GSTREAMERMM_PLUGINS_BAD_CFLAGS) $(GSTREAMERMM_CFLAGS)
+AM_CPPFLAGS = $(local_cppflags) $(GSTREAMERMM_PLUGINS_BAD_CFLAGS) $(GSTREAMERMM_CFLAGS) $(GSTREAMERMM_GL_CFLAGS)
AM_CXXFLAGS = $(GSTREAMERMM_WXXFLAGS)

local_libadd = $(top_builddir)/gstreamer/gstreamermm/libgstreamermm-$(GSTREAMERMM_API_VERSION).la

libgstreamermm_plugins_bad_@GSTREAMERMM_API_VERSION@_la_SOURCES = $(binding_sources)
libgstreamermm_plugins_bad_@GSTREAMERMM_API_VERSION@_la_LDFLAGS = -no-undefined -version-info $(GSTREAMERMM_SO_VERSION)
-libgstreamermm_plugins_bad_@GSTREAMERMM_API_VERSION@_la_LIBADD = $(GSTREAMERMM_PLUGINS_BAD_LIBS) $(local_libadd)
+libgstreamermm_plugins_bad_@GSTREAMERMM_API_VERSION@_la_LIBADD = $(GSTREAMERMM_PLUGINS_BAD_LIBS) $(GSTREAMERMM_GL_LIBS) $(local_libadd)
72 changes: 72 additions & 0 deletions dev-cpp/gstreamermm/gstreamermm-1.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_EAUTORECONF="yes"

inherit gnome2 virtualx

DESCRIPTION="C++ interface for GStreamer"
HOMEPAGE="https://gstreamer.freedesktop.org/bindings/cplusplus.html"

LICENSE="LGPL-2.1"
SLOT="1.0/1"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc examples opengl test"

RDEPEND="
>=media-libs/gstreamer-${PV}:1.0
>=media-libs/gst-plugins-base-${PV}:1.0
>=media-libs/gst-plugins-bad-${PV}:1.0[opengl?]
>=dev-cpp/glibmm-2.47.6:2
>=dev-cpp/libxmlpp-2.14:2.6
>=dev-libs/libsigc++-2:2
"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
app-doc/doxygen
dev-libs/libxslt
media-gfx/graphviz )
test? (
dev-cpp/gtest
>=media-libs/gst-plugins-base-${PV}:1.0[X,ogg,theora,vorbis]
>=media-libs/gst-plugins-good-${PV}:1.0
>=media-plugins/gst-plugins-jpeg-${PV}:1.0 )
"
# dev-cpp/mm-common"
# eautoreconf needs mm-common

# Installs reference docs into /usr/share/doc/gstreamermm-1.0/
# but that's okay, because the rest of dev-cpp/*mm stuff does the same

PATCHES=(
# Upstream patches
"${FILESDIR}"/1.8.0-add-missing-header.patch
"${FILESDIR}"/1.8.0-gst-bad-pkgconfig-cflags.patch
"${FILESDIR}"/1.8.0-fix-wrapping.patch
)

src_prepare() {
if ! use examples; then
# don't waste time building examples
sed -e 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
-i Makefile.am Makefile.in || die
fi

sed -e 's/ -Werror/ /' -i tests/Makefile.am tests/Makefile.in || die

gnome2_src_prepare
}

src_configure() {
gnome2_src_configure \
$(use_enable doc documentation) \
$(use_enable opengl gl) \
$(use_enable test unittests)
}

src_test() {
# running tests in parallel fails
virtx emake -j1 check
}

0 comments on commit 82fa509

Please sign in to comment.