Skip to content

Commit

Permalink
dev-ruby/msgpack: add 1.2.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
graaff committed Mar 3, 2018
1 parent cd851ba commit 83512a7
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/msgpack/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST msgpack-1.2.2.gem 78848 BLAKE2B b3ae75ebd6159a78c6a31ecc45bfe0474d5fe91672b6c9dfe96a561b07ebb5bc9ebf91477bc370fba199c5a8c187faa4995a90aa0209b8af81e6d06cd2e58b7b SHA512 7f7fa3350485c3888a42a78fc53f91029208bc6ee483b4c1a082dfa515d435295b6d2f57e9c4cc3f7805349e4a21854585997075d2535c0343af4ae1ec66a802
DIST msgpack-1.2.4.gem 78848 BLAKE2B 5e4c0f75e051bd1da800257600a44a712a18430b77b1c6ceebf1b6452bda0169fa7fdbd3dc5230b76da226965b32e1581ab3c27be8416c00bd90e827b22bce51 SHA512 dc2267a8c2f673ce6c8910e09841ec01bd84f06baf68b9c9ba2c0acb905d197ca82f481748ceb7edb7dff5359c4d983f381882923a1d935bd5bc536bd2fa60be
44 changes: 44 additions & 0 deletions dev-ruby/msgpack/msgpack-1.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby22 ruby23 ruby24"

RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.rdoc"

inherit multilib ruby-fakegem

DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
HOMEPAGE="https://msgpack.org/"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x86-fbsd"
IUSE="doc"

ruby_add_bdepend "doc? ( dev-ruby/yard )"

all_ruby_prepare() {
sed -i -e '/bundler/I s:^:#:' Rakefile || die

# Remove jruby-specific specs that are run also for other rubies.
rm -rf spec/jruby || die

sed -i -e '/git ls-files/d' msgpack.gemspec || die
}

each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."

# rb_num2int is not inlined on 32 bit arches but also not explicitly
# defined, bug 582968
sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
}

each_ruby_compile() {
emake V=1 -Cext/${PN}
cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
}

0 comments on commit 83512a7

Please sign in to comment.