forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
www-client/vivaldi-snapshot: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Jeroen Roovers
committed
Jun 23, 2017
1 parent
ab12634
commit 837fa19
Showing
2 changed files
with
106 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST vivaldi-snapshot-1.11.880.3_p1-amd64.deb 50665460 SHA256 a5102130e7a8595aee5d9b4fd2f45a7225d2d8dcfb05b21630b5c0338447e54b SHA512 465091acd848228505336448549d9bb8861d914a06a2ca95a673c6e457e4ccb101c27908721609cfe1e81fc0818869c5e217bdf3249e70949cf9025cfe05fcec WHIRLPOOL 9003c1fb1456d665c9ab01c1b41fd2b70a997c03f3972c3080dbaaf8cfe932751886f95e472db8e73bfaaf2a8af87c09e0ae3f7773ea15c7342a4df4c7ced58c | ||
DIST vivaldi-snapshot-1.11.882.4_p1-amd64.deb 50659760 SHA256 1d67849a875703a8a6f953d3d21d81a6eb9f0041ad24ccaddaec25673349bd75 SHA512 47c280bbad55796736853c4e6a5aca7a0b40ef0121117621cbebdf3333b3724c28c2c5132ca4d2ac8d57f2f89b828f7d63c4521efb2a4a35ae5620d4e4a1ee4f WHIRLPOOL 17a989e811b5c67418b5f4d678bc9522dfe1033b79f41b146e943f6d7e0dc1d9bf7a28ff2d6cc8a3b51e65533cfc0cdf2851d20336b6272298f57ddf26ea63ca |
105 changes: 105 additions & 0 deletions
105
www-client/vivaldi-snapshot/vivaldi-snapshot-1.11.882.4_p1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,105 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
CHROMIUM_LANGS=" | ||
am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi | ||
hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv | ||
sw ta te th tr uk vi zh-CN zh-TW | ||
" | ||
inherit chromium-2 eutils multilib unpacker toolchain-funcs | ||
|
||
VIVALDI_HOME="opt/${PN}" | ||
DESCRIPTION="A new browser for our friends" | ||
HOMEPAGE="http://vivaldi.com/" | ||
VIVALDI_BASE_URI="https://downloads.vivaldi.com/snapshot/${PN}_${PV/_p/-}_" | ||
SRC_URI=" | ||
amd64? ( ${VIVALDI_BASE_URI}amd64.deb -> ${P}-amd64.deb ) | ||
" | ||
|
||
LICENSE="Vivaldi" | ||
SLOT="0" | ||
KEYWORDS="-* ~amd64" | ||
|
||
RESTRICT="bindist mirror" | ||
|
||
S=${WORKDIR} | ||
|
||
DEPEND=" | ||
virtual/libiconv | ||
" | ||
RDEPEND=" | ||
dev-libs/expat | ||
dev-libs/glib:2 | ||
dev-libs/nspr | ||
dev-libs/nss | ||
>=dev-libs/openssl-1.0.1:0 | ||
gnome-base/gconf:2 | ||
media-libs/alsa-lib | ||
media-libs/fontconfig | ||
media-libs/freetype | ||
net-misc/curl | ||
net-print/cups | ||
sys-apps/dbus | ||
sys-libs/libcap | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf | ||
x11-libs/gtk+:2 | ||
x11-libs/libX11 | ||
x11-libs/libXScrnSaver | ||
x11-libs/libXcomposite | ||
x11-libs/libXcursor | ||
x11-libs/libXdamage | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXi | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
x11-libs/libXtst | ||
x11-libs/pango[X] | ||
" | ||
|
||
QA_PREBUILT="*" | ||
S=${WORKDIR} | ||
|
||
src_unpack() { | ||
unpack_deb ${A} | ||
} | ||
|
||
src_prepare() { | ||
iconv -c -t UTF-8 usr/share/applications/${PN}.desktop > "${T}"/${PN}.desktop || die | ||
mv "${T}"/${PN}.desktop usr/share/applications/${PN}.desktop || die | ||
|
||
mv usr/share/doc/${PN} usr/share/doc/${PF} || die | ||
chmod 0755 usr/share/doc/${PF} || die | ||
|
||
rm \ | ||
_gpgbuilder \ | ||
etc/cron.daily/${PN} \ | ||
${VIVALDI_HOME}/libwidevinecdm.so \ | ||
|| die | ||
rmdir \ | ||
etc/cron.daily/ \ | ||
etc/ \ | ||
|| die | ||
|
||
local c d | ||
for d in 16 22 24 32 48 64 128 256; do | ||
mkdir -p usr/share/icons/hicolor/${d}x${d}/apps || die | ||
cp \ | ||
${VIVALDI_HOME}/product_logo_${d}.png \ | ||
usr/share/icons/hicolor/${d}x${d}/apps/${PN}.png || die | ||
done | ||
|
||
pushd "${VIVALDI_HOME}/locales" > /dev/null || die | ||
chromium_remove_language_paks | ||
popd > /dev/null || die | ||
|
||
} | ||
|
||
src_install() { | ||
mv * "${D}" || die | ||
dosym /${VIVALDI_HOME}/${PN} /usr/bin/${PN} | ||
|
||
fperms 4711 /${VIVALDI_HOME}/vivaldi-sandbox | ||
} |