Skip to content

Commit

Permalink
app-cdr/cdrdao: fix builds w/gcc-5 #569344
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Jan 11, 2016
1 parent 2df1cf9 commit 83a1a32
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-cdr/cdrdao/cdrdao-1.2.3-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -44,6 +44,7 @@ S=${WORKDIR}/${P/_}

src_prepare() {
epatch "${FILESDIR}"/${P}-glibc212.patch
epatch "${FILESDIR}"/${P}-unsigned-char.patch #569344
}

src_configure() {
Expand Down
42 changes: 42 additions & 0 deletions app-cdr/cdrdao/files/cdrdao-1.2.3-unsigned-char.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
https://bugs.gentoo.org/69344
https://sourceforge.net/p/cdrdao/patches/26/

patch by [email protected]

--- a/dao/CdrDriver.cc
+++ b/dao/CdrDriver.cc
@@ -495,7 +495,7 @@
0, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0
};

-char CdrDriver::REMOTE_MSG_SYNC_[4] = { 0xff, 0x00, 0xff, 0x00 };
+unsigned char CdrDriver::REMOTE_MSG_SYNC_[4] = { 0xff, 0x00, 0xff, 0x00 };


/* Maps a string to the corresponding driver option value
--- a/dao/CdrDriver.h
+++ b/dao/CdrDriver.h
@@ -440,7 +440,7 @@
bool fullBurn_;

static unsigned char syncPattern[12];
- static char REMOTE_MSG_SYNC_[4];
+ unsigned static char REMOTE_MSG_SYNC_[4];

static int speed2Mult(int);
static int mult2Speed(int);
--- a/xdao/CdDevice.cc
+++ b/xdao/CdDevice.cc
@@ -255,10 +255,10 @@

bool CdDevice::updateProgress(Glib::IOCondition cond, int fd)
{
- static char msgSync[4] = { 0xff, 0x00, 0xff, 0x00 };
+ unsigned static char msgSync[4] = { 0xff, 0x00, 0xff, 0x00 };
fd_set fds;
int state = 0;
- char buf[10];
+ unsigned char buf[10];
struct timeval timeout = { 0, 0 };

if (process_ == NULL)

0 comments on commit 83a1a32

Please sign in to comment.