Skip to content

Commit

Permalink
dev-libs/libuv: Version 1.34.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Jan 23, 2020
1 parent 364e0de commit 83bb2d5
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libuv/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libuv-1.33.1.tar.gz 1251944 BLAKE2B fc20883dbd96df0d91fbcc75255ae2a371cd2d4e00a747cf23e7b9dbc2e4663ca71be2eef601b18c58e39f64cb3ad348684db4c683bcdd85a3fea4c28a578417 SHA512 0200aae2d38c26f537658955479cbc54fb69d5d8cbbccf3016cea319b2c46b1f311ca7a8fc289f14532acbbf2905cf96b17353b8b92bf09802424c372701d1d5
DIST libuv-1.34.0.tar.gz 1253950 BLAKE2B 3317709603409e009e24b5ff419bbac03927e75f0c0a37f0c6d8f558d027a25e883eec60a46928bb3533308a6f77a9834841e62ad9162df3c8cca1c3ae24a75e SHA512 30811311268179984fdc44209eb0e9ac4c6df08fa30790b75916ae838b23c2578a8a043340fbde86bcd5a373dcc335dec5fe88209560613876ca3272fd99c9e8
DIST libuv-1.34.1.tar.gz 1243096 BLAKE2B c6c786ceacbe3387a27455a413507cfe69511f88cddf150e98b21520e247a6825ff23506dc7fe1aa8c830772db23085d1b2c496ace11cde8405e4e204ce93f57 SHA512 95212bdba326a22edb2663982a4abb95c420d287c67b20e57d6acdd4c40d40956ad28c599beaf10fbc941c6e50df94261d84abf8ac25abceb10f67d9de5ef3d3
DIST libuv-1.34.2.tar.gz 1245374 BLAKE2B 500857cac1d714b43ae71c0f85e1cc69aab1735756f402582a6814c4d552a80097e76fe3cf4b74a395b5cc4340156c9e8abef2ad02000d2a5565ee8972062ab4 SHA512 7e7a54d2d1e0ed76654ece9481f02177d201a4590c5d9b5c8b4edf6f795a0d7c30970b907481847930a524a0f06c15c6c73b3ce73a8afa2f836e33dbd54a7249
47 changes: 47 additions & 0 deletions dev-libs/libuv/libuv-1.34.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit autotools multilib-minimal

DESCRIPTION="Cross-platform asychronous I/O"
HOMEPAGE="https://github.com/libuv/libuv"
SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD BSD-2 ISC MIT"
SLOT="0/1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
RESTRICT="test"

DEPEND="sys-devel/libtool
virtual/pkgconfig[${MULTILIB_USEDEP}]"

src_prepare() {
default

echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
> m4/libuv-extra-automake-flags.m4 || die

# upstream fails to ship a configure script
eautoreconf
}

multilib_src_configure() {
local myeconfargs=(
cc_cv_cflags__g=no
$(use_enable static-libs static)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_test() {
mkdir "${BUILD_DIR}"/test || die
cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
default
}

multilib_src_install_all() {
einstalldocs
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 83bb2d5

Please sign in to comment.