forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/pyformance: Version bump to 0.3.4
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST pyformance-0.3.2.tar.gz 10726 SHA256 7004f8e6eee1bcf8e28fb2ec74c8d67894158ccc01397faae70f6ee9729f9b8a SHA512 a838bb6cac144c309d2ff7050617b300fa2308f2bbab1d8b072ce87548d2dbd9ecb2dd552f9ddd53ded2ca4020bd42c7a3f4a245bc2c68ded5f01ebaf04edd71 WHIRLPOOL 6fb45017f8ea85ce3d61346f6a489861c30bf64bd8879e5dad4cb0cab4245346348b94183447e7ca86eb674a5ea4a874c42dec768dc02a0562b009d63e287bc5 | ||
DIST pyformance-0.3.4.tar.gz 19394 SHA256 a9294ec48b57711ad60af0badf1354c0e28364e82d2579a0d3d3afbf845547ac SHA512 5dbc83da62bf66767eaaf316824cf5683488d8ee594b72baee327c4ef594f84b5aed07654da483aff29bee98605e5265425be88c165a4bb06e7bdddbbf28e440 WHIRLPOOL 346a1b1d58b3a6be73bff33c6cb943363df2185b26ae709a665b66ab32f594eb3cc3ac7578dcd902652626187715db6fbd48960ec676404e2e2a661ce9e3dff7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python{2_7,3_{4,5}} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics" | ||
HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.python.org/pypi/pyformance/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( dev-python/pytest[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] )" | ||
|
||
RDEPEND="dev-python/six[${PYTHON_USEDEP}]" | ||
|
||
python_prepare() { | ||
sed -i -e "s/find_packages()/find_packages(exclude=['tests'])/" setup.py || die | ||
sed -i -e "s/URLError, err/URLError as err/" ${PN}/reporters/influx.py || die | ||
} | ||
|
||
python_test() { | ||
py.test || die | ||
} |