forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
x11-misc/mate-notification-daemon: version bump to 1.16.0
* dropped gtk2, gtk3 only Package-Manager: portage-2.3.1
- Loading branch information
Showing
2 changed files
with
56 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST mate-notification-daemon-1.12.1.tar.xz 304752 SHA256 856bad2bb90e2b7d1124c0ae197c07a321b3cc2767897b3e6b78e59a3096a7dd SHA512 ce9cd1737cc70b0e17fa856730b51747f78bb40639ff58e205a3f1432edf53aba38442d59b7a4fca6ff460cbdc6c611c0a05a46bbf5db92db0ce5e714e19daae WHIRLPOOL b925ac68692f1535bc57bed23f9c19239583c5ca674e5f6493223d31ff6be6ca2bb94b89cdb12baa0eafcaad1cf1c3d6df7ee717b71730b6947be0c0c81a22cd | ||
DIST mate-notification-daemon-1.14.1.tar.xz 336196 SHA256 8ddefb29d5fe626787fba29d4e76993b5e0efcbd36b2bb9aa2faa1cd64f732fd SHA512 6913e0a7891726fb2f4098b4c7ba578344d29960e6d27a9fa917687f745aedb9482fb65ea9c6d8816a0c8e505ef586f13ac08b010e558b6557e14e8961b1c1f6 WHIRLPOOL ba9fe7f7e30d2a92b93c51a1564414c27ad5533a3dd5d5c5946c697d6d2c3fc0ed586bf051b65a6d06852b08517ca60a262946cfb6f4b415b0a9459307c0ec2a | ||
DIST mate-notification-daemon-1.16.0.tar.xz 336036 SHA256 8555bc619ec11b44b092a57b47b87efa53cac1cc0173c132eedcc11c68ccdc49 SHA512 e54dcedf197904fbf652ac67ecef3cc51531ddc8a8a665fea8e90a0774603e62554ce717bf532000224651f233b51feef1f1b7dd9947d406dd00778b362754bf WHIRLPOOL 0aafb78b7ccab04b5408aba0b47eb339b34da824ed2b60c0fbbaeb3259690d270d4608b1767951f295e31825bead1856c8431094048e58b1c7a66cc477a0db1d |
55 changes: 55 additions & 0 deletions
55
x11-misc/mate-notification-daemon/mate-notification-daemon-1.16.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,55 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
MATE_LA_PUNT="yes" | ||
|
||
inherit mate | ||
|
||
if [[ ${PV} != 9999 ]]; then | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
fi | ||
|
||
DESCRIPTION="MATE Notification daemon" | ||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
IUSE="" | ||
|
||
COMMON_DEPEND="dev-libs/atk:0 | ||
>=dev-libs/dbus-glib-0.78:0 | ||
>=dev-libs/glib-2.36:2 | ||
>=sys-apps/dbus-1:0 | ||
x11-libs/cairo:0 | ||
>=x11-libs/gdk-pixbuf-2.22:2 | ||
>=x11-libs/libnotify-0.7:0 | ||
x11-libs/libX11:0 | ||
virtual/libintl:0 | ||
>=x11-libs/gtk+-3.14:3 | ||
>=x11-libs/libwnck-3:3 | ||
>=media-libs/libcanberra-0.4:0[gtk3] | ||
!x11-misc/notify-osd:* | ||
!x11-misc/qtnotifydaemon:* | ||
!x11-misc/notification-daemon:*" | ||
|
||
RDEPEND="${COMMON_DEPEND}" | ||
|
||
DEPEND="${COMMON_DEPEND} | ||
app-arch/xz-utils:0 | ||
>=dev-util/intltool-0.50.1:* | ||
sys-devel/gettext:* | ||
>=sys-devel/libtool-2.2.6:2 | ||
virtual/pkgconfig:*" | ||
|
||
src_configure() { | ||
mate_src_configure | ||
} | ||
|
||
src_install() { | ||
mate_src_install | ||
|
||
insinto /usr/share/dbus-1/services | ||
doins "${FILESDIR}/org.freedesktop.Notifications.service" | ||
} |