Skip to content

Commit

Permalink
dev-python/mock: Add python3.5 support
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 11, 2015
1 parent 6697e72 commit 842e740
Showing 1 changed file with 42 additions and 0 deletions.
42 changes: 42 additions & 0 deletions dev-python/mock/mock-1.3.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="Rolling backport of unittest.mock for all Pythons"
HOMEPAGE="https://github.com/testing-cabal/mock"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
IUSE="doc test"

CDEPEND="$(python_gen_cond_dep 'dev-python/funcsigs[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
DEPEND="
>=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
test? (
${CDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/unittest2-1.1.0[${PYTHON_USEDEP}]' python{2_7,3_3} pypy)
)"
RDEPEND="
${CDEPEND}
>=dev-python/six-1.7[${PYTHON_USEDEP}]
"

python_test() {
nosetests || die "tests fail under ${EPYTHON}"
}

python_install_all() {
use doc && local DOCS=( docs/*.txt )

distutils-r1_python_install_all
}

0 comments on commit 842e740

Please sign in to comment.