Skip to content

Commit

Permalink
app-misc/uptimed: Bump to version 0.4.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.5, Repoman-3.0.1
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 31, 2020
1 parent e324d02 commit 844b6f6
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/uptimed/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST uptimed-0.4.1.tar.gz 55162 BLAKE2B c281f922ed4fcf4f55571f1f1177451bf9f2e0fecfc87566610e1d24055969cd61543fcb0fdae4d0e6dc7a082c1b9013a08b72641d572a2475e9c7f5fd56deae SHA512 5dfe79aebab8c8daca3a3ec88d54e312446fc7cf8b54ef1414cbfcb3fb25053ef31235de4b42cb14fc7352965b77ca2875c753b97b4d61178792a5484715e23a
DIST uptimed-0.4.2.tar.gz 55339 BLAKE2B 120a3b1d6dc9518f7051af4d7e0f1bcf455f7dd989687fa8f5a40f160f2912c21d09298bbb9c676af5387d96890a98acf3f21b60e046a9548a735ca10dbc4006 SHA512 a18cc8580a4dc7db7f4d97d70e25d76e7b98b9d328a0fa4ece4176d40fc26589149d63ffc9d2638cc35003cf485b43ae6e115aa1821c662d77f234eb3c4c0a4f
DIST uptimed-0.4.3.tar.gz 55396 BLAKE2B bebea6559c436d2700df905b63fabd73b1c55463e8633409bc05cd16c7d110d8116f52e00d63879cfb2e0482f648bda04dcb5a1d5ff629699d2758dcc85ba53a SHA512 f9485224dfe7173bab135a87b047d749f9b61d3c29d50523126b585ae77e68837680fdb725a08fd7cad39f0b35b2da7a6923b8540700881f9638286ab5082260
61 changes: 61 additions & 0 deletions app-misc/uptimed/uptimed-0.4.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools systemd

DESCRIPTION="System uptime record daemon that keeps track of your highest uptimes"
HOMEPAGE="https://github.com/rpodgorny/uptimed/"
SRC_URI="https://github.com/rpodgorny/uptimed/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="static-libs"

RDEPEND="
acct-group/uptimed
acct-user/uptimed
"
DEPEND="${RDEPEND}"
BDEPEND="${RDEPEND}"

src_prepare() {
default
# fix configure.ac for >=automake-1.13 (bug #467582)
sed 's@AM_CONFIG_HEADER@AC_CONFIG_HEADERS@' -i configure.ac || die
eautoreconf
}

src_configure() {
econf $(use_enable static-libs static)
}

src_install() {
local DOCS=( ChangeLog README.md TODO AUTHORS CREDITS INSTALL.cgi sample-cgi/* )
default
find "${ED}" -type f -name '*.la' -delete || die

local spooldir="/var/spool/${PN}"
keepdir ${spooldir}
fowners uptimed:uptimed ${spooldir}

newinitd "${FILESDIR}"/${PN}.init-r1 uptimed
systemd_dounit "${FILESDIR}/${PN}.service"
}

pkg_postinst() {
local spooldir="/var/spool/${PN}"
if [[ -d "${spooldir}" ]] ; then
einfo "Fixing permissions in ${spooldir}"
find ${spooldir} -type f -links 1 \
\( -name records -o -name records.old \) \
| xargs --no-run-if-empty chown uptimed:uptimed || die
fi
echo
elog "Start uptimed with '/etc/init.d/uptimed start' (for openRC)"
elog "or systemctl start uptimed (for systemd)"
elog "To view your uptime records, use the command 'uprecords'."
echo
}

0 comments on commit 844b6f6

Please sign in to comment.