Skip to content

Commit

Permalink
mate-extra/caja-admin: Add new package, caja-extension
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <[email protected]>
  • Loading branch information
NP-Hardass committed Apr 6, 2020
1 parent 8a7c946 commit 84791cc
Show file tree
Hide file tree
Showing 6 changed files with 196 additions and 0 deletions.
3 changes: 3 additions & 0 deletions mate-extra/caja-admin/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
DIST 0.0.1.tar.gz 26920 BLAKE2B 29aa35ef185cd588fd9242ea2b019cb64c4a4965b77523937b8b36c3a3437f7171dac3a000b85d9c4183a962a9dc6be787589408c7804f696aeac3576b7fee50 SHA512 12f54aad32ac11d34ee8344d564d31f29a53324308923e54426ac3837702e71701cf139b150ec3ff210fb0739eb9c46b05c6380d8596031f71b71899800b767d
DIST 0.0.2.tar.gz 27564 BLAKE2B 975bbba48508ed6a997190ea6d5432330710ee312fe6f1e130b47894331a35c32071a40691cf69f617d268ab85dca62bb8bb4577d49bdb3c75c65ce05b4b9220 SHA512 919a92e258585e4b6275d346c82a1f9fc90462aa0cdedafb78867b80496f44bbd3459ce5a67429c5dda499bff2928a014779e81c781278ac0603f6cbebd3ff9e
DIST caja-admin-0.0.2_p20200328.tar.gz 27087 BLAKE2B 1d8ce82026249cff4dc3360cedffb79079e6608414a7718f265a19fce1a579d7f1fc4dadf3b05dd5ef19dbd12a92a61f90c04736cc9196d2dd5d4230c8c31784 SHA512 6a134e1d53bbdbf1a617582de67f7ddba7c7e0193a714246993092dd1c96c2ccc05afdb2da5cd2dfd974f7ab95e0aeedab244f2fa1335fd157ce45b4404a1f90
40 changes: 40 additions & 0 deletions mate-extra/caja-admin/caja-admin-0.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/infirit/caja-admin"
elif [[ ${PV} =~ _p[0-9]{8,} ]]; then
SHA="0af109ac79df76fbcc406d577d79f1c64d1a1fca"
SRC_URI="https://github.com/infirit/${PN}/archive/${SHA}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-${SHA}"
else
SRC_URI="https://github.com/infirit/${PN}/archive/${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

CMAKE_MIN_VERSION="2.6"
PYTHON_COMPAT=( python{3_6,3_7} )

inherit cmake-utils python-single-r1

DESCRIPTION="Caja Admin Extension"
HOMEPAGE="https://github.com/infirit/caja-admin"

LICENSE="GPL-3+"
SLOT="0"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

COMMON_DEPEND="${PYTHON_DEPS}"
RDEPEND="${COMMON_DEPEND}
dev-python/python-caja[${PYTHON_SINGLE_USEDEP}]
sys-auth/polkit
"
DEPEND="${COMMON_DEPEND}
sys-devel/gettext
"
BDEPEND=""
47 changes: 47 additions & 0 deletions mate-extra/caja-admin/caja-admin-0.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/infirit/caja-admin"
elif [[ ${PV} =~ _p[0-9]{8,} ]]; then
SHA="0af109ac79df76fbcc406d577d79f1c64d1a1fca"
SRC_URI="https://github.com/infirit/${PN}/archive/${SHA}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-${SHA}"
else
SRC_URI="https://github.com/infirit/${PN}/archive/${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

CMAKE_MIN_VERSION="2.6"
PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )

inherit cmake-utils python-single-r1

DESCRIPTION="Caja Admin Extension"
HOMEPAGE="https://github.com/infirit/caja-admin"

LICENSE="GPL-3+"
SLOT="0"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

COMMON_DEPEND="${PYTHON_DEPS}"
RDEPEND="${COMMON_DEPEND}
app-editors/pluma
dev-python/python-caja[${PYTHON_SINGLE_USEDEP}]
sys-auth/polkit
x11-terms/mate-terminal
"
DEPEND="${COMMON_DEPEND}
sys-devel/gettext
"
BDEPEND=""

src_install() {
cmake-utils_src_install
python_optimize "${D}/usr/share/caja-python/extensions"
}
46 changes: 46 additions & 0 deletions mate-extra/caja-admin/caja-admin-0.0.2_p20200328.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/infirit/caja-admin"
elif [[ ${PV} =~ _p[0-9]{8,} ]]; then
SHA="b20de2dd2e1ef74db66705965fd7480e2bf98153"
SRC_URI="https://github.com/infirit/${PN}/archive/${SHA}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-${SHA}"
else
SRC_URI="https://github.com/infirit/${PN}/archive/${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )

inherit meson python-single-r1

DESCRIPTION="Caja Admin Extension"
HOMEPAGE="https://github.com/infirit/caja-admin"

LICENSE="GPL-3+"
SLOT="0"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

COMMON_DEPEND="${PYTHON_DEPS}"
RDEPEND="${COMMON_DEPEND}
app-editors/pluma
dev-python/python-caja[${PYTHON_SINGLE_USEDEP}]
sys-auth/polkit
x11-terms/mate-terminal
"
DEPEND="${COMMON_DEPEND}
sys-devel/gettext
"
BDEPEND=""

src_install() {
meson_src_install
python_optimize "${D}/usr/share/caja-python/extensions"
}
46 changes: 46 additions & 0 deletions mate-extra/caja-admin/caja-admin-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/infirit/caja-admin"
elif [[ ${PV} =~ _p[0-9]{8,} ]]; then
SHA="b20de2dd2e1ef74db66705965fd7480e2bf98153"
SRC_URI="https://github.com/infirit/${PN}/archive/${SHA}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-${SHA}"
else
SRC_URI="https://github.com/infirit/${PN}/archive/${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )

inherit meson python-single-r1

DESCRIPTION="Caja Admin Extension"
HOMEPAGE="https://github.com/infirit/caja-admin"

LICENSE="GPL-3+"
SLOT="0"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

COMMON_DEPEND="${PYTHON_DEPS}"
RDEPEND="${COMMON_DEPEND}
app-editors/pluma
dev-python/python-caja[${PYTHON_SINGLE_USEDEP}]
sys-auth/polkit
x11-terms/mate-terminal
"
DEPEND="${COMMON_DEPEND}
sys-devel/gettext
"
BDEPEND=""

src_install() {
meson_src_install
python_optimize "${D}/usr/share/caja-python/extensions"
}
14 changes: 14 additions & 0 deletions mate-extra/caja-admin/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
<longdescription lang="en">
An extension for Caja that allows administrator access
</longdescription>
<upstream>
<remote-id type="github">infirit/caja-admin</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 84791cc

Please sign in to comment.