Skip to content

Commit

Permalink
media-video/kmplayer: version bump 0.12.0b
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
kensington committed Jan 18, 2017
1 parent acb0f70 commit 847e8f1
Show file tree
Hide file tree
Showing 2 changed files with 87 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/kmplayer/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kmplayer-0.12.0a.tar.bz2 596374 SHA256 b1cc05f1942882e34d013ab363e553e4ec87af6c9c7ef9755db2b8fa4b8930d8 SHA512 4ae24621ab54706ba323e9b345f4bc6876d3b7b84eef8edc9d07351e336dc940a3d314c394470ce3a85ebfcc77cb7fe6eedb96ca382b2a81f6d95ecff1f3f875 WHIRLPOOL eb45b40177e82ec45234a11b62f1ae3c3dd8989ab6d7bf0b8968e601ed32b976a1061223aee37de0d4544f5431bd9614dac3e8fb2f4d19685b1050b7b768ca9d
DIST kmplayer-0.12.0b.tar.bz2 599496 SHA256 5e98cea9bd958860d90003d37037172a95ed8b699133e8f1e6033147aaefed73 SHA512 d34c496d0c24c6d5c1bb675b83fac60da5c9672e4076aed72bac2e9b333e88d031076e7e386ec7b61ae8ece88870f6187c61f483f425aa78edd1e443c7f2e882 WHIRLPOOL 4ce75858bd6f385572f1c39e1aef47ad9526986b8c99de228d9e77168e804b2aeeca2933bb95c8be0f3a2200154473fd99a02af2d449a3861c845715f772570c
86 changes: 86 additions & 0 deletions media-video/kmplayer/kmplayer-0.12.0b.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

EGIT_BRANCH="0.12"
KDE_HANDBOOK="true"
inherit kde5

DESCRIPTION="Video player plugin for Konqueror and basic MPlayer frontend"
HOMEPAGE="https://kmplayer.kde.org"
SRC_URI="mirror://kde/stable/${PN}/${EGIT_BRANCH}/${P}.tar.bz2"

LICENSE="GPL-2 FDL-1.2 LGPL-2.1"
KEYWORDS="~amd64 ~x86"
IUSE="cairo npp"

CDEPEND="
$(add_frameworks_dep kbookmarks)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdelibs4support)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep kmediaplayer)
$(add_frameworks_dep kparts)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtsvg)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtx11extras)
$(add_qt_dep qtxml)
media-libs/phonon[qt5]
x11-libs/libX11
x11-libs/libxcb
cairo? ( x11-libs/cairo[xcb] )
npp? (
dev-libs/dbus-glib
dev-libs/glib:2
www-plugins/adobe-flash:*
>=x11-libs/gtk+-2.10.14:2
)
"
DEPEND="${CDEPEND}
sys-devel/gettext
"
RDEPEND="${CDEPEND}
media-video/mplayer
!media-video/kmplayer:4
"

src_prepare() {
if use npp; then
sed -i src/kmplayer_part.desktop \
-e ":^MimeType: s:=:=application/x-shockwave-flash;:" || die
fi

kde5_src_prepare
}

src_configure() {
# 0.12: expat build broken, check in later releases
local mycmakeargs=(
-DKMPLAYER_BUILT_WITH_EXPAT=OFF
-DKMPLAYER_BUILT_WITH_CAIRO=$(usex cairo)
-DKMPLAYER_BUILT_WITH_NPP=$(usex npp)
)

kde5_src_configure
}

src_install() {
kde5_src_install

if use npp; then
kwriteconfig5 --file "${ED}/usr/share/config/kmplayerrc" --group "application/x-shockwave-flash" --key player npp
kwriteconfig5 --file "${ED}/usr/share/config/kmplayerrc" --group "application/x-shockwave-flash" --key plugin /usr/lib/nsbrowser/plugins/libflashplayer.so
fi
}

0 comments on commit 847e8f1

Please sign in to comment.