Skip to content

Commit

Permalink
games-rpg/manaplus: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Michael Sterrett committed Mar 1, 2016
1 parent d293a59 commit 84a878c
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-rpg/manaplus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST manaplus-1.5.11.21.tar.xz 9556540 SHA256 57b6e0d8a730f56060062aa0d6e6baafc100860aa2cc4ba5120d21772410aae6 SHA512 145479b9b6912064356f842910c2a5bbb16bacc7372b898d98f237514722bbac4c6f3fe49ee30942b6e38820cfe9d3508ba5ac64b858a6003e27569327729d7d WHIRLPOOL 628009c082219c63f42892881060dff3784ae419d3d6dab95357272774d0d0545a97cf0d7190157e3338ac38e7f821fe9e3a893f24ee10be71ec6ac83c097722
DIST manaplus-1.6.1.16.tar.xz 9610164 SHA256 393678d7de6d0253e53756bb689d2f778ed4c402215c8d72c576fdb6da963aef SHA512 2ba77b8d79e765cad7ecf3074eec49791a3f68d4fa66eed9bbf13adf23e94c35b55d8587850352e0855a7320c828dc886224fa4aa6260cd449a850ba469dd0be WHIRLPOOL f7dfdb3a0693f55d2202f488f0bfd036cb23f821c14962105c73ea16c5969f0c7bd53e2d5abd416f5d588be73de461bc1d58ff9269ed4c55cd4064644a759805
DIST manaplus-1.6.2.27.tar.xz 9642388 SHA256 1f8b3209b5e71250f0ccf643c5e26e7770258d903986e48066a4233a4b9d8d4e SHA512 ba03f8f317ad0ab7f4039ee3d032134aee9fbb4584ffa5b63ee18935ac0e59647a4373c9a52a1b69b2117de22f73907a647f8c07209ae968d6b170ddfdbada8b WHIRLPOOL 08ce25c664fc3c26af7af78ec83d900cab75b7330ff02e736a92850a2b03d52fe4726b76938548a56ce5d72823d2198e62129df76dced03befe0754f6145a404
71 changes: 71 additions & 0 deletions games-rpg/manaplus/manaplus-1.6.2.27.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit games

DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
HOMEPAGE="http://manaplus.evolonline.org"
SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls opengl"

RDEPEND="
>=dev-games/physfs-1.0.0
dev-libs/libxml2
media-libs/libpng:0=
media-libs/libsdl2[X,opengl?,video]
media-libs/sdl2-gfx
media-libs/sdl2-image[png]
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-net
media-libs/sdl2-ttf
net-misc/curl
sys-libs/zlib
x11-libs/libX11
x11-misc/xdg-utils
x11-apps/xmessage
media-fonts/dejavu
media-fonts/wqy-microhei
media-fonts/liberation-fonts
media-fonts/mplus-outline-fonts
nls? ( virtual/libintl )
opengl? ( virtual/opengl )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )"

src_configure() {
CONFIG_SHELL=/bin/bash \
egamesconf \
--with-sdl2 \
--without-internalsdlgfx \
--localedir=/usr/share/locale \
--prefix="/usr" \
--bindir="${GAMES_BINDIR}" \
$(use_with opengl) \
$(use_enable nls)
}

src_install() {
default
dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusansmono.ttf
dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavuserifcondensed-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavuserifcondensed.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono-bold.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsansmono.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans-bold.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/liberationsans.ttf
dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-bold.ttf
dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/mplus-1p-regular.ttf
dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${GAMES_DATADIR}"/${PN}/data/fonts/wqy-microhei.ttf

prepgamesdirs
}

0 comments on commit 84a878c

Please sign in to comment.