Skip to content

Commit

Permalink
dev-php/ming-php: Version bump for 0.4.8
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Brian Evans committed Jan 1, 2018
1 parent aba7f7d commit 84dbf9f
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/ming-php/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ming-0_4_7.tar.gz 14903570 BLAKE2B 48e7b3c2b8a81fa63da18dd140064c572efe563eb621f33b4bc57cdcad8d6cb828e8f62fc63b47144389b0eefa5b571c47e39013ec2724611d20e74928275213 SHA512 232cf45daabd7b60203c9382aa6568455a42ddcd1bd60eec9bfe3f5e80376fcc9ff6304efbafca1ac8a504e2e167bc394e4902e0d067303d9582551461e09d3c
DIST ming-0_4_8.tar.gz 14908459 BLAKE2B df89beab98a7fbdcbefccad3a2fb013453405a7dba757131a61f06d9e40b7e1fe7beeadab42c113b12cff24b91cb1e76e9fabee0e1b4af58e2127eba13cc27bc SHA512 e395acde9119ad32f4cedd500bcceee70bdd563222a41dda899cc318d5e34eb580abc38ac39c6dec7821913a0a70d2f953fc81f52255b623e34f7c3aaafbc9c0
46 changes: 46 additions & 0 deletions dev-php/ming-php/ming-php-0.4.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PHP_EXT_NAME=ming
MY_P="${PHP_EXT_NAME}-${PV//./_}"
USE_PHP="php5-6 php7-0 php7-1 php7-2"
PHP_EXT_S="libming-${MY_P}/php_ext"
inherit flag-o-matic php-ext-source-r3

DESCRIPTION="PHP extension for the ming Flash movie generation library"
HOMEPAGE="http://ming.sourceforge.net/"
SRC_URI="https://github.com/libming/libming/archive/${MY_P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE=""

RDEPEND="media-libs/ming"
DEPEND="${RDEPEND}"

S="${WORKDIR}/libming-${MY_P}"
# Clear out near-empty README files which are not helpful to the user
DOCS=( )

src_prepare() {
local slot orig_s="${PHP_EXT_S}"
for slot in $(php_get_slots); do
cp "${FILESDIR}/php_ext-config.m4" "${WORKDIR}/${slot}/config.m4" || \
die "Failed to copy config.m4 to target"
rm "${WORKDIR}/${slot}/Makefile.am" || die "Failed to remove Makefile.am for ${slot}"
php_init_slot_env ${slot}
eapply_user
php-ext-source-r3_phpize
done
}

src_configure() {
# build is sensitive to -O3 (bug #297437)
replace-flags -O3 -O2

local PHP_EXT_EXTRA_ECONF="--with-ming=${S}"
php-ext-source-r3_src_configure
}

0 comments on commit 84dbf9f

Please sign in to comment.