Skip to content

Commit

Permalink
app-backup/tarsnap: bump to v1.0.39
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/649474
Package-Manager: Portage-2.3.53, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Dec 29, 2018
1 parent c0a34f0 commit 85537d2
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/tarsnap/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tarsnap-autoconf-1.0.35.tgz 600115 BLAKE2B d2dc76a444e6095f00ba3742fa0aca5fd13263e5cc1ad666c222983ef5a5a9c9c72b5af18283ad33bef690328b9eab0c70fe908b33d87b286b1eacd55b664a4d SHA512 70f932b172717d7f0d6f96a357487b8f8ad13cb7332d73878f629c3abf0862da54a0621092d81ce8cd9eb8380cf5b4c32e89df4d890949429fc84737024dcb61
DIST tarsnap-autoconf-1.0.37.tgz 629450 BLAKE2B 440858098c5c3f2be6fb6b1473ab4fade158203162c04fbc4c2e051f443c7ce3246ab0701e117bccb436b8f1f022e986ec67f653a3c34b9c36da99ca85d73bc8 SHA512 050053f2109b74cda16511cf35ab2c11e0470ba745c661d254b7c17efde9e629830d519896b343dbd4f48ee739dfef47b724eb5e2e78c3e7dbc4ae018a536a5f
DIST tarsnap-autoconf-1.0.39.tgz 641089 BLAKE2B 4da7fa75c2a6df3186fac4f39a511532ae866c287a2bdc8dcc22049b53fcc903305f84fae9258793bc0c7a47b208d0bf2995143ee7b4296a35b4ca41d65d9a09 SHA512 dec8a72144a3a7fd42b006933c904b812894ca9fe2c57ecc4fbba817b9b49c8f15517530a00b0c3a9897e3182b4d9aee525334537806a9c4f7308086678fa2b4
43 changes: 43 additions & 0 deletions app-backup/tarsnap/tarsnap-1.0.39.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit bash-completion-r1

DESCRIPTION="Online backups for the truly paranoid"
HOMEPAGE="https://www.tarsnap.com/"
SRC_URI="https://www.tarsnap.com/download/${PN}-autoconf-${PV}.tgz"

LICENSE="tarsnap"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="acl bzip2 libressl lzma xattr"

RDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
sys-libs/e2fsprogs-libs
sys-libs/zlib
acl? ( sys-apps/acl )
bzip2? ( app-arch/bzip2 )
lzma? ( app-arch/xz-utils )
xattr? ( sys-apps/attr )"
DEPEND="${RDEPEND}
virtual/os-headers" # Required for "magic.h"

S=${WORKDIR}/${PN}-autoconf-${PV}

src_configure() {
econf \
$(use_enable xattr) \
$(use_enable acl) \
$(use_with bzip2 bz2lib) \
--without-lzmadec \
$(use_with lzma)
}

src_install() {
default
dobashcomp misc/bash_completion.d/*
}

0 comments on commit 85537d2

Please sign in to comment.