Skip to content

Commit

Permalink
dev-lang/lua: fix for bug #520480
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
Rafael Martins committed Nov 28, 2016
1 parent 621ea4c commit 856bde2
Show file tree
Hide file tree
Showing 2 changed files with 147 additions and 0 deletions.
12 changes: 12 additions & 0 deletions dev-lang/lua/files/lua-5.1.5-fix_vararg_calls.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -uNr lua-5.1.5.orig/src/ldo.c lua-5.1.5/src/ldo.c
--- lua-5.1.5.orig/src/ldo.c 2016-11-28 20:04:13.177047928 +0100
+++ lua-5.1.5/src/ldo.c 2016-11-28 20:07:15.170432525 +0100
@@ -274,7 +274,7 @@
CallInfo *ci;
StkId st, base;
Proto *p = cl->p;
- luaD_checkstack(L, p->maxstacksize);
+ luaD_checkstack(L, p->maxstacksize + p->numparams);
func = restorestack(L, funcr);
if (!p->is_vararg) { /* no varargs? */
base = func + 1;
135 changes: 135 additions & 0 deletions dev-lang/lua/lua-5.1.5-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,135 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils multilib multilib-minimal portability toolchain-funcs versionator

DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="http://www.lua.org/"
SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux ~ppc-aix ~x64-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="+deprecated emacs readline static"

RDEPEND="readline? ( >=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
sys-devel/libtool"
PDEPEND="emacs? ( app-emacs/lua-mode )"

MULTILIB_WRAPPED_HEADERS=(
/usr/include/luaconf.h
)

src_prepare() {
local PATCH_PV=$(get_version_component_range 1-2)

epatch "${FILESDIR}/${P}-fix_vararg_calls.patch"

epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make-r1.patch
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch

# use glibtool on Darwin (versus Apple libtool)
if [[ ${CHOST} == *-darwin* ]] ; then
sed -i -e '/LIBTOOL = /s:libtool:glibtool:' \
Makefile src/Makefile || die
fi

#EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="upstream.patch" epatch

# correct lua versioning
sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:5:1/' src/Makefile || die

sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html || die

if ! use deprecated ; then
# patches from 5.1.4 still apply
epatch "${FILESDIR}"/${PN}-5.1.4-deprecated.patch
epatch "${FILESDIR}"/${PN}-5.1.4-test.patch
fi

if ! use readline ; then
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
fi

# Using dynamic linked lua is not recommended for performance
# reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
# Mainly, this is of concern if your arch is poor with GPRs, like x86
# Note that this only affects the interpreter binary (named lua), not the lua
# compiler (built statically) nor the lua libraries (both shared and static
# are installed)
if use static ; then
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static-r1.patch
fi

# custom Makefiles
multilib_copy_sources
}

multilib_src_configure() {
# We want packages to find our things...
sed -i \
-e 's:/usr/local:'${EPREFIX}'/usr:' \
-e "s:\([/\"]\)\<lib\>:\1$(get_libdir):g" \
etc/lua.pc src/luaconf.h || die
}

multilib_src_compile() {
tc-export CC
myflags=
# what to link to liblua
liblibs="-lm"
liblibs="${liblibs} $(dlopen_lib)"

# what to link to the executables
mylibs=
if use readline; then
mylibs="-lreadline"
fi

cd src
emake CC="${CC}" CFLAGS="-DLUA_USE_LINUX ${CFLAGS}" \
RPATH="${EPREFIX}/usr/$(get_libdir)/" \
LUA_LIBS="${mylibs}" \
LIB_LIBS="${liblibs}" \
V=${PV} \
gentoo_all

mv lua_test ../test/lua.static
}

multilib_src_install() {
emake INSTALL_TOP="${ED}/usr" INSTALL_LIB="${ED}/usr/$(get_libdir)" \
V=${PV} gentoo_install

insinto /usr/$(get_libdir)/pkgconfig
doins etc/lua.pc
}

multilib_src_install_all() {
dodoc HISTORY README
dohtml doc/*.html doc/*.png doc/*.css doc/*.gif

doicon etc/lua.ico

doman doc/lua.1 doc/luac.1
}

multilib_src_test() {
local positive="bisect cf echo env factorial fib fibfor hello printf sieve
sort trace-calls trace-globals"
local negative="readonly"
local test

cd "${BUILD_DIR}" || die
for test in ${positive}; do
test/lua.static test/${test}.lua || die "test $test failed"
done

for test in ${negative}; do
test/lua.static test/${test}.lua && die "test $test failed"
done
}

0 comments on commit 856bde2

Please sign in to comment.