forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Gentoo-bug: 361995 Package-Manager: portage-2.2.27
- Loading branch information
1 parent
0f5fe54
commit 8591ef8
Showing
4 changed files
with
186 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST Falcon-0.9.6.4.tar.gz 1782796 SHA256 24f4294f93c192f21d3590795a9fdd864c3f2d376cb0baac9c1e11e893cfaf81 SHA512 244fc0cc6811d9c918a1983d93e380982584016d84752b00d3adc17e46d7a7cbf9d20f09b7562316b1c9ea6eaaa91c1cb931f4469f7d510d9084f1daaca732a5 WHIRLPOOL 2178d6307fcd516f490fada540af649a60ca39f8640215b926f153316ab349ed9b46e47c7849270a20632e9639ca65d635f88ed4d0a2fccf718967ce83106a8b | ||
DIST Falcon-0.9.6.8.tgz 11772705 SHA256 f4b00983e7f91a806675d906afd2d51dcee048f12ad3af4b1dadd92059fa44b9 SHA512 f354a058d9075a636c0b2db339fd86adda9b4a4bc7c229186b73aa200e059a21b311a4944b1b7388b4992390e4d540af8832e4b2cea31d7f956df1dd96f2f59c WHIRLPOOL cc42e7d250aea223162703a52b5f9461d52db6051d29dfb26320ce740fe6b502e8c8f474bb97809dc238fb23ce8cb99e9ec6d35fb01656a20e9d9b3d8b3b24e0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
inherit cmake-utils multilib | ||
|
||
MY_P="${P/f/F}" | ||
|
||
DESCRIPTION="An open source general purpose untyped language written in C++" | ||
HOMEPAGE="http://falconpl.org/" | ||
SRC_URI="http://falconpl.org/project_dl/_official_rel/${MY_P}.tgz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="curl dbus debug gd gtk mysql pdf readline sdl sqlite" | ||
|
||
DEPEND=" | ||
dev-libs/libpcre | ||
sys-libs/zlib | ||
curl? ( net-misc/curl ) | ||
dbus? ( sys-apps/dbus ) | ||
gd? ( media-libs/gd:= ) | ||
gtk? ( dev-libs/glib:2 ) | ||
mysql? ( virtual/libmysqlclient:= ) | ||
readline? ( sys-libs/readline:0 ) | ||
pdf? ( media-libs/libharu ) | ||
sdl? ( | ||
media-libs/libsdl | ||
media-libs/sdl-image | ||
media-libs/sdl-mixer | ||
media-libs/sdl-ttf | ||
) | ||
sqlite? ( dev-db/sqlite:3 ) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
DOCS="AUTHORS ChangeLog README RELNOTES" | ||
PATCHES=( | ||
"${FILESDIR}/${P}-mongo-amd64.patch" | ||
"${FILESDIR}/${P}-mongo-stdint.patch" | ||
) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DFALCON_BUILD_CURL=$(usex curl) | ||
-DFALCON_BUILD_DBUS=$(usex dbus) | ||
-DFALCON_BUILD_GD2=$(usex gd) | ||
-DFALCON_BUILD_GTK=$(usex gtk) | ||
-DFALCON_BUILD_PDF=$(usex pdf) | ||
-DFALCON_BUILD_SDL=$(usex sdl) | ||
-DFALCON_DBI_BUILD_MYSQL=$(usex mysql) | ||
-DFALCON_DBI_BUILD_SQLITE=$(usex sqlite) | ||
-DFALCON_DISABLE_RPATH=ON | ||
-DFALCON_SKIP_BISON=ON | ||
-DFALCON_WITH_EDITLINE=$(usex readline) | ||
-DFALCON_WITH_MANPAGES=ON | ||
-DFALCON_WITH_INTERNAL_EDITLINE=OFF | ||
-DFALCON_WITH_INTERNAL_PCRE=OFF | ||
-DFALCON_WITH_INTERNAL_ZLIB=OFF | ||
-DFALCON_WITH_GPL_READLINE=ON | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_test() { | ||
pushd "${S}/tests/core/testsuite" > /dev/null || die | ||
"${CMAKE_BUILD_DIR}/bin/faltest" | ||
popd > /dev/null || die | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,75 @@ | ||
From 64526ea7d3b5ec04f398bd28cb4e505e6a0f3218 Mon Sep 17 00:00:00 2001 | ||
From: Stanislas Marquis <[email protected]> | ||
Date: Sun, 9 Jan 2011 08:40:00 +0100 | ||
Subject: [PATCH] [mongo] [cmake] Fix problems with Linux x64. | ||
|
||
--- | ||
modules/native/mongodb/CMakeLists.txt | 11 +++++++++-- | ||
modules/native/mongodb/mongodb_mod.cpp | 2 +- | ||
modules/native/mongodb/src/CMakeLists.txt | 8 ++++++-- | ||
3 files changed, 16 insertions(+), 5 deletions(-) | ||
|
||
diff --git a/modules/native/mongodb/CMakeLists.txt b/modules/native/mongodb/CMakeLists.txt | ||
index ba7e5cf..bf2d869 100644 | ||
--- a/modules/native/mongodb/CMakeLists.txt | ||
+++ b/modules/native/mongodb/CMakeLists.txt | ||
@@ -8,6 +8,10 @@ falcon_define_module( FALCON_MODULE mongo ) | ||
|
||
message( STATUS "Adding mongodb module" ) | ||
|
||
+if ( NOT MSVC ) | ||
+ option( MONGO_HAVE_STDINT "MongoDB problem with int64_t?" OFF ) | ||
+endif() | ||
+ | ||
## | ||
# Find Falcon | ||
# | ||
@@ -28,8 +32,11 @@ add_subdirectory( src ) | ||
if ( MSVC ) | ||
add_definitions( -DMONGO_USE__INT64 ) | ||
else() | ||
- #add_definitions( -DMONGO_HAVE_STDINT ) | ||
- add_definitions( -DMONGO_USE_LONG_LONG_INT ) | ||
+ if ( MONGO_HAVE_STDINT ) | ||
+ add_definitions( -DMONGO_HAVE_STDINT ) | ||
+ else() | ||
+ add_definitions( -DMONGO_USE_LONG_LONG_INT ) | ||
+ endif() | ||
endif() | ||
|
||
## | ||
diff --git a/modules/native/mongodb/mongodb_mod.cpp b/modules/native/mongodb/mongodb_mod.cpp | ||
index 6102664..4d47fac 100644 | ||
--- a/modules/native/mongodb/mongodb_mod.cpp | ||
+++ b/modules/native/mongodb/mongodb_mod.cpp | ||
@@ -1321,7 +1321,7 @@ BSONIter::makeItem( const bson_type tp, | ||
//... | ||
break; | ||
case bson_long: | ||
- it = new Item( bson_iterator_long_raw( iter ) ); | ||
+ it = new Item( (int64) bson_iterator_long_raw( iter ) ); | ||
break; | ||
case bson_eoo: | ||
default: | ||
diff --git a/modules/native/mongodb/src/CMakeLists.txt b/modules/native/mongodb/src/CMakeLists.txt | ||
index 48cdaef..d883af3 100644 | ||
--- a/modules/native/mongodb/src/CMakeLists.txt | ||
+++ b/modules/native/mongodb/src/CMakeLists.txt | ||
@@ -7,8 +7,12 @@ include_directories( BEFORE . ) | ||
if ( MSVC ) | ||
add_definitions( -DMONGO_USE__INT64 ) | ||
else() | ||
- add_definitions( -DMONGO_USE_LONG_LONG_INT ) | ||
- #add_definitions( --std=c99 ) | ||
+ add_definitions( -fPIC ) | ||
+ if ( MONGO_HAVE_STDINT ) | ||
+ add_definitions( -DMONGO_HAVE_STDINT ) | ||
+ else() | ||
+ add_definitions( -DMONGO_USE_LONG_LONG_INT ) | ||
+ endif() | ||
endif() | ||
|
||
set( MONGO_SRCS | ||
-- | ||
1.7.9.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
From a64c0c3959a0f5e853daba2b35ca19459acf875e Mon Sep 17 00:00:00 2001 | ||
From: Stanislas Marquis <[email protected]> | ||
Date: Sat, 29 Jan 2011 12:27:50 +0100 | ||
Subject: [PATCH] [mongo] Fix detection of stdint.h | ||
|
||
--- | ||
modules/native/mongodb/CMakeLists.txt | 12 +++++++++++- | ||
1 files changed, 11 insertions(+), 1 deletions(-) | ||
|
||
diff --git a/modules/native/mongodb/CMakeLists.txt b/modules/native/mongodb/CMakeLists.txt | ||
index bf2d869..e4d1df6 100644 | ||
--- a/modules/native/mongodb/CMakeLists.txt | ||
+++ b/modules/native/mongodb/CMakeLists.txt | ||
@@ -8,8 +8,18 @@ falcon_define_module( FALCON_MODULE mongo ) | ||
|
||
message( STATUS "Adding mongodb module" ) | ||
|
||
+## | ||
+# Check for stdint.h | ||
+# | ||
if ( NOT MSVC ) | ||
- option( MONGO_HAVE_STDINT "MongoDB problem with int64_t?" OFF ) | ||
+ find_file( STDINT_H stdint.h HINTS /usr/include ) | ||
+ if ( STDINT_H STREQUAL STDINT_H-NOTFOUND ) | ||
+ option( MONGO_HAVE_STDINT "MongoDB should use stdint.h" OFF ) | ||
+ else() | ||
+ option( MONGO_HAVE_STDINT "MongoDB should use stdint.h" ON ) | ||
+ endif() | ||
+ mark_as_advanced( STDINT_H ) | ||
+ mark_as_advanced( MONGO_HAVE_STDINT ) | ||
endif() | ||
|
||
## | ||
-- | ||
1.7.9.1 | ||
|