Skip to content

Commit

Permalink
mate-extra/mate-power-manager: add 1.26.0
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/809062
Signed-off-by: Oz N Tiram <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
oz123 authored and thesamesam committed Oct 4, 2022
1 parent 3c24f10 commit 85b86dc
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/mate-power-manager/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mate-power-manager-1.24.3.tar.xz 6199712 BLAKE2B 21eb92d6b0bc8f97c3f13847e877d6df7d8782ca90cae20e414d38c18ec9345b4b6a65cc72ed23010aec65d764381e66ac01a77a60b698c43764f2c3eb6c5229 SHA512 6aad5c5346e563ce0fbc4e72bccce49323843e3b12738b9e45040dd804f962344a1dbc8f26d518b28fc35ca9ec87a2068f81731eb0c094be114378f2f93a2a8c
DIST mate-power-manager-1.26.0.tar.xz 6247700 BLAKE2B 2b3cea55c4486df36a85540b842dc63d0f61df394d785f55dbbb004ab963d42fecd616d9bb8ab66d55fc04c2048dcec7d0be443ee0e753479c03b892a132fe13 SHA512 1ddede827f72738e87870d2abeed7f0767ef2e383b8325b24faa0fd1e811ed634446516e6634b19a6546ddd7185092fd757b2b2ff97f51b88a9d2c313407abd4
71 changes: 71 additions & 0 deletions mate-extra/mate-power-manager/mate-power-manager-1.26.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
fi

DESCRIPTION="A session daemon for MATE that makes it easy to manage your laptop or desktop"

LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
SLOT="0"
IUSE="+applet +elogind libsecret policykit systemd test"

REQUIRED_USE="^^ ( elogind systemd )"

# Interactive testsuite.
RESTRICT="test"

COMMON_DEPEND="
>=dev-libs/dbus-glib-0.70
>=dev-libs/glib-2.50:2
>=media-libs/libcanberra-0.10:0[gtk3]
>=sys-apps/dbus-1
>=sys-power/upower-0.99.8:=
>=x11-apps/xrandr-1.3
>=x11-libs/cairo-1
>=x11-libs/gdk-pixbuf-2.11:2
>=x11-libs/gtk+-3.22:3
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrandr
>=x11-libs/libnotify-0.7:0
x11-libs/pango
applet? ( >=mate-base/mate-panel-1.17.0 )
libsecret? ( >=app-crypt/libsecret-0.11 )
"

RDEPEND="${COMMON_DEPEND}
virtual/libintl
policykit? ( >=mate-extra/mate-polkit-1.6 )
systemd? ( sys-apps/systemd )
elogind? ( sys-auth/elogind )
"

BDEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.3
app-text/yelp-tools
dev-libs/libxml2
dev-util/glib-utils
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
x11-base/xorg-proto
"

src_configure() {
mate_src_configure \
--enable-compile-warnings=minimum \
$(use_with libsecret) \
$(use_enable applet applets) \
$(use_enable test tests)
}

src_test() {
unset DBUS_SESSION_BUS_ADDRESS

dbus-launch Xemake check || die "Test phase failed"
}

0 comments on commit 85b86dc

Please sign in to comment.