forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
- Loading branch information
1 parent
a6a8f08
commit 85dde98
Showing
2 changed files
with
45 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST zeroconf-0.17.5.tar.gz 18428 SHA256 51ea8affc3512259d5e702a46031139c2eaefe2a0891990e5866d0b5a436112e SHA512 834f8d66bb92232474f60a5137ed7de3788fe1b7109cd5dd2100c3845a89bbb224df060bcb482b0c48b0a5849604247b8f29a902f9c78c35a72497a77f5323b3 WHIRLPOOL b18548e0ac1f7f4e03c4326d227ebcd6a56e43cfeb4ee4168ba47eae73675c131dda5d2840b506f56abf816517328eb2143c10afa52a6b972ee851be30f04736 | ||
DIST zeroconf-0.17.5.tar.gz 18428 BLAKE2B b77b0a3c561fd498e59043d8b613ee17f9b9a6ef4f98070d1f2125653017233e12d4a3e87071709981dc67150589d55591b5956fe9661a18d257331662294dfa SHA512 834f8d66bb92232474f60a5137ed7de3788fe1b7109cd5dd2100c3845a89bbb224df060bcb482b0c48b0a5849604247b8f29a902f9c78c35a72497a77f5323b3 | ||
DIST zeroconf-0.19.1.tar.gz 22769 BLAKE2B a63332d70c5610da4fe44cc32d106893241284c3f70b5d6f55f68e3b3dd045a9c39b1009e9dce0b80c836d5ab0693b99974901ee664513c36f34c31907162d46 SHA512 1a7ac803caca1b230eba6c4bcfb714613f218850d9373ea0de609a3c9a509d13acfd14d64f9efbab78637b74aebdf385cf2deded1ff871fc6f3aea4477a07730 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)" | ||
HOMEPAGE="https://github.com/jstasiak/python-zeroconf https://pypi.python.org/pypi/zeroconf" | ||
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
dev-python/netifaces[${PYTHON_USEDEP}] | ||
dev-python/six[${PYTHON_USEDEP}] | ||
virtual/python-enum34[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/nose[${PYTHON_USEDEP}] | ||
)" | ||
|
||
# Not included | ||
RESTRICT="test" | ||
|
||
python_prepare_all() { | ||
# It's virtual/python-enum34 | ||
sed \ | ||
-e "s:'enum-compat',::g" \ | ||
-i setup.py || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
nosetests --verbose || die | ||
} |