Skip to content

Commit

Permalink
dev-perl/Perlbal: EAPI6 + tests
Browse files Browse the repository at this point in the history
- EAPI6ify
- Enable tests
- Convert init scripts into patches to make it easier to tweak
  from eapply_user ( due to a fixed path in ${S} )
- Disable currently failing tests pending more investigation, as
  disabling some known buggy tests is better than disabling *all* tests
  as without *some* tests, we cant' even tell it compiles.

Package-Manager: Portage-2.3.18, Repoman-2.3.6
  • Loading branch information
kentfredric committed Dec 27, 2017
1 parent 4db02b0 commit 85ef5b1
Show file tree
Hide file tree
Showing 2 changed files with 114 additions and 0 deletions.
59 changes: 59 additions & 0 deletions dev-perl/Perlbal/Perlbal-1.800.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_AUTHOR=DORMANDO
DIST_VERSION=1.80
inherit perl-module

DESCRIPTION="Reverse-proxy load balancer and webserver"
HOMEPAGE="http://www.danga.com/perlbal/"

SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="
dev-perl/libwww-perl
dev-perl/HTTP-Date
dev-perl/Sys-Syscall
>=dev-perl/Danga-Socket-1.440.0
dev-perl/HTTP-Message
dev-perl/BSD-Resource
dev-perl/IO-AIO
"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-1.58-Use-saner-name-in-process-listing.patch"
"${FILESDIR}/${PN}-1.80-init-scripts.patch"
)

PERL_RM_FILES=(
# These currently fail for unclear reasons
"t/20-put.t"
"t/31-realworld.t"
"t/32-selector.t"
"t/35-reproxy.t"
"t/40-ranges.t"
)
DIST_TEST="do" # parallel testing broken

src_install() {
perl-module_src_install || die "perl-module_src_install failed"
cd "${S}"
dodoc doc/*.txt
docinto hacking
dodoc doc/hacking/*.txt
docinto conf
dodoc conf/*.{dat,conf}
keepdir /etc/perlbal
newinitd "${S}"/gentoo/init.d/perlbal perlbal
newconfd "${S}"/gentoo/conf.d/perlbal perlbal
}

pkg_postinst() {
einfo "Please see the example configuration files located"
einfo "within /usr/share/doc/${PF}/conf/"
}
55 changes: 55 additions & 0 deletions dev-perl/Perlbal/files/Perlbal-1.80-init-scripts.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
From d942cda4543a68d0b93150fe80428f0b6d72d536 Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <[email protected]>
Date: Sun, 13 May 2007 20:18:36 +1200
Subject: Add init script and configuration

---
gentoo/conf.d/perlbal | 4 ++++
gentoo/init.d/perlbal | 24 ++++++++++++++++++++++++
2 files changed, 28 insertions(+)
create mode 100644 gentoo/conf.d/perlbal
create mode 100755 gentoo/init.d/perlbal

diff --git a/gentoo/conf.d/perlbal b/gentoo/conf.d/perlbal
new file mode 100644
index 0000000..1ddb6e1
--- /dev/null
+++ b/gentoo/conf.d/perlbal
@@ -0,0 +1,4 @@
+# PIDFILE is not yet used, pending upstream still
+#PIDFILE="/var/run/perlbal.pid"
+PERLBAL_OPTS="--daemon --config=/etc/perlbal/perlbal.conf"
+# vim: ft=gentoo-conf-d:
diff --git a/gentoo/init.d/perlbal b/gentoo/init.d/perlbal
new file mode 100755
index 0000000..a3db214
--- /dev/null
+++ b/gentoo/init.d/perlbal
@@ -0,0 +1,24 @@
+#!/sbin/openrc-run
+
+NAME="perlbal"
+BINARY="/usr/bin/perlbal"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting $NAME"
+ # Add --pidfile when upstream supports PIDFILES
+ start-stop-daemon --start \
+ --exec ${BINARY} -- ${PERLBAL_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $NAME"
+ start-stop-daemon --stop --exec "${BINARY}"
+ eend $?
+}
+
+# vim: ft=gentoo-init-d:
--
2.15.1

0 comments on commit 85ef5b1

Please sign in to comment.