Skip to content

Commit

Permalink
net-misc/dhcpcd: version bump
Browse files Browse the repository at this point in the history
  • Loading branch information
williamh committed Sep 4, 2015
1 parent f0cc21a commit 85fce91
Show file tree
Hide file tree
Showing 2 changed files with 121 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/dhcpcd/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST dhcpcd-6.9.0.tar.bz2 176736 SHA256 1566a58ef785880c07762ff6c520e974cf42872be5fbb23b4520f4446b120a68 SHA512 bb02005ff54ad722961208be69f48c61fb72cf56c9ca89348f3e0973e96317b06b4eaf48412ec5e763c9e20bad6f38e06d520048f3412d3bf46716f5dfb671a6 WHIRLPOOL 450b89ff260cfef8e865d1f02b7aa7119d0e37a231d08577545d0091496cee370f5f9c2614e6d5ef2b9a99b412d909d3ed4711c7433b6de085b7dc62df84a4fb
DIST dhcpcd-6.9.1.tar.xz 175656 SHA256 c03b750e1fe2890b62ac0e7d7092a1698b598adb6f88b67916586a619f7c066f SHA512 87ecd54fc94eb3fbebbf87c4037da4767f31ca60718c5fd8cc3dcff4c3294edf7808627ef909120b668f1b767f0d588dddb7c1920a971c86bdc83f72b64e33a3 WHIRLPOOL d8ef71fef224101a785c838ae48fbe440e7b3ca0f07d435d0a9f7a3fef458e28c094b08966ac88a25ec92fbadcfc06a52d55c39f5772427958f715d665cfe0e9
DIST dhcpcd-6.9.2.tar.xz 176240 SHA256 e9f82422a35ad1f4f5f888a433a76e98e3cdd4419886c29ccbfb336eecc58a70 SHA512 9eb9dccdd26d9b088cf1bfdcef0ebcb83b8f18f1058a8ce385c3f69ab30682814215c24fbe5903d6a9ee7b4a5fbc93504949513987525515e1f597183e8b6920 WHIRLPOOL 86788c68d92ce774a96806bdcd03ff624ccf632f9bc5627cab218e63824e4da9d997300453de2d0fe299127880dc6d51a1bc9130246bebb425d32e1315f62455
DIST dhcpcd-6.9.3.tar.xz 176320 SHA256 6089471ed695fa62ac8351466b96b4b6365fd14ec455a120a6524663808eae53 SHA512 0a895f17fa093ac758224bfddad003ee25f81fe96331b1952264c3623018e00048603c9a3c5ba385a93441e987b1ce4cd02ec1f42e1caca2e646a6ac4781c3d9 WHIRLPOOL 6de1622444cf393287abbd469016f3c3cc0a99e6ecc4b781c5b9e0389c899365cfefa46e93d16872e6427517f92ff4750e3a246604562922836ae112dbd4349d
120 changes: 120 additions & 0 deletions net-misc/dhcpcd/dhcpcd-6.9.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,120 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

if [[ ${PV} == "9999" ]]; then
FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
else
MY_P="${P/_alpha/-alpha}"
MY_P="${MY_P/_beta/-beta}"
MY_P="${MY_P/_rc/-rc}"
SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
S="${WORKDIR}/${MY_P}"
fi

inherit eutils systemd toolchain-funcs

DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
LICENSE="BSD-2"
SLOT="0"
IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"

COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"

if [[ ${PV} == "9999" ]]; then
DEPEND+=" dev-vcs/fossil"

src_unpack()
{
local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
local repo=${distdir}/fossil/${PN}.fossil

addwrite "${distdir}"

if [[ -e "${repo}" ]]; then
fossil pull "${FOSSIL_URI}" -R "${repo}" || die
else
mkdir -p "${distdir}/fossil" || die
fossil clone "${FOSSIL_URI}" "${repo}" || die
fi

mkdir -p "${S}" || die
cd "${S}" || die
fossil open "${repo}" || die
}
fi

src_prepare()
{
epatch_user
}

src_configure()
{
local dev hooks rundir
use udev || dev="--without-dev --without-udev"
hooks="--with-hook=ntp.conf"
use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
use kernel_linux && rundir="--rundir=${EPREFIX}/run"
econf \
--prefix="${EPREFIX}" \
--libexecdir="${EPREFIX}/lib/dhcpcd" \
--dbdir="${EPREFIX}/var/lib/dhcpcd" \
--localstatedir="${EPREFIX}/var" \
${rundir} \
$(use_enable embedded) \
$(use_enable ipv6) \
${dev} \
CC="$(tc-getCC)" \
${hooks}
}

src_install()
{
default
newinitd "${FILESDIR}"/${PN}.initd ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
}

pkg_postinst()
{
# Upgrade the duid file to the new format if needed
local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
local new_duid="${ROOT}"/etc/dhcpcd.duid
if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
fi

# Move the duid to /etc, a more sensible location
if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
cp -p "${old_duid}" "${new_duid}"
fi

if [ -z "$REPLACING_VERSIONS" ]; then
elog
elog "dhcpcd has zeroconf support active by default."
elog "This means it will always obtain an IP address even if no"
elog "DHCP server can be contacted, which will break any existing"
elog "failover support you may have configured in your net configuration."
elog "This behaviour can be controlled with the noipv4ll configuration"
elog "file option or the -L command line switch."
elog "See the dhcpcd and dhcpcd.conf man pages for more details."

elog
elog "Dhcpcd has duid enabled by default, and this may cause issues"
elog "with some dhcp servers. For more information, see"
elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
fi

if ! has_version net-dns/bind-tools; then
elog
elog "If you activate the lookup-hostname hook to look up your hostname"
elog "using the dns, you need to install net-dns/bind-tools."
fi
}

0 comments on commit 85fce91

Please sign in to comment.