forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-java/owasp-java-encoder: add 1.3.0
Signed-off-by: Volkmar W. Pogatzki <[email protected]> Closes: gentoo@bbed781 Signed-off-by: Miroslav Šulc <[email protected]>
- Loading branch information
Showing
2 changed files
with
31 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST owasp-java-encoder-1.2.3.tar.gz 134303 BLAKE2B 76b9652863fcdfdce82bd26062fa500bb92b21ba6edff7b3f409a1375e135176f826dca4bb02b4dd48905112ae20a0af0a1f09cb4e21ea41c672a44c52fea209 SHA512 19c13894ce68325553bdbee41190cb113d698c79ec74885604fd9db4f083efe0fcdc4313b7191014bfd972d0ee52f0fbe0621d7bb407745bd1feeb2ac9e49783 | ||
DIST owasp-java-encoder-1.3.0.tar.gz 150029 BLAKE2B 31e350f02a7374f809e435d90ee9b4b1424cd9cb2da7d4062dfe0fc5898e02623496e464483bafd550b82b926260ab4df918f9be776e47f66587c6bc3829ebba SHA512 0ccdd6ae63e657ee28a4d9de7664269eff57802bddb03c7163fdb27326668256573d995b0111dc83cc1e5a6acc247e03da443f4b34c08cf99b085ec0a383a439 |
30 changes: 30 additions & 0 deletions
30
dev-java/owasp-java-encoder/owasp-java-encoder-1.3.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
# Copyright 2023-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
JAVA_PKG_IUSE="doc source test" | ||
MAVEN_ID="org.owasp.encoder:encoder:${PV}" | ||
JAVA_TESTING_FRAMEWORKS="junit-4" | ||
|
||
inherit java-pkg-2 java-pkg-simple | ||
|
||
DESCRIPTION="OWASP Java Encoder" | ||
HOMEPAGE="https://owasp.org/www-project-java-encoder/" | ||
SRC_URI="https://github.com/OWASP/owasp-java-encoder/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/${P}/core" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
DEPEND=">=virtual/jdk-1.8:*" | ||
RDEPEND=">=virtual/jre-1.8:*" | ||
|
||
# skipping 10 tests because kinda unpredictable as it expects that it cannot | ||
# surpass a predefined value, which in some case obviously doesn't work. | ||
JAVA_RM_FILES=( src/test/java/org/owasp/encoder/BenchmarkTest.java ) | ||
JAVA_SRC_DIR="src/main/java" | ||
JAVA_TEST_GENTOO_CLASSPATH="junit-4" | ||
JAVA_TEST_RESOURCE_DIRS="src/test/resources" | ||
JAVA_TEST_SRC_DIR="src/test/java" |