Skip to content

Commit

Permalink
dev-libs/girara: Version bump (v0.3.5)
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.5, Repoman-3.0.1
Signed-off-by: Felix Neumärker <[email protected]>
Closes: gentoo#17543
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
xdch47 authored and thesamesam committed Sep 16, 2020
1 parent 969c260 commit 8632436
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/girara/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST girara-0.3.3.tar.gz 72372 BLAKE2B 59171e104f1558ed794e1bb623bb5121007af0cf831524fac5170ce8e55d939d19ecb747b7bc4bb900e978d29fd987d592a0e16982a248adc5b085503ccb2b43 SHA512 2764f339c4b5744330c60fa5c8c902a06952d6c5a38589d236fe290f9934b9128527658d8aa99d42806255403b90f55ea1a85e5bd09da4b3a8f7c48be4d94f51
DIST girara-0.3.4.tar.gz 72981 BLAKE2B 690b8de0e906e43e32b7a1009a04d4bb1d5b029924ea5b85491ec740ba4b4363f8729bd9b8498f1f25309e2eabde6868f41a689ed06dfb6aa36b081676232624 SHA512 1eca68f4f28505d897c2f7cfb8804e67591e8327feb347c66da216d8f764cb0c88028d1c4c162579a882df7db1883b834c97d8488296ea5c0a8f709dfcea1f1a
DIST girara-0.3.5.tar.xz 60488 BLAKE2B 2d0f2f0635e8e8906810b1425191f5d70b7f9af0985c461bd90654e83d87ad698da225d70064438fed4473295aca8dbd26c4ce1efd96f8a7399e7145b1f8c111 SHA512 e7c5bf887b29767878502224ad45d62e43b3da91bd8e754603256550d4f0126f1493f0fb7473a4ebb8cc5909306564249c6a60e99eba2b0b417b98c728fcdc84
46 changes: 46 additions & 0 deletions dev-libs/girara/girara-0.3.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson virtualx

DESCRIPTION="UI library that focuses on simplicity and minimalism"
HOMEPAGE="https://pwmt.org/projects/girara/"

if [[ ${PV} == *999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
EGIT_BRANCH="develop"
else
SRC_URI="https://pwmt.org/projects/girara/download/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi

LICENSE="ZLIB"
SLOT="0"
IUSE="doc libnotify test"

RESTRICT="!test? ( test )"

DEPEND="dev-libs/glib:2
dev-libs/json-c:=
>=x11-libs/gtk+-3.20:3
libnotify? ( x11-libs/libnotify )"
RDEPEND="${DEPEND}"
BDEPEND="doc? ( app-doc/doxygen )
test? ( dev-libs/check )
virtual/pkgconfig"

src_configure() {
local emesonargs=(
-Djson=enabled
-Ddocs=$(usex doc enabled disabled)
-Dnotify=$(usex libnotify enabled disabled)
)
meson_src_configure
}

src_test() {
virtx meson_src_test
}

0 comments on commit 8632436

Please sign in to comment.