forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-perl/Test-Pod-Coverage: Bump to version 1.100.0
- EAPI6 - Unwanted test/dep cleanup - Update LICENSE to "Artistic-2" Upstream: - Update license - Fix tests - doc patches Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
- Loading branch information
1 parent
972a2e7
commit 865a05d
Showing
2 changed files
with
27 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST Test-Pod-Coverage-1.08.tar.gz 6418 SHA256 e06336c3eb7d0f37605934b983ececf2782c78dda04ffdb96c7dc12f466a5578 SHA512 fe42fd3a12555ce95f06c345ab5f5a333263b29b313d3ed45114aee4215373959c4ee079f3eed0f97c8ec7454f6b5f2c76e4a246eb036fc583858b5be95e03ab WHIRLPOOL d853d0ae027d5a89e1ec431e8e0eadc2466f05e23eca04dc79fc91c7dffae9c7ff7ab61b7576380c4888d8bc8e8dab84bc763d4991885bab2f76e1c1f6005e38 | ||
DIST Test-Pod-Coverage-1.10.tar.gz 8083 SHA256 48c9cca9f7d99eee741176445b431adf09c029e1aa57c4703c9f46f7601d40d4 SHA512 ebcebb900f4367984245d1915937200e2de8586a6e6ea9c9b71588e56caf68808ee73c21e633434ab5c43b80b42dd56cb0cbd4e67519e928270e1eda06c1d02c WHIRLPOOL ddd407f6323a335821950c7b7520ab1bbf642cedc48e33f2e882cc29ecf0b40ef13cc435d28b60ec16c2ef452c984aeed92858dd755d84a75daf4d70a52372ac |
26 changes: 26 additions & 0 deletions
26
dev-perl/Test-Pod-Coverage/Test-Pod-Coverage-1.100.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=NEILB | ||
DIST_VERSION=1.10 | ||
inherit perl-module | ||
|
||
DESCRIPTION="Check for pod coverage in your distribution" | ||
LICENSE="Artistic-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
virtual/perl-Test-Simple | ||
dev-perl/Pod-Coverage" | ||
DEPEND="${RDEPEND} | ||
virtual/perl-ExtUtils-MakeMaker" | ||
|
||
src_test() { | ||
perl_rm_files t/pod.t | ||
perl-module_src_test | ||
} |