Skip to content

Commit

Permalink
app-i18n/fbterm: update to EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
hattya committed Aug 5, 2017
1 parent c70e17d commit 868f612
Show file tree
Hide file tree
Showing 2 changed files with 32 additions and 32 deletions.
53 changes: 25 additions & 28 deletions app-i18n/fbterm/fbterm-1.7-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,60 +1,57 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
inherit autotools-utils
EAPI="6"

inherit autotools

DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
HOMEPAGE="https://fbterm.googlecode.com/"
SRC_URI="https://fbterm.googlecode.com/files/${P}.0.tar.gz"
SRC_URI="https://${PN}.googlecode.com/files/${P}.0.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="caps gpm video_cards_vesa"

RDEPEND="caps? ( sys-libs/libcap )
RDEPEND="media-libs/fontconfig
media-libs/freetype:2
caps? ( sys-libs/libcap )
gpm? ( sys-libs/gpm )
video_cards_vesa? ( dev-libs/libx86 )
media-libs/fontconfig
media-libs/freetype:2"
video_cards_vesa? ( dev-libs/libx86 )"
DEPEND="${RDEPEND}
sys-libs/ncurses
virtual/pkgconfig"

AUTOTOOLS_IN_SOURCE_BUILD=1
PATCHES=( "${FILESDIR}"/${PN}-gcc6.patch )

DOCS=( AUTHORS NEWS README )
src_prepare() {
sed -i "s|tic|tic -o '\$(DESTDIR)\$(datadir)/terminfo'|" terminfo/Makefile.am

PATCHES=(
"${FILESDIR}"/${PN}-gcc6.patch
)
default
eautoreconf
}

src_configure() {
local myeconfargs=(
$(use_enable gpm)
econf \
$(use_enable gpm) \
$(use_enable video_cards_vesa vesa)
)
autotools-utils_src_configure
}

src_install() {
autotools-utils_src_install
$(type -P tic) -o "${ED}/usr/share/terminfo/" \
"${S}"/terminfo/fbterm || die "Failed to generate terminfo database"
default

if use caps; then
setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/fbterm
setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/${PN}
else
fperms u+s /usr/bin/fbterm
fperms u+s /usr/bin/${PN}
fi
}

pkg_postinst() {
einfo
einfo " ${PN} won't work with vga16fb. You have to use other native"
einfo " framebuffer drivers or vesa driver."
einfo " See ${EPREFIX}/usr/share/doc/${P}/README for details."
einfo " To use ${PN}, ensure you are in video group."
einfo " To input CJK merge app-i18n/fbterm-ucimf"
einfo
elog "${PN} won't work with vga16fb. You have to use other native"
elog "framebuffer drivers or vesa driver."
elog "See ${EPREFIX}/usr/share/doc/${P}/README for details."
elog
elog "To use ${PN}, ensure you are in video group."
}
11 changes: 7 additions & 4 deletions app-i18n/fbterm/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Cjk</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Cjk</name>
</maintainer>
<upstream>
<remote-id type="google-code">fbterm</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 868f612

Please sign in to comment.