Skip to content

Commit

Permalink
dev-python/oauth2client: version bump to 2.0.2
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Apr 21, 2016
1 parent 62e2a92 commit 86ba707
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/oauth2client/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST oauth2client-1.4.6.tar.gz 95325 SHA256 d4376fc0f5543612c62cdee5ea68530bd9c8
DIST oauth2client-1.5.1.tar.gz 130237 SHA256 3e4ad7b3399cd9c4b8785acbbba2ca55eaefef17989f784352d2386776bf17c5 SHA512 ad228264b93ec23bfb4bbc9614a980172e3c763adde12e0b050166ccd49eece1d2464a078884ed16cbaea60a7bf88784a22314382073e360f1ec591b19a2da2f WHIRLPOOL 963b9518944dc081fdd3c32f1c6a12527a567f2c762355b109cee01b1cb1c1c35d85301bd2df6e47d2d11ac1e5b6c6a2bbc59098c10baa75ea2574567617f7ec
DIST oauth2client-1.5.2.tar.gz 131665 SHA256 b8df20b122e4f49a5fe5bc3c825d16015f5012c171c6c81eb4048e4d8c2ffee3 SHA512 15f10b52aa93fc10289658d5ff671a247e5c92c5ff2be424a04617fee1a3a82439b829b0f5dcb04e3e84802e02580e366e08356df7ec6e24563a530d2f6b1db5 WHIRLPOOL 00f3033359eceda12528ef4caffc0a9d7d6561919272fe98e09d2599114f07d9be42eb32a4038c155c621581f98ecc0eb516bcaa018d4376e30906dd4a0adfbc
DIST oauth2client-2.0.1.tar.gz 153127 SHA256 fa0357fca4ce431073ead236256347aafe3d368c16c5edaeba7f826b1b1d5fb6 SHA512 66179a604418a8aee9ca9dbfc5ad18356d5130a588e85f4dab3330feef194af2114bc2eb18ec625acf791938e4d7f78ee55284f45a67a48c775676697ce2b183 WHIRLPOOL bef0f7394cbeade328f74288bd602973a7828915ff616c7331d6c1910be02bc74a8e11062bd0602a2c4f1681d7d8c6558aecd695df3ef711f74ba81fad0b1ab3
DIST oauth2client-2.0.2.tar.gz 164190 SHA256 f1e7f1453714a3861ca0827959e507160ba065503f17d49f5a84c5eb47b86514 SHA512 ef8c81fe7f0d254c71a15115be58787bbf771b824e988b56ba9561c58b4726b03b4fce1b8c8f50c971236c558b0205fff11b949f7b70fcf749f3eb210c8dab0b WHIRLPOOL 5958b658e8af39ee7789b268b1d091489bbd1aa08bf5ede58c49492e05092e25a9907b594238e54526dabfa5acfcfe024f9926bbb9ec52cb975766b4e34847c9
46 changes: 46 additions & 0 deletions dev-python/oauth2client/oauth2client-2.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy)

inherit distutils-r1

DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
HOMEPAGE="https://github.com/google/oauth2client"
SRC_URI="https://github.com/google/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

RDEPEND="
>=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
>=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
>=dev-python/six-1.6.1[${PYTHON_USEDEP}]
!<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"

S="${WORKDIR}"/${P/_p/-post}

# Needs network
RESTRICT=test

python_prepare_all() {
sed \
-e "s:find_packages():find_packages(exclude=['tests','tests.*']):" \
-i setup.py || die
distutils-r1_python_prepare_all
}

python_test() {
nosetests || die
}

0 comments on commit 86ba707

Please sign in to comment.