Skip to content

Commit

Permalink
dev-ruby/actionpack: add 6.1.7
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Oct 2, 2022
1 parent 9cb25b8 commit 86bb2ff
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/actionpack/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
DIST rails-5.2.8.1.tgz 8848345 BLAKE2B 6786359e6c519e98079dc6f87a1ad23a69e7b65d2e688e9f09bd446012a18e76173d2997c125dd0260ece78114be9462d8c3dfb3464c6428734377f793828a9f SHA512 05e3bd1fb50c87ba31d47d99748b2edafa2e58dbf4e0c4ee991b7c65e68abbbc794d8f385836fa1fddcd277f78edeb1f9c2d675c1c53403c1f230593a8bd2c71
DIST rails-6.0.5.1.tgz 18607954 BLAKE2B 74f75399a287f1eae199a5764c952b75dd95a02c88899ade69d60acae00a7588b2f3a8ab3b9d2c9224d62f87305c596e16b196a5c32b19731d4415f17a29d38e SHA512 a65c3fab39eadba75e0107486c82a4da212e612ddb2350f77bb00ad887e0b52980edba08d42c02801c4e4fd71d750de3dbd78c820ef050016867737dccc06b36
DIST rails-6.1.6.1.tgz 11028264 BLAKE2B 568033eb816613ba0ba5f2df38e6a30158b2e31ef4d4da151f8c0de2934b07736833026793ce9192994d9ef2a2a45b67735a35760c1be8b8a68c1968147cc6db SHA512 04acf9dbf5ee734636aada67be001690899eb13f73ea688455fcaee8cbf4839aedf06943c8adb5eecf13fd9a5f6be1a225310aa481d3a254172fd0ce0402362f
DIST rails-6.1.7.tgz 11038670 BLAKE2B fd25884a6f58f10387f1f89ffd39caad337d7a3af6902f9ccdcf4eb108f9355124b6e1004d8b8f2b625ac7d9cfcd8635e7668101a1cba5d866a5fbe1b691e6e2 SHA512 7d56f604fbc2fb83a2e3a4ee070f55fb285018a48584115e0bf19982553eb5b78a173a5adbf1879e88c0739bea9dccc66879646da5c0b141b24f1500e1bdcb5f
DIST rails-7.0.3.1.tgz 11049683 BLAKE2B 31aa9c20b4add7e11b832aff57fcf78284b7f28e71cfc71b5769c65170f1fff3f33d73224bbfa826852a59aac30671ff7c3ef19cbe0aaabc8528a805c6b98e8a SHA512 2ad615df9e019193489d5ce82152fd0ff12d8435401258b2b8a87d1c5da46587cdd45dc483847891f7b8be1d019b09b77a48fa7849d5260ee6fdbbf6df64ef03
DIST rails-7.0.4.tgz 11061225 BLAKE2B 9c520766f936c82ae9ee943c3db0ad575d7fc59aea947fb2790cf511188fbd33166a62332564c4714372203f5fabdde842334103b48f4115c31f5d0fe18375f1 SHA512 118035226054ad5083d2affde55a812917652491f82a9a578380a790770fdda3a14904f6de10f58651bbbab278aa23920b652aa1b34c71441d465c3b7b4be82c
71 changes: 71 additions & 0 deletions dev-ruby/actionpack/actionpack-6.1.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

USE_RUBY="ruby27 ruby30 ruby31"

RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem

DESCRIPTION="Eases web-request routing, handling, and response"
HOMEPAGE="https://github.com/rails/rails"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
~dev-ruby/activesupport-${PV}
~dev-ruby/actionview-${PV}
dev-ruby/rack:2.2
>=dev-ruby/rack-test-0.6.3:*
>=dev-ruby/rails-html-sanitizer-1.2.0:1
dev-ruby/rails-dom-testing:2
"

ruby_add_bdepend "
test? (
dev-ruby/mocha:0.14
dev-ruby/bundler
>=dev-ruby/capybara-2.15
~dev-ruby/activemodel-${PV}
~dev-ruby/railties-${PV}
>=dev-ruby/rack-cache-1.2:1.2
www-servers/puma
<dev-ruby/minitest-5.16:5
)"

all_ruby_prepare() {
eapply "${FILESDIR}/actionpack-7.0.4-rack-test-2.patch"

# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
rm ../Gemfile.lock || die

sed -i -e '3igem "railties", "~> 6.1.0"; gem "activerecord", "~> 6.1.0"' test/abstract_unit.rb || die

# Use different timezone notation, this changed at some point due to an external dependency changing.
sed -i -e 's/-0000/GMT/' test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die

# Avoid tests depending on an unreleased version of selenium-webdriver
sed -i -e '/define extra capabilities/,/^ end/ s:^:#:' test/dispatch/system_testing/driver_test.rb || die

# Avoid tests with rack-cache since it is not ready for ruby31
# >=dev-ruby/rack-cache-1.2:1.2
rm -f test/dispatch/rack_cache_test.rb || die
}

0 comments on commit 86bb2ff

Please sign in to comment.