Skip to content

Commit

Permalink
dev-tex/tex4ht: Sync from TeX Live 2021
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Ulrich Müller <[email protected]>
  • Loading branch information
ulm committed Apr 25, 2021
1 parent 1502e7c commit 86db49e
Show file tree
Hide file tree
Showing 2 changed files with 126 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-tex/tex4ht/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST tex4ht-1.0.2009_06_11_1038.tar.gz 2576719 BLAKE2B d04fd7b5f614414a200b01f11bea9880ea12561873fc08cb2f5f6f62167d6128cc50abbeeee0c7eae5d80046f6d3b504493d66262153c5a534fd1b56bfa1dfcd SHA512 868961c16da63ef20a8af3ec3e56a2b6c518a291cdbc3974f701773dbb55b844f0df06aae4c7b481c96b9e2ba29cb0f1ed1279b6f32340e4708e31bb67170963
DIST tex4ht-texlive-2019-03-22.tar.xz 868992 BLAKE2B 662cc23de1b3b5f4e3d504655b5b3d87740fea045bef7987cbe2d81971e73375bd88d8ab111d48878ce1fe9d1eece4e4003e443ed0bc0f9b643b7e1653a5fc8c SHA512 44d9e2c4f92ae1ea1d7f14432d7fe1a9f11b30ec8602d55c4b8f3f46283671fb75b08641c8170bd46918e16db1bed696a613a0518acd4e195e173fe12e386833
DIST tex4ht-texlive-2020-06-24.tar.xz 880952 BLAKE2B d021efca48571711d06d7ed6ecefce068339a49fa83efeaa476329d892a77f73b27273a711dad2cb7ce212ece87ef8a776a10127cec5dc2e0096ce36adbc42a4 SHA512 b6109d27fd38eb0f2f9aab8b96adee2e69081c7317de3c9f527e47053d1520b93c0499e23fdc66f38f04c50633f72930e4fdf5d07612894427ae31dcbc1f66d4
DIST tex4ht-texlive-20210423.tar.xz 906180 BLAKE2B 7592380e798385471f3b9675deb557a100650749a58a2724d366cfe8ad9fb4b2d2a678265b5d2166905c4cc9f52e92ef722085cc39df167c7c23f4926a619b49 SHA512 7131a62f9ecbeeb3afbc97f465b20b5bc5c57bdade9d07772661607f5f43fb0ef67f42630fceee8d5988872b158efe1dd99bb220c1e7cd9e936f71feab036888
125 changes: 125 additions & 0 deletions dev-tex/tex4ht/tex4ht-20090611_p1038_p20210423.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,125 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit latex-package toolchain-funcs java-pkg-opt-2 flag-o-matic readme.gentoo-r1

# tex4ht-20050331_p2350 -> tex4ht-1.0.2005_03_31_2350
MY_P="${PN}-1.0.${PV:0:4}_${PV:4:2}_${PV:6:2}_$(ver_cut 3)"

# from https://mirrors.ctan.org/systems/texlive/tlnet/archive/tex4ht.tar.xz
MY_P_TEXLIVE="${PN}-texlive-$(ver_cut 5)"

DESCRIPTION="Converts (La)TeX to (X)HTML, XML and OO.org"
HOMEPAGE="http://www.cse.ohio-state.edu/~gurari/TeX4ht/
http://www.cse.ohio-state.edu/~gurari/TeX4ht/bugfixes.html"
SRC_URI="http://www.cse.ohio-state.edu/~gurari/TeX4ht/fix/${MY_P}.tar.gz
https://dev.gentoo.org/~ulm/distfiles/${MY_P_TEXLIVE}.tar.xz"

LICENSE="LPPL-1.2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="java"

RDEPEND="app-text/ghostscript-gpl
media-gfx/imagemagick
dev-libs/kpathsea
java? ( >=virtual/jre-1.5 )"

DEPEND="dev-libs/kpathsea"

BDEPEND="virtual/pkgconfig
java? ( >=virtual/jdk-1.5 )"

S="${WORKDIR}/${MY_P}"

src_prepare() {
cp -a "${WORKDIR}/texmf-dist/"* texmf/ || die
default
cd "${S}/texmf/tex4ht/base/unix" || die
sed -i \
-e "s#~/tex4ht.dir#${EPREFIX}/usr/share#" \
-e "s#tpath/tex/texmf/fonts/tfm/!#t${EPREFIX}/usr/share/texmf-dist/fonts/tfm/!\nt${EPREFIX}/usr/local/share/texmf/fonts/tfm/!\nt${EPREFIX}/var/cache/fonts/tfm/!\nt${EPREFIX}${TEXMF}/fonts/tfm/!#" \
-e "s#%%~#${EPREFIX}${TEXMF}#g" \
-e "s#/usr/share/texmf/#${EPREFIX}${TEXMF}/#" \
tex4ht.env \
|| die "sed of tex4ht.env failed"

einfo "Removing precompiled java stuff"
find "${S}" '(' -name '*.class' -o -name '*.jar' ')' -print -delete || die
}

src_compile() {
has_version '>=dev-libs/kpathsea-6.2.1' \
&& append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"

cd "${S}/src" || die
einfo "Compiling postprocessor sources..."
for f in tex4ht t4ht; do
$(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o $f $f.c \
-DENVFILE="\"${EPREFIX}${TEXMF}/tex4ht/base/tex4ht.env\"" \
-DHAVE_DIRENT_H -DKPATHSEA -lkpathsea \
|| die "Compiling $f failed"
done
if use java; then
einfo "Compiling java files..."
cd java || die
ejavac *.java */*.java */*/*.java -d ../../texmf/tex4ht/bin
cd "${S}/texmf/tex4ht/bin" || die
# Create the jar needed by oolatex
jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
fi
}

src_install() {
# install the binaries
dobin "${S}/src/tex4ht" "${S}/src/t4ht"
# install the scripts
if ! use java; then
rm -f "${S}"/bin/unix/oo*
rm -f "${S}"/bin/unix/jh*
fi
dobin "${S}"/bin/unix/mk4ht

# install the .4ht scripts
insinto ${TEXMF}/tex/generic/tex4ht
doins "${S}"/texmf/tex/generic/tex4ht/*

# install the special htf fonts
insinto ${TEXMF}/tex4ht
doins -r "${S}/texmf/tex4ht/ht-fonts"

if use java; then
# install the java files
doins -r "${S}/texmf/tex4ht/bin"
java-pkg_jarinto ${TEXMF}/tex4ht/bin
java-pkg_dojar "${S}/${PN}.jar"
fi

# install the .4xt files
doins -r "${S}/texmf/tex4ht/xtpipes"

# install the env file
insinto ${TEXMF}/tex4ht/base
newins "${S}/texmf/tex4ht/base/unix/tex4ht.env" tex4ht.env

insinto /etc/texmf/texmf.d
doins "${FILESDIR}/50tex4ht.cnf"

insinto ${TEXMF}/tex/generic/${PN}
insopts -m755
doins "${S}"/bin/ht/unix/*

local DOC_CONTENTS="In order to avoid collisions with multiple packages,
we are not installing the scripts in /usr/bin any more.
If you want to use, say, htlatex, you can use 'mk4ht htlatex file'."
use java || DOC_CONTENTS+="\n\nODF converters (oolatex & friends)
require the java use flag."
readme.gentoo_create_doc
}

pkg_postinst() {
latex-package_pkg_postinst
readme.gentoo_print_elog
}

0 comments on commit 86db49e

Please sign in to comment.