Skip to content

Commit

Permalink
x11-libs/snorenotify: Fix desktop files
Browse files Browse the repository at this point in the history
Revision bump adds upstream patch spotted by Coacher
<[email protected]>.

Gentoo-bug: 588756

Package-Manager: portage-2.3.0
  • Loading branch information
johu committed Jul 15, 2016
1 parent d3ab6ee commit 86f0ca5
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
41 changes: 41 additions & 0 deletions x11-libs/snorenotify/files/snorenotify-0.7.0-desktop.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
From 897a64b18f8727c951dac8ca91ebf43f2c18f908 Mon Sep 17 00:00:00 2001
From: Javier Llorente <[email protected]>
Date: Sat, 13 Feb 2016 12:20:03 +0100
Subject: [PATCH] Fix desktop categories, remove version (see
desktop-entry-spec), add a newline at eof

---
src/daemon/snorenotify.desktop.in | 3 +--
src/settings/snoresettings.desktop.in | 3 +--
2 files changed, 2 insertions(+), 4 deletions(-)

diff --git a/src/daemon/snorenotify.desktop.in b/src/daemon/snorenotify.desktop.in
index 83f0e3f..9fc1876 100644
--- a/src/daemon/snorenotify.desktop.in
+++ b/src/daemon/snorenotify.desktop.in
@@ -1,8 +1,7 @@
[Desktop Entry]
Type=Application
-Version=@SNORE_VERSION_MAJOR@.@SNORE_VERSION_MINOR@.@SNORE_VERSION_PATCH@
Name=SnoreNotify
Comment=A daemon redirecting desktop notifications to one or multiple additional backends.
Icon=snore
Exec=snorenotify
-Categories=Qt;System;
\ No newline at end of file
+Categories=Qt;Settings;Qt;Utility;DesktopSettings;
diff --git a/src/settings/snoresettings.desktop.in b/src/settings/snoresettings.desktop.in
index 823bb2d..497d119 100644
--- a/src/settings/snoresettings.desktop.in
+++ b/src/settings/snoresettings.desktop.in
@@ -1,8 +1,7 @@
[Desktop Entry]
Type=Application
-Version=@SNORE_VERSION_MAJOR@.@SNORE_VERSION_MINOR@.@SNORE_VERSION_PATCH@
Name=SnoreSettings
Comment=Settings client for applications using libsnore.
Icon=snore
Exec=snoresettings
-Categories=Qt;System;
\ No newline at end of file
+Categories=Qt;Settings;Qt;Utility;DesktopSettings;
59 changes: 59 additions & 0 deletions x11-libs/snorenotify/snorenotify-0.7.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit cmake-utils gnome2-utils virtualx

DESCRIPTION="Multi platform Qt notification framework"
HOMEPAGE="https://techbase.kde.org/Projects/Snorenotify"
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"

LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="sound test"

RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwebsockets:5
dev-qt/qtwidgets:5
sound? ( dev-qt/qtmultimedia:5 )
"
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
kde-frameworks/extra-cmake-modules
test? ( dev-qt/qttest:5 )
"

PATCHES=( "${FILESDIR}/${P}-desktop.patch" )

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package sound Qt5Multimedia)
$(cmake-utils_use_find_package test Qt5Test)
)

cmake-utils_src_configure
}

src_test() {
virtx cmake-utils_src_test
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 86f0ca5

Please sign in to comment.