Skip to content

Commit

Permalink
games-action/armagetronad: add 0.2.9.2.3
Browse files Browse the repository at this point in the history
Signed-off-by: Michael Mair-Keimberger <[email protected]>
Closes: gentoo#37885
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
mm1ke authored and chewi committed Aug 2, 2024
1 parent 68804c5 commit 86f9bf5
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-action/armagetronad/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST armagetronad-0.2.9.1.0.tbz 1943758 BLAKE2B ed4ecef19125d69faf402829b88288124dd364eafc836be3848727c2bfbd87ca29e18b48448dc868fb995947b2daae150c3b9f5dcf048d0d90d442f5bcf425f0 SHA512 8c2b9cba7d480dec6d7d60984327a5d45c8c87b968fb81a1e192973e6826ddb66c8d41ca82bb04d80da5c6fa2152d19dd890957dabc6cc5ce2d4dffbc45d1f65
DIST armagetronad-0.2.9.2.3.tbz 1834233 BLAKE2B 9b7d09ca7952ffe67a50be01c44adef81640e8cf222158477f66487ea89c7b25e1675bb9308ba71023ce045a4ea739891ce2273d5aa017cef2fa81128c71774c SHA512 813911a75fa1b3a90d99d62c0c38e9b325166623280c0d6a8217f8ca905b4a4617401db12bda898d82aa086a1bd673b31741b95b60b0f1247e6a5677a48c98eb
64 changes: 64 additions & 0 deletions games-action/armagetronad/armagetronad-0.2.9.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools desktop

DESCRIPTION="Fast-paced 3D lightcycle game based on Tron"
HOMEPAGE="https://www.armagetronad.org/"
SRC_URI="https://launchpad.net/armagetronad/$(ver_cut 1-3)/${PV}/+download/armagetronad-${PV}.tbz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dedicated sound"

RDEPEND="
dev-libs/libxml2
!dedicated? (
media-libs/libpng:0=
media-libs/libsdl[X,opengl,video,sound?]
media-libs/sdl-image[jpeg,png]
virtual/glu
virtual/opengl
sound? ( media-libs/sdl-mixer )
)"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}"/${PN}-0.2.9.1.0-AR.patch
)

src_prepare() {
default

eautoreconf
}

src_configure() {
local econfargs=(
$(use_enable dedicated)
$(use_enable sound music)
# following options only mess with paths and users
--disable-games
--disable-sysinstall
--disable-uninstall
--disable-useradd
)
econf ${econfargs[@]}
}

src_install() {
# long history of being broken without -j1 (bug #330705,698020)
# do not remove (again) without a proper fix or extensive tests
emake -j1 DESTDIR="${D}" install
einstalldocs

# handle misplaced .desktop / icons
if ! use dedicated; then
rm -r "${ED}"/usr/share/${PN}/desktop || die
doicon desktop/icons/48x48/armagetronad.png
make_desktop_entry ${PN}
fi
}

0 comments on commit 86f9bf5

Please sign in to comment.