Skip to content

Commit

Permalink
app-emulation/libvirt: Do not create qemu user if USE=-qemu, bug #601678
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.0, Repoman-2.3.1
  • Loading branch information
tamiko committed Jan 22, 2017
1 parent 5409644 commit 875198b
Show file tree
Hide file tree
Showing 5 changed files with 18 additions and 48 deletions.
14 changes: 4 additions & 10 deletions app-emulation/libvirt/libvirt-1.3.5-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -125,15 +125,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"

pkg_setup() {
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"

# Some people used the masked ebuild which was not adding the qemu
# user to the kvm group originally. This results in VMs failing to
# start for some users. bug #430808
egetent group kvm | grep -q qemu
if [[ $? -ne 0 ]]; then
gpasswd -a qemu kvm
if use qemu; then
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"
fi

# Check kernel configuration:
Expand Down
14 changes: 4 additions & 10 deletions app-emulation/libvirt/libvirt-2.1.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -124,15 +124,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"

pkg_setup() {
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"

# Some people used the masked ebuild which was not adding the qemu
# user to the kvm group originally. This results in VMs failing to
# start for some users. bug #430808
egetent group kvm | grep -q qemu
if [[ $? -ne 0 ]]; then
gpasswd -a qemu kvm
if use qemu; then
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"
fi

# Check kernel configuration:
Expand Down
14 changes: 4 additions & 10 deletions app-emulation/libvirt/libvirt-2.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -124,15 +124,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"

pkg_setup() {
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"

# Some people used the masked ebuild which was not adding the qemu
# user to the kvm group originally. This results in VMs failing to
# start for some users. bug #430808
egetent group kvm | grep -q qemu
if [[ $? -ne 0 ]]; then
gpasswd -a qemu kvm
if use qemu; then
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"
fi

# Check kernel configuration:
Expand Down
12 changes: 3 additions & 9 deletions app-emulation/libvirt/libvirt-2.5.0-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -130,15 +130,9 @@ PATCHES=(
)

pkg_setup() {
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"

# Some people used the masked ebuild which was not adding the qemu
# user to the kvm group originally. This results in VMs failing to
# start for some users. bug #430808
egetent group kvm | grep -q qemu
if [[ $? -ne 0 ]]; then
gpasswd -a qemu kvm
if use qemu; then
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"
fi

# Check kernel configuration:
Expand Down
12 changes: 3 additions & 9 deletions app-emulation/libvirt/libvirt-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -130,15 +130,9 @@ PATCHES=(
)

pkg_setup() {
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"

# Some people used the masked ebuild which was not adding the qemu
# user to the kvm group originally. This results in VMs failing to
# start for some users. bug #430808
egetent group kvm | grep -q qemu
if [[ $? -ne 0 ]]; then
gpasswd -a qemu kvm
if use qemu; then
enewgroup qemu 77
enewuser qemu 77 -1 -1 "qemu,kvm"
fi

# Check kernel configuration:
Expand Down

0 comments on commit 875198b

Please sign in to comment.